summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-08-05 13:49:18 -0500
committerAustin English <wizardedit@gentoo.org>2016-08-05 14:43:17 -0500
commit89e172db0aa6b6d1d30e4c509286dd27647827e4 (patch)
tree2a8ab6fa9930dd4367ad5ab51d394c21df0f4b6b /games-mud
parentsys-fs/multipath-tools: version bump (diff)
downloadgentoo-89e172db0aa6b6d1d30e4c509286dd27647827e4.tar.gz
gentoo-89e172db0aa6b6d1d30e4c509286dd27647827e4.tar.bz2
gentoo-89e172db0aa6b6d1d30e4c509286dd27647827e4.zip
games-mud/crystal: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-mud')
-rw-r--r--games-mud/crystal/crystal-0.2.4-r1.ebuild41
-rw-r--r--games-mud/crystal/files/crystal-0.2.4-build.patch8
-rw-r--r--games-mud/crystal/files/crystal-0.2.4-gcc43.patch4
3 files changed, 47 insertions, 6 deletions
diff --git a/games-mud/crystal/crystal-0.2.4-r1.ebuild b/games-mud/crystal/crystal-0.2.4-r1.ebuild
new file mode 100644
index 000000000000..0fa260d972f3
--- /dev/null
+++ b/games-mud/crystal/crystal-0.2.4-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="The crystal MUD client"
+HOMEPAGE="http://www.evilmagic.org/crystal/"
+SRC_URI="http://www.evilmagic.org/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/openssl:0=
+ sys-libs/ncurses:0=
+ sys-libs/zlib
+ virtual/libiconv"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-build.patch
+)
+
+src_prepare() {
+ default
+
+ # avoid colliding with xscreensaver (bug #281191)
+ mv crystal.6 crystal-mud.6 || die
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-scripting
+}
diff --git a/games-mud/crystal/files/crystal-0.2.4-build.patch b/games-mud/crystal/files/crystal-0.2.4-build.patch
index 147447f3c9a8..1f8917e4056d 100644
--- a/games-mud/crystal/files/crystal-0.2.4-build.patch
+++ b/games-mud/crystal/files/crystal-0.2.4-build.patch
@@ -1,5 +1,5 @@
---- configure.in
-+++ configure.in
+--- a/configure.in
++++ b/configure.in
@@ -31,7 +31,9 @@
AC_PROG_CXX
AC_CHECK_FUNCS(select socket strerror strstr)
@@ -11,8 +11,8 @@
AC_CHECK_LIB(z, main, [LIBS=$LIBS" -lz "; AC_DEFINE(HAVE_ZLIB)], AC_MSG_WARN([No zlib - MCCP support will not be built]))
---- Makefile.am
-+++ Makefile.am
+--- a/Makefile.am
++++ b/Makefile.am
@@ -5,7 +5,11 @@
common.h crystal.h grid.h io.h telnet.h wcwidth.c \
scripting.cc scripting.h
diff --git a/games-mud/crystal/files/crystal-0.2.4-gcc43.patch b/games-mud/crystal/files/crystal-0.2.4-gcc43.patch
index 40623c5c22b3..dbb4e2a1649f 100644
--- a/games-mud/crystal/files/crystal-0.2.4-gcc43.patch
+++ b/games-mud/crystal/files/crystal-0.2.4-gcc43.patch
@@ -1,5 +1,5 @@
---- common.h
-+++ common.h
+--- a/common.h
++++ b/common.h
@@ -3,6 +3,8 @@
#include <string>