summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Pavlov <t.x00100x.t@yandex.ru>2023-12-08 16:03:55 +0300
committerUlrich Müller <ulm@gentoo.org>2023-12-26 23:49:28 +0100
commitb4d6e35d92e3b8688f3a53ceae57e4080a73f376 (patch)
tree6b3ad4b7a0d229e00d92a452012c646da59213f4 /games-fps
parentgames-fps/serioussam-tse-data: new package, add 1.7-r1 (diff)
downloadgentoo-b4d6e35d92e3b8688f3a53ceae57e4080a73f376.tar.gz
gentoo-b4d6e35d92e3b8688f3a53ceae57e4080a73f376.tar.bz2
gentoo-b4d6e35d92e3b8688f3a53ceae57e4080a73f376.zip
games-fps/serioussam: new package, add 1.10.6
Bug: https://bugs.gentoo.org/854567 Signed-off-by: Alexander Pavlov <t.x00100x.t@yandex.ru> [Use ED instead of D.] Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/serioussam/Manifest1
-rw-r--r--games-fps/serioussam/metadata.xml22
-rw-r--r--games-fps/serioussam/serioussam-1.10.6.ebuild106
3 files changed, 129 insertions, 0 deletions
diff --git a/games-fps/serioussam/Manifest b/games-fps/serioussam/Manifest
new file mode 100644
index 000000000000..eb7ea315651a
--- /dev/null
+++ b/games-fps/serioussam/Manifest
@@ -0,0 +1 @@
+DIST serioussam-1.10.6c.tar.gz 47908208 BLAKE2B 90af9f8c11b474ce0e114c3390e1afd5c746c1b2ca4e61bd6085f1dc42f6f73981cc4434ff8fdcc1306178ae9d2707026765a3a1da006d5adb841d2d314a4214 SHA512 de1ba536c84977d1e7335833b8a2080b13a22ca25efba88363972dceb4bcbfda1db448de42d262fa003fe9df393327509e76afc3cc501f96ed6495d29b74b6bb
diff --git a/games-fps/serioussam/metadata.xml b/games-fps/serioussam/metadata.xml
new file mode 100644
index 000000000000..c9c22cde71e7
--- /dev/null
+++ b/games-fps/serioussam/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>t.x00100x.t@yandex.ru</email>
+ <name>Alexander Pavlov</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="alsa">Enable support ALSA sound.</flag>
+ <flag name="pipewire">Enable support for pipewire.</flag>
+ <flag name="vulkan">Enable support Vulkan render.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">tx00100xt/SeriousSamClassic-VK</remote-id>
+ <bugs-to>https://github.com/tx00100xt/SeriousSamClassic-VK/issues</bugs-to>
+ <changelog>https://github.com/tx00100xt/SeriousSamClassic-VK/releases</changelog>
+ </upstream>
+</pkgmetadata>
diff --git a/games-fps/serioussam/serioussam-1.10.6.ebuild b/games-fps/serioussam/serioussam-1.10.6.ebuild
new file mode 100644
index 000000000000..5b9b2d1a433d
--- /dev/null
+++ b/games-fps/serioussam/serioussam-1.10.6.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake desktop
+
+MY_PN1="SamTFE"
+MY_PN2="SamTSE"
+# Game name
+GN1="serioussam"
+GN2="serioussamse"
+
+DESCRIPTION="Linux port of Serious Sam Classic with Vulkan support"
+HOMEPAGE="https://github.com/tx00100xt/SeriousSamClassic-VK"
+SRC_URI="https://github.com/tx00100xt/SeriousSamClassic-VK/archive/refs/tags/${PV}c.tar.gz -> ${P}c.tar.gz"
+S="${WORKDIR}/SeriousSamClassic-VK-${PV}c"
+
+MY_CONTENT1="${WORKDIR}/SeriousSamClassic-VK-${PV}c/${MY_PN1}"
+MY_CONTENT2="${WORKDIR}/SeriousSamClassic-VK-${PV}c/${MY_PN2}"
+
+LICENSE="GPL-2 BSD ZLIB"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="alsa pipewire vulkan"
+
+RDEPEND="
+ games-fps/serioussam-tfe-data
+ games-fps/serioussam-tse-data
+ media-libs/libsdl2[video,joystick,opengl]
+ media-libs/libvorbis
+ sys-libs/zlib
+ alsa? (
+ >=media-libs/libsdl2-2.0.6[alsa,sound]
+ )
+ pipewire? (
+ >=media-libs/libsdl2-2.0.6[pipewire,sound]
+ )
+ vulkan? (
+ dev-util/vulkan-headers
+ media-libs/vulkan-loader
+ media-libs/libsdl2[video,joystick,opengl,vulkan]
+ )
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ sys-devel/flex
+ sys-devel/bison
+ media-gfx/imagemagick
+"
+
+src_configure() {
+ einfo "Remove Win32 stuff..."
+ rm -rf "${MY_CONTENT1}"/Tools.Win32 || die "Failed to remove stuff Win32"
+ rm -rf "${MY_CONTENT2}"/Tools.Win32 || die "Failed to remove stuff Win32"
+
+ einfo "Setting build type Release..."
+ CMAKE_BUILD_TYPE="Release"
+ local mycmakeargs=(
+ -DUSE_SYSTEM_INSTALL=ON
+ -DUSE_SYSTEM_VULKAN=$(usex vulkan ON OFF)
+ -DUSE_ASM=$(usex x86 OFF ON)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ local dir1="/usr/share/${GN1}"
+ local dir2="/usr/share/${GN2}"
+ local dir3="/usr/share/applications"
+ cmake_src_install
+
+ # install man pages
+ mv "${S}"/man/gentoo/serioussam-vk.1 "${S}"/man/gentoo/serioussam.1 \
+ || die "Failed move man pages"
+ doman "${S}"/man/gentoo/serioussam.1
+
+ # removing repo stuff
+ rm -fr "${MY_CONTENT1}/Sources" && rm -fr "${MY_CONTENT2}/Sources" \
+ || die "Failed to remove Sources"
+ rm -f "${MY_CONTENT1}"/{*.png,*.desktop} \
+ || die "Failed to remove serioussam icon and desktop file"
+ rm -f "${MY_CONTENT2}"/{*.png,*.desktop} \
+ || die "Failed to remove serioussamse icon and desktop file"
+ rm -f "${ED}${dir3}/${GN1}.desktop" "${ED}${dir3}/${GN2}.desktop" \
+ || die "Failed to remove desktop file"
+
+ # moving repo content (Scripts, Data, Settings ...)
+ cp -fr "${MY_CONTENT1}"/* "${ED}${dir1}" \
+ || die "Failed to copy repo content (Scripts, Settings)"
+ cp -fr "${MY_CONTENT2}"/* "${ED}${dir2}" \
+ || die "Failed to copy repo content (Scripts, Settings)"
+
+ make_desktop_entry ${GN1} "Serious Sam The First Encounter" ${GN1}
+ make_desktop_entry ${GN2} "Serious Sam The Second Encounter" ${GN2}
+}
+
+pkg_postinst() {
+ elog " Look at:"
+ elog " man serioussam"
+ elog " https://github.com/tx00100xt/SeriousSamClassic-VK"
+ elog " https://github.com/tx00100xt/SeriousSamClassic-VK/wiki"
+ elog " For information on the first launch of the game"
+}