summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-10-07 07:50:12 -0700
committerEli Schwartz <eschwartz@gentoo.org>2024-10-09 13:26:38 -0400
commitee8bbed8ed79b6eaf0887c1eb52610d3c19be996 (patch)
tree0ac9fc6d2778c5dcc49d57f5bb0c0ad54e099c8e /games-emulation
parentdev-util/quilt: stabilize 0.68-r1 for amd64 (diff)
downloadgentoo-ee8bbed8ed79b6eaf0887c1eb52610d3c19be996.tar.gz
gentoo-ee8bbed8ed79b6eaf0887c1eb52610d3c19be996.tar.bz2
gentoo-ee8bbed8ed79b6eaf0887c1eb52610d3c19be996.zip
games-emulation/rmg: mark as LTO-unsafe, strict-aliasing unsafe
Signed-off-by: orbea <orbea@riseup.net> Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/rmg/rmg-0.6.5.ebuild9
-rw-r--r--games-emulation/rmg/rmg-9999.ebuild9
2 files changed, 16 insertions, 2 deletions
diff --git a/games-emulation/rmg/rmg-0.6.5.ebuild b/games-emulation/rmg/rmg-0.6.5.ebuild
index d6de051e2f28..6ca37bec7198 100644
--- a/games-emulation/rmg/rmg-0.6.5.ebuild
+++ b/games-emulation/rmg/rmg-0.6.5.ebuild
@@ -27,7 +27,7 @@ CRATES="
winapi@0.3.9
"
-inherit cargo cmake xdg
+inherit cargo cmake flag-o-matic xdg
MY_PN="${PN^^}"
MY_P="${MY_PN}-${PV}"
@@ -117,6 +117,13 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://github.com/gonetz/GLideN64/issues/2877
+ #
+ # Disable strict-aliasing until its handled upstream.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
export PKG_CONFIG_ALLOW_CROSS=1
local mycmakeargs=(
diff --git a/games-emulation/rmg/rmg-9999.ebuild b/games-emulation/rmg/rmg-9999.ebuild
index d6de051e2f28..6ca37bec7198 100644
--- a/games-emulation/rmg/rmg-9999.ebuild
+++ b/games-emulation/rmg/rmg-9999.ebuild
@@ -27,7 +27,7 @@ CRATES="
winapi@0.3.9
"
-inherit cargo cmake xdg
+inherit cargo cmake flag-o-matic xdg
MY_PN="${PN^^}"
MY_P="${MY_PN}-${PV}"
@@ -117,6 +117,13 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://github.com/gonetz/GLideN64/issues/2877
+ #
+ # Disable strict-aliasing until its handled upstream.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
export PKG_CONFIG_ALLOW_CROSS=1
local mycmakeargs=(