summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2023-12-19 20:46:15 -0800
committerSam James <sam@gentoo.org>2024-01-05 05:24:05 +0000
commit8625fc0f300c42c98d8db1c029ebcbe682d009e2 (patch)
treeae35197ca08fe040c869ca6d16fc8c4719a14bff /games-emulation/mednafen-jg
parentgames-emulation/bsnes-jg: fix arm endianness detection (diff)
downloadgentoo-8625fc0f300c42c98d8db1c029ebcbe682d009e2.tar.gz
gentoo-8625fc0f300c42c98d8db1c029ebcbe682d009e2.tar.bz2
gentoo-8625fc0f300c42c98d8db1c029ebcbe682d009e2.zip
games-emulation/mednafen-jg: add cpu_flags_x86_avx
Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/34381 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-emulation/mednafen-jg')
-rw-r--r--games-emulation/mednafen-jg/mednafen-jg-9999.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/games-emulation/mednafen-jg/mednafen-jg-9999.ebuild b/games-emulation/mednafen-jg/mednafen-jg-9999.ebuild
index 0c98a116fa35..9949818d7a2d 100644
--- a/games-emulation/mednafen-jg/mednafen-jg-9999.ebuild
+++ b/games-emulation/mednafen-jg/mednafen-jg-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -15,11 +15,12 @@ if [[ "${PV}" == *9999 ]] ; then
else
SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
S="${WORKDIR}/${MY_P}"
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
fi
LICENSE="BSD GPL-2 GPL-2+ LGPL-2.1+ ZLIB"
SLOT="1"
+IUSE="cpu_flags_x86_avx"
DEPEND="
app-arch/zstd
@@ -46,7 +47,7 @@ src_prepare() {
src_configure() {
cd jollygood/conf || die
- econf
+ econf $(use_enable cpu_flags_x86_avx avx)
}
src_compile() {