summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/sdlroids
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/sdlroids')
-rw-r--r--games-arcade/sdlroids/Manifest1
-rw-r--r--games-arcade/sdlroids/files/1.3.4-sound.patch15
-rw-r--r--games-arcade/sdlroids/metadata.xml8
-rw-r--r--games-arcade/sdlroids/sdlroids-1.3.4-r3.ebuild34
4 files changed, 58 insertions, 0 deletions
diff --git a/games-arcade/sdlroids/Manifest b/games-arcade/sdlroids/Manifest
new file mode 100644
index 000000000000..f709891032bb
--- /dev/null
+++ b/games-arcade/sdlroids/Manifest
@@ -0,0 +1 @@
+DIST sdlroids-1.3.4.tar.bz2 136588 SHA256 224b1def78dba8a4f7ec7bb15df16a21c85e50dc3d09888a19da0497d37c709c SHA512 abd202e462ac96781481defb9442f3ee69cbfafb5b4e82ae435dca23068257c3e65ba4886c0c41f2568a8568b52267ded24b8684efb3f7cafd21754103cc31b4 WHIRLPOOL 1df895bc8db1472b39d852bd8ce58295e46431b7d466e3bec80d9760e4ceb08e4bedb8c25e7f2aedb6fe47170c13ba63562f85647ab127c1e75b4fe3e1e2c5d8
diff --git a/games-arcade/sdlroids/files/1.3.4-sound.patch b/games-arcade/sdlroids/files/1.3.4-sound.patch
new file mode 100644
index 000000000000..00da03f94252
--- /dev/null
+++ b/games-arcade/sdlroids/files/1.3.4-sound.patch
@@ -0,0 +1,15 @@
+--- sdlsound.c.orig 2004-07-02 23:03:03.000000000 -0700
++++ sdlsound.c 2004-07-02 23:05:37.000000000 -0700
+@@ -205,9 +205,9 @@
+ int load_sample(int num) {
+
+ if((samples[num] = Mix_LoadWAV(samplename[num])) ||
+- Mix_LoadWAV(datafilename(NULL, samplename[num])) ||
+- Mix_LoadWAV(datafilename(DATADIR, samplename[num])) ||
+- Mix_LoadWAV(datafilename(bindir, samplename[num])))
++ (samples[num] = Mix_LoadWAV(datafilename(NULL, samplename[num]))) ||
++ (samples[num] = Mix_LoadWAV(datafilename(DATADIR, samplename[num]))) ||
++ (samples[num] = Mix_LoadWAV(datafilename(bindir, samplename[num]))))
+ return 1;
+ return 0;
+ }
diff --git a/games-arcade/sdlroids/metadata.xml b/games-arcade/sdlroids/metadata.xml
new file mode 100644
index 000000000000..3901cd5790ba
--- /dev/null
+++ b/games-arcade/sdlroids/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">sdlroids</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-arcade/sdlroids/sdlroids-1.3.4-r3.ebuild b/games-arcade/sdlroids/sdlroids-1.3.4-r3.ebuild
new file mode 100644
index 000000000000..55d37b791c5d
--- /dev/null
+++ b/games-arcade/sdlroids/sdlroids-1.3.4-r3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Asteroids Clone for X using SDL"
+HOMEPAGE="http://david.hedbor.org/projects/sdlroids/"
+SRC_URI="mirror://sourceforge/sdlroids/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-mixer"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e 's/$(SOUNDSDIR)/$(DESTDIR)$(SOUNDSDIR)/' \
+ -e 's/$(GFXDIR)/$(DESTDIR)$(GFXDIR)/' Makefile.in \
+ || die "sed failed"
+ epatch "${FILESDIR}"/${PV}-sound.patch
+}
+
+src_install() {
+ default
+ newicon icons/sdlroids-48x48.xpm ${PN}.xpm
+ make_desktop_entry ${PN} SDLRoids ${PN}
+ prepgamesdirs
+}