summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-26 22:02:50 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-26 23:40:14 +0100
commit276a229fedf2b61918d6f0fcf5cacf42410bf2a2 (patch)
tree1c82c535a7c91925dcb0434a4342f44afce4af05 /games-arcade/performous/files
parentdev-qt/qtimageformats: Bump to QT5_KDEPATCHSET_REV=2 (diff)
downloadgentoo-276a229fedf2b61918d6f0fcf5cacf42410bf2a2.tar.gz
gentoo-276a229fedf2b61918d6f0fcf5cacf42410bf2a2.tar.bz2
gentoo-276a229fedf2b61918d6f0fcf5cacf42410bf2a2.zip
games-arcade/performous: drop 1.1-r3
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-arcade/performous/files')
-rw-r--r--games-arcade/performous/files/performous-1.1-boost-1.70.patch52
-rw-r--r--games-arcade/performous/files/performous-1.1-boost-1.73.patch11
-rw-r--r--games-arcade/performous/files/performous-1.1-gentoo.patch12
-rw-r--r--games-arcade/performous/files/performous-1.1-jpeg-9c.patch11
-rw-r--r--games-arcade/performous/files/performous-1.1-linguas.patch18
-rw-r--r--games-arcade/performous/files/performous-1.1-nomancompress.patch59
-rw-r--r--games-arcade/performous/files/performous-1.1-pango-use-pkgconfig.patch113
7 files changed, 0 insertions, 276 deletions
diff --git a/games-arcade/performous/files/performous-1.1-boost-1.70.patch b/games-arcade/performous/files/performous-1.1-boost-1.70.patch
deleted file mode 100644
index d868e1279659..000000000000
--- a/games-arcade/performous/files/performous-1.1-boost-1.70.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-https://bugs.gentoo.org/671594
-
---- a/game/audio.cc
-+++ b/game/audio.cc
-@@ -77,7 +77,7 @@
- static ptime getTime() { return microsec_clock::universal_time(); }
- // Conversion helpers
- static double getSeconds(time_duration t) { return 1e-6 * t.total_microseconds(); }
-- static time_duration getDuration(double seconds) { return microseconds(1e6 * seconds); }
-+ static time_duration getDuration(double seconds) { return microseconds(static_cast<long long>(1e6 * seconds)); }
-
- mutable boost::mutex m_mutex;
- ptime m_baseTime; ///< A reference time (corresponds to m_basePos)
-@@ -149,7 +149,7 @@
- int64_t m_pos; ///< Current sample position
- bool m_preview;
- AudioClock m_clock;
-- time_duration durationOf(int64_t samples) const { return microseconds(1e6 * samples / srate / 2.0); }
-+ time_duration durationOf(int64_t samples) const { return microseconds(static_cast<long long>(1e6 * samples / srate / 2.0)); }
- public:
- bool suppressCenterChannel;
- double fadeLevel;
---- a/game/backgrounds.hh
-+++ b/game/backgrounds.hh
-@@ -7,6 +7,7 @@
- #include <boost/scoped_ptr.hpp>
- #include <boost/thread/mutex.hpp>
- #include <boost/thread/thread.hpp>
-+#include <boost/noncopyable.hpp>
- #include <vector>
-
- /// songs class for songs screen
---- a/game/songs.hh
-+++ b/game/songs.hh
-@@ -6,6 +6,7 @@
- #include <boost/scoped_ptr.hpp>
- #include <boost/thread/mutex.hpp>
- #include <boost/thread/thread.hpp>
-+#include <boost/noncopyable.hpp>
- #include <set>
- #include <sstream>
- #include <vector>
---- a/game/svg.cc
-+++ b/game/svg.cc
-@@ -4,6 +4,7 @@
- #include "configuration.hh"
- #include "../common/image.hh"
-
-+#include <boost/smart_ptr/shared_ptr.hpp>
- #include <librsvg/rsvg.h>
- #include <iostream>
-
diff --git a/games-arcade/performous/files/performous-1.1-boost-1.73.patch b/games-arcade/performous/files/performous-1.1-boost-1.73.patch
deleted file mode 100644
index 3d7147a5170f..000000000000
--- a/games-arcade/performous/files/performous-1.1-boost-1.73.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/game/surface.cc 2021-01-18 14:22:05.876604740 +0300
-+++ b/game/surface.cc 2021-01-18 14:23:08.908716258 +0300
-@@ -135,7 +135,7 @@
- bitmap.resize(1, 1);
- target->load(bitmap);
- // Ask the loader to retrieve the image
-- ldr->push(target, Job(name, boost::bind(&T::load, target, _1)));
-+ ldr->push(target, Job(name, boost::bind(&T::load, target, boost::placeholders::_1)));
- }
-
- Surface::Surface(fs::path const& filename) { loader(this, filename); }
diff --git a/games-arcade/performous/files/performous-1.1-gentoo.patch b/games-arcade/performous/files/performous-1.1-gentoo.patch
deleted file mode 100644
index a73663a88c41..000000000000
--- a/games-arcade/performous/files/performous-1.1-gentoo.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ru performous-1.0.orig/game/CMakeLists.txt performous-1.0/game/CMakeLists.txt
---- performous-1.0.orig/game/CMakeLists.txt 2014-10-28 19:11:45.000000000 -0400
-+++ performous-1.0/game/CMakeLists.txt 2015-03-31 03:01:30.806061643 -0400
-@@ -141,7 +141,7 @@
- set(BIN_INSTALL .) # Straight to Program Files/Performous with no bin subfolder.
- set(SUBSYSTEM_WIN32 WIN32)
- else()
-- set(BIN_INSTALL bin)
-+ set(BIN_INSTALL @GENTOO_BINDIR@)
- endif()
-
- # Build main executable
diff --git a/games-arcade/performous/files/performous-1.1-jpeg-9c.patch b/games-arcade/performous/files/performous-1.1-jpeg-9c.patch
deleted file mode 100644
index d878cec07f51..000000000000
--- a/games-arcade/performous/files/performous-1.1-jpeg-9c.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/common/image.cc
-+++ b/common/image.cc
-@@ -180,7 +180,7 @@
- }
- jpeg_create_decompress(&cinfo);
- jpeg_mem_src(&cinfo, data.data(), data.size());
-- if (jpeg_read_header(&cinfo, true) != JPEG_HEADER_OK) throw std::runtime_error("Cannot read header of " + filename.string());
-+ if (jpeg_read_header(&cinfo, TRUE) != JPEG_HEADER_OK) throw std::runtime_error("Cannot read header of " + filename.string());
- jpeg_start_decompress(&cinfo);
- bitmap.resize(cinfo.output_width, cinfo.output_height);
- unsigned stride = (bitmap.width * 3 + 3) & ~3; // Number of bytes per row (word-aligned)
diff --git a/games-arcade/performous/files/performous-1.1-linguas.patch b/games-arcade/performous/files/performous-1.1-linguas.patch
deleted file mode 100644
index f8f1349ea3b9..000000000000
--- a/games-arcade/performous/files/performous-1.1-linguas.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff -ru performous-1.0.orig/lang/CMakeLists.txt performous-1.0/lang/CMakeLists.txt
---- performous-1.0.orig/lang/CMakeLists.txt 2014-10-28 19:11:45.000000000 -0400
-+++ performous-1.0/lang/CMakeLists.txt 2015-02-22 04:25:40.502252942 -0500
-@@ -9,5 +9,13 @@
- file(MAKE_DIRECTORY "${mobuild}")
- add_custom_command(OUTPUT "${mofile}" COMMAND "${Msgfmt_BIN}" -v "${pofile}" -o "${mofile}" MAIN_DEPENDENCY "${pofile}" COMMENT "Building ${language} locale" VERBATIM)
- add_custom_target("locale_${language}" ALL DEPENDS "${mofile}") # Make sure the mofiles are always built
-- install(FILES "${mofile}" DESTINATION "${LOCALE_DIR}/${language}/LC_MESSAGES")
- endforeach(language)
-+foreach(language $ENV{LINGUAS})
-+ set(pofile ${CMAKE_CURRENT_SOURCE_DIR}/${language}.po)
-+ if (EXISTS ${pofile})
-+ set(mofile ${CMAKE_CURRENT_BINARY_DIR}/${language}.mo)
-+ install(FILES ${mofile} DESTINATION
-+{LOCALE_DIR}/${language}/LC_MESSAGES RENAME ${CMAKE_PROJECT_NAME}.mo)
-+ endif()
-+endforeach(language)
-+
diff --git a/games-arcade/performous/files/performous-1.1-nomancompress.patch b/games-arcade/performous/files/performous-1.1-nomancompress.patch
deleted file mode 100644
index fd21f9b70343..000000000000
--- a/games-arcade/performous/files/performous-1.1-nomancompress.patch
+++ /dev/null
@@ -1,59 +0,0 @@
---- a/docs/man/CMakeLists.txt 2018-10-14 19:57:14.924572577 +0200
-+++ b/docs/man/CMakeLists.txt 2018-10-14 20:11:13.250717230 +0200
-@@ -1,14 +1,12 @@
- find_program(HELP2MAN help2man DOC "Location of the help2man program")
--find_program(GZIP gzip DOC "Location of the gzip program")
- mark_as_advanced(HELP2MAN)
--mark_as_advanced(GZIP)
--if(HELP2MAN AND GZIP)
-- set(MANFILE ${CMAKE_CURRENT_BINARY_DIR}/performous.6.gz)
-+if(HELP2MAN)
-+ set(MANFILE ${CMAKE_CURRENT_BINARY_DIR}/performous.6)
- set(H2MFILE ${CMAKE_CURRENT_SOURCE_DIR}/performous.h2m)
- set(PERFORMOUS_EXEC ${CMAKE_BINARY_DIR}/performous)
- add_custom_command(
- OUTPUT ${MANFILE}
-- COMMAND ${HELP2MAN} ${PERFORMOUS_EXEC} -s 6 -i ${H2MFILE} -N | ${GZIP} > ${MANFILE}
-+ COMMAND ${HELP2MAN} ${PERFORMOUS_EXEC} -s 6 -i ${H2MFILE} -N > ${MANFILE}
- MAIN_DEPENDENCY ${H2MFILE}
- DEPENDS ${PERFORMOUS_EXEC}
- COMMENT "Building Performous man page"
-@@ -17,13 +15,13 @@
- add_custom_target(manpage ALL DEPENDS ${MANFILE})
- iF (APPLE)
- install(FILES ${MANFILE} DESTINATION Resources/man/man6)
-- else(APPLE)
-+ else()
- install(FILES ${MANFILE} DESTINATION share/man/man6)
- endif()
--else(HELP2MAN AND GZIP)
-- message("WARNING: One of the following is missing: help2man, gzip; performous man page will not be generated")
--endif(HELP2MAN AND GZIP)
--if(ENABLE_TOOLS AND GZIP)
-+else()
-+ message("WARNING: help2man is missing; performous man page will not be generated")
-+endif()
-+if(ENABLE_TOOLS)
- set(TOOLS
- "ss_pak_extract" "ss_extract" "ss_cover_conv"
- "ss_adpcm_decode" "ss_ipu_conv" "ss_chc_decode"
-@@ -31,15 +29,7 @@
- set(MAN_SECTION "1")
- foreach(TOOL ${TOOLS})
- set(TOOL_MANFILE ${CMAKE_CURRENT_SOURCE_DIR}/${TOOL}.${MAN_SECTION})
-- set(TOOL_MANFILE_GZ ${CMAKE_CURRENT_BINARY_DIR}/${TOOL}.${MAN_SECTION}.gz)
-- add_custom_command(
-- OUTPUT ${TOOL_MANFILE_GZ}
-- COMMAND ${GZIP} -c ${TOOL_MANFILE} > ${TOOL_MANFILE_GZ}
-- MAIN_DEPENDENCY ${TOOL_MANFILE}
-- COMMENT "Building ${TOOL} man page"
-- VERBATIM
-- )
-- add_custom_target(${TOOL}.${MAN_SECTION} ALL DEPENDS ${TOOL_MANFILE_GZ})
-- install(FILES ${TOOL_MANFILE_GZ} DESTINATION share/man/man${MAN_SECTION})
-- endforeach(TOOL)
--endif(ENABLE_TOOLS AND GZIP)
-+ add_custom_target(${TOOL}.${MAN_SECTION} ALL DEPENDS ${TOOL_MANFILE})
-+ install(FILES ${TOOL_MANFILE} DESTINATION share/man/man${MAN_SECTION})
-+ endforeach()
-+endif()
diff --git a/games-arcade/performous/files/performous-1.1-pango-use-pkgconfig.patch b/games-arcade/performous/files/performous-1.1-pango-use-pkgconfig.patch
deleted file mode 100644
index 9019183206d6..000000000000
--- a/games-arcade/performous/files/performous-1.1-pango-use-pkgconfig.patch
+++ /dev/null
@@ -1,113 +0,0 @@
-From caea553262e1d40bf9caec84223b5d25989464c0 Mon Sep 17 00:00:00 2001
-From: Orivej Desh <orivej@gmx.fr>
-Date: Wed, 25 Mar 2020 14:17:06 +0000
-Subject: [PATCH] Rely on pkg-config to find Pango
-
-Fixes build with pango that needs -I/usr/include/harfbuzz (as specified in its
-pkg config).
-
-PkgConfig results can be overridded by setting e.g. Pango_PKGCONF_INCLUDEDIR,
-Pango_PKGCONF_LDFLAGS (see FindPkgConfig documentation).
-
-IMPORTED_TARGET was added in CMake 3.6.
-
-Fixes #490
-Closes #493
----
- CMakeLists.txt | 2 +-
- cmake/Modules/FindPango.cmake | 25 ++---------------------
- cmake/Modules/FindPangoCairo.cmake | 32 ++++--------------------------
- 3 files changed, 7 insertions(+), 52 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index f6e72942d..ca7ae4e92 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -1,4 +1,4 @@
--cmake_minimum_required(VERSION 2.8)
-+cmake_minimum_required(VERSION 3.6)
- project(Performous CXX C)
-
- set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/Modules/")
-diff --git a/cmake/Modules/FindPango.cmake b/cmake/Modules/FindPango.cmake
-index bdddb9e03..42cb199cc 100644
---- a/cmake/Modules/FindPango.cmake
-+++ b/cmake/Modules/FindPango.cmake
-@@ -2,31 +2,10 @@
- # Once done, this will define
- #
- # Pango_FOUND - system has Pango
--# Pango_INCLUDE_DIRS - the Pango include directories
- # Pango_LIBRARIES - link these to use Pango
-
- include(LibFindMacros)
-
--# Dependencies
--libfind_package(Pango Freetype)
--libfind_package(Pango Glib)
--libfind_package(Pango GObject)
--
--# Use pkg-config to get hints about paths
--libfind_pkg_check_modules(Pango_PKGCONF pango)
--
--# Include dir
--find_path(Pango_INCLUDE_DIR
-- NAMES pango/pango.h
-- HINTS ${Pango_PKGCONF_INCLUDE_DIRS}
-- PATH_SUFFIXES pango-1.0
--)
--
--# Finally the library itself
--find_library(Pango_LIBRARY
-- NAMES pango-1.0
-- HINTS ${Pango_PKGCONF_LIBRARY_DIRS}
--)
--
-+libfind_pkg_check_modules(Pango_PKGCONF IMPORTED_TARGET pango)
-+set(Pango_LIBRARY PkgConfig::Pango_PKGCONF)
- libfind_process(Pango)
--
-diff --git a/cmake/Modules/FindPangoCairo.cmake b/cmake/Modules/FindPangoCairo.cmake
-index a26f83bd0..1c1a9e843 100644
---- a/cmake/Modules/FindPangoCairo.cmake
-+++ b/cmake/Modules/FindPangoCairo.cmake
-@@ -1,35 +1,11 @@
- # - Try to find PangoCairo
- # Once done, this will define
- #
--# PangoCairo_FOUND - system has Pango
--# PangoCairo_INCLUDE_DIRS - the Pango include directories
--# PangoCairo_LIBRARIES - link these to use Pango
-+# PangoCairo_FOUND - system has PangoCairo
-+# PangoCairo_LIBRARIES - link these to use PangoCairo
-
- include(LibFindMacros)
-
--# Dependencies
--libfind_package(PangoCairo Pango)
--libfind_package(PangoCairo Cairo)
--
--# Use pkg-config to get hints about paths
--libfind_pkg_check_modules(PangoCairo_PKGCONF pangocairo)
--
--# Include dir
--find_path(PangoCairo_INCLUDE_DIR
-- NAMES pango/pangocairo.h
-- HINTS ${PangoCairo_PKGCONF_INCLUDE_DIRS}
-- PATH_SUFFIXES pango-1.0
--)
--
--# Finally the library itself
--find_library(PangoCairo_LIBRARY
-- NAMES pangocairo-1.0
-- HINTS ${PangoCairo_PKGCONF_LIBRARY_DIRS}
--)
--
--# Set the include dir variables and the libraries and let libfind_process do the rest.
--# NOTE: Singular variables for this library, plural for libraries this this lib depends on.
--set(PangoCairo_PROCESS_INCLUDES PangoCairo_INCLUDE_DIR Pango_INCLUDE_DIR Cairo_INCLUDE_DIR)
--set(PangoCairo_PROCESS_LIBS PangoCairo_LIBRARY Pango_LIBRARY Cairo_LIBRARY)
-+libfind_pkg_check_modules(PangoCairo_PKGCONF IMPORTED_TARGET pangocairo)
-+set(PangoCairo_LIBRARY PkgConfig::PangoCairo_PKGCONF)
- libfind_process(PangoCairo)
--