summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/dynamitejack
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/dynamitejack')
-rw-r--r--games-arcade/dynamitejack/Manifest1
-rw-r--r--games-arcade/dynamitejack/dynamitejack-1.0.23-r1.ebuild68
-rw-r--r--games-arcade/dynamitejack/metadata.xml6
3 files changed, 75 insertions, 0 deletions
diff --git a/games-arcade/dynamitejack/Manifest b/games-arcade/dynamitejack/Manifest
new file mode 100644
index 000000000000..19448ceb83bb
--- /dev/null
+++ b/games-arcade/dynamitejack/Manifest
@@ -0,0 +1 @@
+DIST dynamitejack-1.0.23.tgz 54195417 SHA256 aa5fbc27d6931753373e7af99a9521e335a4a5b38a7be0fc8e82c2191b3302e2 SHA512 57897194244ded8d41ef0e7704fd973a58fe52dbc01b7dceed2a47694f7cc3e75d732547532bc7be4dd7d510572dedb85188da413b5857f52182799427243c4d WHIRLPOOL 78d09068461ff8d11cb1a73ec94d160e085636f3d6f1933f0210b12505319c74a0d23daf66814fc23ad0c1c6e1a1dc6cb45adf783376d5573a949d5c3f9a1f4d
diff --git a/games-arcade/dynamitejack/dynamitejack-1.0.23-r1.ebuild b/games-arcade/dynamitejack/dynamitejack-1.0.23-r1.ebuild
new file mode 100644
index 000000000000..9f2e49b3cc49
--- /dev/null
+++ b/games-arcade/dynamitejack/dynamitejack-1.0.23-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# TODO: icon
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A stealth game with bombs in glorious 2D"
+HOMEPAGE="http://www.galcon.com/dynamitejack/"
+SRC_URI="${P}.tgz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE=""
+RESTRICT="bindist fetch splitdebug"
+
+MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${MYGAMEDIR#/}/bin/*"
+
+# linked to pulseaudio
+RDEPEND="
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ >=media-libs/alsa-lib-1.0.27.2[abi_x86_32(-)]
+ >=media-libs/flac-1.2.1-r5[abi_x86_32(-)]
+ >=media-libs/libogg-1.3.0[abi_x86_32(-)]
+ >=media-libs/libsdl-1.2.15-r4[X,sound,joystick,opengl,video,abi_x86_32(-)]
+ >=media-libs/libsndfile-1.0.25[abi_x86_32(-)]
+ >=media-libs/libvorbis-1.3.3-r1[abi_x86_32(-)]
+ >=media-sound/pulseaudio-2.1-r1[abi_x86_32(-)]
+ >=virtual/glu-9.0-r1[abi_x86_32(-)]
+ >=x11-libs/libICE-1.0.8-r1[abi_x86_32(-)]
+ >=x11-libs/libSM-1.2.1-r1[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXau-1.0.7-r1[abi_x86_32(-)]
+ >=x11-libs/libxcb-1.9.1[abi_x86_32(-)]
+ >=x11-libs/libXdmcp-1.1.1-r1[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
+ >=x11-libs/libXi-1.7.2[abi_x86_32(-)]
+ >=x11-libs/libXtst-1.2.1-r1[abi_x86_32(-)]"
+
+S=${WORKDIR}/${PN}
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to ${DISTDIR}"
+}
+
+src_prepare() {
+ rm run_me || die
+ mv LINUX.txt "${T}"/ || die
+}
+
+src_install() {
+ dodoc "${T}"/LINUX.txt
+
+ insinto "${MYGAMEDIR}"
+ doins -r *
+
+ games_make_wrapper ${PN} "./main" "${MYGAMEDIR}/bin"
+ make_desktop_entry ${PN}
+
+ fperms +x "${MYGAMEDIR}"/bin/main
+ prepgamesdirs
+}
diff --git a/games-arcade/dynamitejack/metadata.xml b/games-arcade/dynamitejack/metadata.xml
new file mode 100644
index 000000000000..01a746edb196
--- /dev/null
+++ b/games-arcade/dynamitejack/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+</pkgmetadata>
+