summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/ceferino
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/ceferino')
-rw-r--r--games-arcade/ceferino/Manifest1
-rw-r--r--games-arcade/ceferino/ceferino-0.97.8.ebuild55
-rw-r--r--games-arcade/ceferino/files/ceferino-0.97.8-gcc44.patch11
-rw-r--r--games-arcade/ceferino/metadata.xml5
4 files changed, 72 insertions, 0 deletions
diff --git a/games-arcade/ceferino/Manifest b/games-arcade/ceferino/Manifest
new file mode 100644
index 000000000000..361afea91679
--- /dev/null
+++ b/games-arcade/ceferino/Manifest
@@ -0,0 +1 @@
+DIST ceferino-0.97.8.tar.gz 2380632 SHA256 6f0f2674a8a968950498570b89123e341dca50499d255e7bcdf3703a85aa3074 SHA512 459e5b5e19ff9cfc8bd82af856dea68d5f8694ff2b4a04e35c1b3fa1d065c8d8c60025b5e9ea1918eae4bf12a9ca354187513a3cb2813a55d39ef57deb2a7d05 WHIRLPOOL f989e81fc032ea6c65486d07ce80834052aa7ac31b3aceebe1580212817a3f59f6e0bb2b9fd1fa0fe1d14c11af164965675d164b836b7c032a0ddce21c39d3d4
diff --git a/games-arcade/ceferino/ceferino-0.97.8.ebuild b/games-arcade/ceferino/ceferino-0.97.8.ebuild
new file mode 100644
index 000000000000..21615df9a159
--- /dev/null
+++ b/games-arcade/ceferino/ceferino-0.97.8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Super-Pang clone (destroy bouncing balloons with your grapnel)"
+HOMEPAGE="http://www.loosersjuegos.com.ar/juegos/ceferino"
+SRC_URI="http://www.loosersjuegos.com.ar/juegos/ceferino/descargas/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="nls"
+
+RDEPEND=">=media-libs/libsdl-1.2
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+ sed -i \
+ -e '/^\(gnu\)\?localedir /s:= .*:= /usr/share/locale:' \
+ po/Makefile.in.in \
+ || die "sed failed"
+ sed -i \
+ -e '/^INCLUDES/s:\$(datadir)/locale:/usr/share/locale:' \
+ src/Makefile.in \
+ || die "sed failed"
+}
+
+src_configure() {
+ egamesconf $(use_enable nls)
+}
+
+src_install() {
+ default
+ newicon data/ima/icono.png ${PN}.png
+ make_desktop_entry ceferino "Don Ceferino Hazaña"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if ! has_version "media-libs/sdl-mixer[mod]" ; then
+ ewarn
+ ewarn "To hear music, you will have to rebuild media-libs/sdl-mixer"
+ ewarn "with the \"mod\" USE flag turned on."
+ ewarn
+ fi
+}
diff --git a/games-arcade/ceferino/files/ceferino-0.97.8-gcc44.patch b/games-arcade/ceferino/files/ceferino-0.97.8-gcc44.patch
new file mode 100644
index 000000000000..96944dd382bb
--- /dev/null
+++ b/games-arcade/ceferino/files/ceferino-0.97.8-gcc44.patch
@@ -0,0 +1,11 @@
+--- src/nivel.h
++++ src/nivel.h
+@@ -34,7 +34,7 @@
+ class nivel
+ {
+ public:
+- void iniciar(juego *_pjuego, grafico *grafico, grafico *pfondos, SDL_Surface *fondo);
++ void iniciar(juego *_pjuego, grafico *_grafico, grafico *pfondos, SDL_Surface *fondo);
+ int avanzar_nivel(int salto = 1);
+ int reiniciar_nivel(void);
+ int get_dist_suelo(int x, int y, int max);
diff --git a/games-arcade/ceferino/metadata.xml b/games-arcade/ceferino/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/ceferino/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>