summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2021-08-02 18:32:57 +0200
committerIonen Wolkens <ionen@gentoo.org>2021-08-02 14:17:01 -0400
commit164161a7e0dfad67faa29a3db914bc3005830218 (patch)
tree40b8078ce1a01e04359564f320fe61d134bf1ec7 /games-arcade/ceferino
parentgames-arcade/defendguin: respect CPPFLAGS too (diff)
downloadgentoo-164161a7e0dfad67faa29a3db914bc3005830218.tar.gz
gentoo-164161a7e0dfad67faa29a3db914bc3005830218.tar.bz2
gentoo-164161a7e0dfad67faa29a3db914bc3005830218.zip
games-arcade/ceferino: EAPI8, minor improvements
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-arcade/ceferino')
-rw-r--r--games-arcade/ceferino/ceferino-0.97.8-r3.ebuild45
-rw-r--r--games-arcade/ceferino/files/ceferino-0.97.8-fix-audio.patch11
2 files changed, 56 insertions, 0 deletions
diff --git a/games-arcade/ceferino/ceferino-0.97.8-r3.ebuild b/games-arcade/ceferino/ceferino-0.97.8-r3.ebuild
new file mode 100644
index 000000000000..54be47444942
--- /dev/null
+++ b/games-arcade/ceferino/ceferino-0.97.8-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools desktop
+
+DESCRIPTION="Super-Pang clone (destroy bouncing balloons with your grapnel)"
+HOMEPAGE="http://www.losersjuegos.com.ar/juegos/ceferino"
+SRC_URI="mirror://debian/pool/main/c/ceferino/${PN}_${PV}+svn37.orig.tar.gz"
+S+="+svn37"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-mixer[mod]
+ nls? ( virtual/libintl )
+"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-audio.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ default
+ newicon data/ima/icono.png ${PN}.png
+ make_desktop_entry ceferino "Don Ceferino Hazaña"
+}
diff --git a/games-arcade/ceferino/files/ceferino-0.97.8-fix-audio.patch b/games-arcade/ceferino/files/ceferino-0.97.8-fix-audio.patch
new file mode 100644
index 000000000000..6ac1de0d07f8
--- /dev/null
+++ b/games-arcade/ceferino/files/ceferino-0.97.8-fix-audio.patch
@@ -0,0 +1,11 @@
+12 .wav files for an array with 11 elements invokes undefined behavior.
+
+--- a/src/audio.h
++++ b/src/audio.h
+@@ -50,5 +50,5 @@
+ int canal_musica;
+
+- Mix_Chunk *sonidos[11];
++ Mix_Chunk *sonidos[12];
+ Mix_Music *musicas[2];
+