summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-09-04 11:50:21 +0100
committerJames Le Cuirot <chewi@gentoo.org>2022-09-04 11:51:59 +0100
commit2bcd079aabc431e62e55b5a087ad4c63e56d0014 (patch)
tree1ace32a2ea5b35fa32b7e30c358dd511b9e8dace /games-action/a-story-about-my-uncle
parentsci-geosciences/gpsd: x86 stable wrt bug #868309 (diff)
downloadgentoo-2bcd079aabc431e62e55b5a087ad4c63e56d0014.tar.gz
gentoo-2bcd079aabc431e62e55b5a087ad4c63e56d0014.tar.bz2
gentoo-2bcd079aabc431e62e55b5a087ad4c63e56d0014.zip
games-action/a-story-about-my-uncle: New package at version 5188
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-action/a-story-about-my-uncle')
-rw-r--r--games-action/a-story-about-my-uncle/Manifest2
-rw-r--r--games-action/a-story-about-my-uncle/a-story-about-my-uncle-5188.ebuild71
-rw-r--r--games-action/a-story-about-my-uncle/files/wrapper.sh9
-rw-r--r--games-action/a-story-about-my-uncle/metadata.xml22
4 files changed, 104 insertions, 0 deletions
diff --git a/games-action/a-story-about-my-uncle/Manifest b/games-action/a-story-about-my-uncle/Manifest
new file mode 100644
index 000000000000..9706fb85be4f
--- /dev/null
+++ b/games-action/a-story-about-my-uncle/Manifest
@@ -0,0 +1,2 @@
+DIST ASAMU.png 5451 BLAKE2B 767d4cb7ba77430a70b776370e1c25e486c02cac14a9bfdff18be2fd869b38ed27d43d756409a0aeb319b1e5653a28dfa45f6310139f1c752796a7545b506f98 SHA512 1871986ee96e4c6cb4225e418b83ce970674f71504d97b8a9f764716ae85e9a1ef01831a12e1010d9e2c681b93ac35ee2a35429612aaa6d37a42a6b9756c5024
+DIST Linux-NoDRM-ASAMU_5188.zip 997974042 BLAKE2B fe7920e18d4d867203fb10db3ab22b7b831abd08c07c6611a0e52249244aa519bbbee235382ae5b00ba85126a5c456700836331a8bf3f8542c14837de879b3ba SHA512 2ae3e811cb35f61d69cedf7d9ac35db88b6bb78ef8b43599732f5f7db13cf13993a6f01d7b097d8fe98e50265652003988c785e4132c18251a3b7335521fea96
diff --git a/games-action/a-story-about-my-uncle/a-story-about-my-uncle-5188.ebuild b/games-action/a-story-about-my-uncle/a-story-about-my-uncle-5188.ebuild
new file mode 100644
index 000000000000..f6d88f93d2ec
--- /dev/null
+++ b/games-action/a-story-about-my-uncle/a-story-about-my-uncle-5188.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CHECKREQS_DISK_BUILD="1219M"
+inherit check-reqs desktop prefix xdg
+
+MY_PN="ASAMU"
+MY_P="${MY_PN}_${PV}"
+DESCRIPTION="First person platforming adventure game about a boy who searches for his lost uncle"
+HOMEPAGE="https://www.humblebundle.com/store/a-story-about-my-uncle"
+SRC_URI="Linux-NoDRM-${MY_P}.zip
+ fetch+https://dev.gentoo.org/~chewi/distfiles/${MY_PN}.png"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist fetch splitdebug"
+
+BDEPEND="
+ app-arch/unzip
+"
+
+RDEPEND="
+ media-libs/libsdl2[opengl,sound,video]
+ sys-apps/bubblewrap
+ >=sys-devel/gcc-3.4
+ >=sys-libs/glibc-2.14
+ virtual/opengl
+"
+
+S="${WORKDIR}"
+DIR="/opt/${MY_PN}"
+QA_PREBUILT="${DIR#/}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download Linux-NoDRM-${MY_P}.zip from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_prepare() {
+ default
+ rm -v Binaries/*/libSDL2-2.0.so.0 || die
+}
+
+src_install() {
+ insinto "${DIR}"
+ doins -r ${MY_PN}/ Engine/
+
+ # The game resets the user config when the timestamps of the other config
+ # files change, and doins does not preserve timestamps. Reduce the impact of
+ # this by preserving the original timestamps with touch
+ local file
+ find -type f -name "*.ini" -print0 | while read -rd '' file; do
+ touch -r "${file}" "${ED}${DIR}/${file}" || die
+ done
+
+ local platform=linux-$(usex amd64 amd64 x86)
+ insinto "${DIR}"/Binaries/gentoo
+ exeinto "${DIR}"/Binaries/gentoo
+ doins Binaries/${platform}/steam_appid.txt
+ doexe Binaries/${platform}/{${MY_PN},*.so*}
+
+ keepdir "${DIR}"/${MY_PN}/Saves
+ newbin $(prefixify_ro "${FILESDIR}"/wrapper.sh) ${MY_PN}
+
+ doicon -s 64 "${DISTDIR}"/${MY_PN}.png
+ make_desktop_entry ${MY_PN} "A Story About My Uncle" ${MY_PN}
+}
diff --git a/games-action/a-story-about-my-uncle/files/wrapper.sh b/games-action/a-story-about-my-uncle/files/wrapper.sh
new file mode 100644
index 000000000000..b81badb1f99f
--- /dev/null
+++ b/games-action/a-story-about-my-uncle/files/wrapper.sh
@@ -0,0 +1,9 @@
+#!/bin/sh -eu
+
+# Unfortunately, this game always writes within its own installation directory
+# rather than HOME. We work around this with bubblewrap.
+
+DIR="${HOME}"/.local/share/ASAMU
+mkdir -p "${DIR}"/Saves
+cp -r --preserve=timestamps /opt/ASAMU/ASAMU/Config/ "${DIR}"/
+exec bwrap --bind / / --dev-bind /dev /dev --bind "${DIR}"/Config /opt/ASAMU/ASAMU/Config --bind "${DIR}"/Saves /opt/ASAMU/ASAMU/Saves /opt/ASAMU/Binaries/gentoo/ASAMU "${@}"
diff --git a/games-action/a-story-about-my-uncle/metadata.xml b/games-action/a-story-about-my-uncle/metadata.xml
new file mode 100644
index 000000000000..9388d049a4d3
--- /dev/null
+++ b/games-action/a-story-about-my-uncle/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ A Story About My Uncle is a first person platforming adventure game
+ about a boy who searches for his lost uncle, and ends up in a world he
+ couldn’t imagine existed. Take help of your uncle’s mysterious
+ inventions that let you jump incredibly high and far through beautiful
+ scenery, uncover clues to your uncle’s whereabouts, and meet fantastical
+ creatures that will help you on your journey.
+
+ The movement in A Story About My Uncle is a crucial part of its core
+ gameplay – focusing on swinging through the world with a grappling hook
+ that gives the player a wonderful sense of speed and freedom. Soar
+ through a game world with a unique art style and a mysterious story that
+ unravels before you.
+ </longdescription>
+</pkgmetadata>