summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2021-03-22 11:06:16 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-22 11:06:16 +0100
commitcb797361214a6547228ddb23a5c046e14a9fdbe5 (patch)
treec5bd143272ee82db5d2596b0cd9b7254da77d1ca /dev-vcs
parentdev-python/flit_core: Add python@ as co-maint (diff)
downloadgentoo-cb797361214a6547228ddb23a5c046e14a9fdbe5.tar.gz
gentoo-cb797361214a6547228ddb23a5c046e14a9fdbe5.tar.bz2
gentoo-cb797361214a6547228ddb23a5c046e14a9fdbe5.zip
dev-vcs/git: respect toolchain variables with USE=gnome-keyring
Closes: https://bugs.gentoo.org/762796 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git/git-2.26.2.ebuild8
-rw-r--r--dev-vcs/git/git-2.26.3.ebuild8
-rw-r--r--dev-vcs/git/git-2.28.1.ebuild8
-rw-r--r--dev-vcs/git/git-2.29.3.ebuild8
-rw-r--r--dev-vcs/git/git-2.30.2.ebuild8
-rw-r--r--dev-vcs/git/git-2.31.0-r1.ebuild8
-rw-r--r--dev-vcs/git/git-9999-r1.ebuild8
-rw-r--r--dev-vcs/git/git-9999-r2.ebuild8
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild8
-rw-r--r--dev-vcs/git/git-9999.ebuild8
10 files changed, 60 insertions, 20 deletions
diff --git a/dev-vcs/git/git-2.26.2.ebuild b/dev-vcs/git/git-2.26.2.ebuild
index c4ac2f48da97..f4c8b88dbf91 100644
--- a/dev-vcs/git/git-2.26.2.ebuild
+++ b/dev-vcs/git/git-2.26.2.ebuild
@@ -55,7 +55,10 @@ IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl
# Common to both DEPEND and RDEPEND
DEPEND="
- gnome-keyring? ( app-crypt/libsecret )
+ gnome-keyring? (
+ app-crypt/libsecret
+ dev-libs/glib:2
+ )
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
sys-libs/zlib
@@ -113,6 +116,7 @@ BDEPEND="
app-text/xmlto
sys-apps/texinfo
)
+ gnome-keyring? ( virtual/pkgconfig )
nls? ( sys-devel/gettext )
test? ( app-crypt/gnupg )
"
@@ -372,7 +376,7 @@ src_compile() {
if use gnome-keyring ; then
pushd contrib/credential/libsecret &>/dev/null || die
- git_emake || die "emake git-credential-libsecret failed"
+ git_emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" PKG_CONFIG="$(tc-getPKG_CONFIG)"
popd &>/dev/null || die
fi
diff --git a/dev-vcs/git/git-2.26.3.ebuild b/dev-vcs/git/git-2.26.3.ebuild
index 6932d90f123d..4bbcac28a0de 100644
--- a/dev-vcs/git/git-2.26.3.ebuild
+++ b/dev-vcs/git/git-2.26.3.ebuild
@@ -55,7 +55,10 @@ IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl
# Common to both DEPEND and RDEPEND
DEPEND="
- gnome-keyring? ( app-crypt/libsecret )
+ gnome-keyring? (
+ app-crypt/libsecret
+ dev-libs/glib:2
+ )
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
sys-libs/zlib
@@ -113,6 +116,7 @@ BDEPEND="
app-text/xmlto
sys-apps/texinfo
)
+ gnome-keyring? ( virtual/pkgconfig )
nls? ( sys-devel/gettext )
test? ( app-crypt/gnupg )
"
@@ -372,7 +376,7 @@ src_compile() {
if use gnome-keyring ; then
pushd contrib/credential/libsecret &>/dev/null || die
- git_emake || die "emake git-credential-libsecret failed"
+ git_emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" PKG_CONFIG="$(tc-getPKG_CONFIG)"
popd &>/dev/null || die
fi
diff --git a/dev-vcs/git/git-2.28.1.ebuild b/dev-vcs/git/git-2.28.1.ebuild
index d725b8e79c39..b52504ad1b28 100644
--- a/dev-vcs/git/git-2.28.1.ebuild
+++ b/dev-vcs/git/git-2.28.1.ebuild
@@ -55,7 +55,10 @@ IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl
# Common to both DEPEND and RDEPEND
DEPEND="
- gnome-keyring? ( app-crypt/libsecret )
+ gnome-keyring? (
+ app-crypt/libsecret
+ dev-libs/glib:2
+ )
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
sys-libs/zlib
@@ -113,6 +116,7 @@ BDEPEND="
app-text/xmlto
sys-apps/texinfo
)
+ gnome-keyring? ( virtual/pkgconfig )
nls? ( sys-devel/gettext )
test? ( app-crypt/gnupg )
"
@@ -372,7 +376,7 @@ src_compile() {
if use gnome-keyring ; then
pushd contrib/credential/libsecret &>/dev/null || die
- git_emake || die "emake git-credential-libsecret failed"
+ git_emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" PKG_CONFIG="$(tc-getPKG_CONFIG)"
popd &>/dev/null || die
fi
diff --git a/dev-vcs/git/git-2.29.3.ebuild b/dev-vcs/git/git-2.29.3.ebuild
index d73a1120a380..a5dd77688d1a 100644
--- a/dev-vcs/git/git-2.29.3.ebuild
+++ b/dev-vcs/git/git-2.29.3.ebuild
@@ -55,7 +55,10 @@ IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl
# Common to both DEPEND and RDEPEND
DEPEND="
- gnome-keyring? ( app-crypt/libsecret )
+ gnome-keyring? (
+ app-crypt/libsecret
+ dev-libs/glib:2
+ )
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
sys-libs/zlib
@@ -114,6 +117,7 @@ BDEPEND="
app-text/xmlto
sys-apps/texinfo
)
+ gnome-keyring? ( virtual/pkgconfig )
nls? ( sys-devel/gettext )
test? ( app-crypt/gnupg )
"
@@ -350,7 +354,7 @@ src_compile() {
if use gnome-keyring ; then
pushd contrib/credential/libsecret &>/dev/null || die
- git_emake || die "emake git-credential-libsecret failed"
+ git_emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" PKG_CONFIG="$(tc-getPKG_CONFIG)"
popd &>/dev/null || die
fi
diff --git a/dev-vcs/git/git-2.30.2.ebuild b/dev-vcs/git/git-2.30.2.ebuild
index f6a6fb30a9e9..4a85546fc4f9 100644
--- a/dev-vcs/git/git-2.30.2.ebuild
+++ b/dev-vcs/git/git-2.30.2.ebuild
@@ -55,7 +55,10 @@ IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl
# Common to both DEPEND and RDEPEND
DEPEND="
- gnome-keyring? ( app-crypt/libsecret )
+ gnome-keyring? (
+ app-crypt/libsecret
+ dev-libs/glib:2
+ )
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
sys-libs/zlib
@@ -114,6 +117,7 @@ BDEPEND="
app-text/xmlto
sys-apps/texinfo
)
+ gnome-keyring? ( virtual/pkgconfig )
nls? ( sys-devel/gettext )
test? ( app-crypt/gnupg )
"
@@ -350,7 +354,7 @@ src_compile() {
if use gnome-keyring ; then
pushd contrib/credential/libsecret &>/dev/null || die
- git_emake || die "emake git-credential-libsecret failed"
+ git_emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" PKG_CONFIG="$(tc-getPKG_CONFIG)"
popd &>/dev/null || die
fi
diff --git a/dev-vcs/git/git-2.31.0-r1.ebuild b/dev-vcs/git/git-2.31.0-r1.ebuild
index bfb176d4710e..b3036ae3ffcf 100644
--- a/dev-vcs/git/git-2.31.0-r1.ebuild
+++ b/dev-vcs/git/git-2.31.0-r1.ebuild
@@ -55,7 +55,10 @@ IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl
# Common to both DEPEND and RDEPEND
DEPEND="
- gnome-keyring? ( app-crypt/libsecret )
+ gnome-keyring? (
+ app-crypt/libsecret
+ dev-libs/glib:2
+ )
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
sys-libs/zlib
@@ -111,6 +114,7 @@ BDEPEND="
app-text/xmlto
sys-apps/texinfo
)
+ gnome-keyring? ( virtual/pkgconfig )
nls? ( sys-devel/gettext )
test? ( app-crypt/gnupg )
"
@@ -338,7 +342,7 @@ src_compile() {
if use gnome-keyring ; then
pushd contrib/credential/libsecret &>/dev/null || die
- git_emake || die "emake git-credential-libsecret failed"
+ git_emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" PKG_CONFIG="$(tc-getPKG_CONFIG)"
popd &>/dev/null || die
fi
diff --git a/dev-vcs/git/git-9999-r1.ebuild b/dev-vcs/git/git-9999-r1.ebuild
index ff37be69674c..367d7ed0beda 100644
--- a/dev-vcs/git/git-9999-r1.ebuild
+++ b/dev-vcs/git/git-9999-r1.ebuild
@@ -55,7 +55,10 @@ IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl
# Common to both DEPEND and RDEPEND
DEPEND="
- gnome-keyring? ( app-crypt/libsecret )
+ gnome-keyring? (
+ app-crypt/libsecret
+ dev-libs/glib:2
+ )
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
sys-libs/zlib
@@ -111,6 +114,7 @@ BDEPEND="
app-text/xmlto
sys-apps/texinfo
)
+ gnome-keyring? ( virtual/pkgconfig )
nls? ( sys-devel/gettext )
test? ( app-crypt/gnupg )
"
@@ -338,7 +342,7 @@ src_compile() {
if use gnome-keyring ; then
pushd contrib/credential/libsecret &>/dev/null || die
- git_emake || die "emake git-credential-libsecret failed"
+ git_emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" PKG_CONFIG="$(tc-getPKG_CONFIG)"
popd &>/dev/null || die
fi
diff --git a/dev-vcs/git/git-9999-r2.ebuild b/dev-vcs/git/git-9999-r2.ebuild
index ff37be69674c..367d7ed0beda 100644
--- a/dev-vcs/git/git-9999-r2.ebuild
+++ b/dev-vcs/git/git-9999-r2.ebuild
@@ -55,7 +55,10 @@ IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl
# Common to both DEPEND and RDEPEND
DEPEND="
- gnome-keyring? ( app-crypt/libsecret )
+ gnome-keyring? (
+ app-crypt/libsecret
+ dev-libs/glib:2
+ )
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
sys-libs/zlib
@@ -111,6 +114,7 @@ BDEPEND="
app-text/xmlto
sys-apps/texinfo
)
+ gnome-keyring? ( virtual/pkgconfig )
nls? ( sys-devel/gettext )
test? ( app-crypt/gnupg )
"
@@ -338,7 +342,7 @@ src_compile() {
if use gnome-keyring ; then
pushd contrib/credential/libsecret &>/dev/null || die
- git_emake || die "emake git-credential-libsecret failed"
+ git_emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" PKG_CONFIG="$(tc-getPKG_CONFIG)"
popd &>/dev/null || die
fi
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index c60eee31d41d..2b86230aabea 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -55,7 +55,10 @@ IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl
# Common to both DEPEND and RDEPEND
DEPEND="
- gnome-keyring? ( app-crypt/libsecret )
+ gnome-keyring? (
+ app-crypt/libsecret
+ dev-libs/glib:2
+ )
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
sys-libs/zlib
@@ -111,6 +114,7 @@ BDEPEND="
app-text/xmlto
sys-apps/texinfo
)
+ gnome-keyring? ( virtual/pkgconfig )
nls? ( sys-devel/gettext )
test? ( app-crypt/gnupg )
"
@@ -338,7 +342,7 @@ src_compile() {
if use gnome-keyring ; then
pushd contrib/credential/libsecret &>/dev/null || die
- git_emake || die "emake git-credential-libsecret failed"
+ git_emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" PKG_CONFIG="$(tc-getPKG_CONFIG)"
popd &>/dev/null || die
fi
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index ef8a11391cf3..37136eafce08 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -55,7 +55,10 @@ IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl
# Common to both DEPEND and RDEPEND
DEPEND="
- gnome-keyring? ( app-crypt/libsecret )
+ gnome-keyring? (
+ app-crypt/libsecret
+ dev-libs/glib:2
+ )
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
sys-libs/zlib
@@ -111,6 +114,7 @@ BDEPEND="
app-text/xmlto
sys-apps/texinfo
)
+ gnome-keyring? ( virtual/pkgconfig )
nls? ( sys-devel/gettext )
test? ( app-crypt/gnupg )
"
@@ -338,7 +342,7 @@ src_compile() {
if use gnome-keyring ; then
pushd contrib/credential/libsecret &>/dev/null || die
- git_emake || die "emake git-credential-libsecret failed"
+ git_emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" PKG_CONFIG="$(tc-getPKG_CONFIG)"
popd &>/dev/null || die
fi