summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2023-06-01 13:10:00 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2023-06-01 13:11:47 -0400
commit03e86ab117eff577e520b7537b79adfb23f6b1b0 (patch)
tree974cdaf3b4b5672dc0acea44947b3a18a2e92a08 /dev-vcs
parentsys-fs/fuse-overlayfs: Stabilize 1.11 amd64, #907645 (diff)
downloadgentoo-03e86ab117eff577e520b7537b79adfb23f6b1b0.tar.gz
gentoo-03e86ab117eff577e520b7537b79adfb23f6b1b0.tar.bz2
gentoo-03e86ab117eff577e520b7537b79adfb23f6b1b0.zip
dev-vcs/fossil: add 2.22
Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/fossil/Manifest1
-rw-r--r--dev-vcs/fossil/fossil-2.22.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-vcs/fossil/Manifest b/dev-vcs/fossil/Manifest
index 9c719a6045e3..5a76766833a5 100644
--- a/dev-vcs/fossil/Manifest
+++ b/dev-vcs/fossil/Manifest
@@ -1,2 +1,3 @@
DIST fossil-src-2.19.tar.gz 6435868 BLAKE2B 414dd8b1630bb6a8bcc22f3528da60386663e7f31191e5134474e37211e55323af45947452a0f09e21964dd3cd94ca6cf6e34ecd74e0d3e4f0dce7a50146f0ff SHA512 fcd84df2d84c3a958bb19228de4320456382d3c925717c58bec42de86d96383a9208fb31ba6aaeccd9bc6bba949048d5c1ce3d2b3e8535951956ae18d9aa34e4
DIST fossil-src-2.21.tar.gz 6703622 BLAKE2B fcc74ed5e3eec34f044624b128b8933b54d1cea99a212a1423e369fc469af4634f469f8c9c20af768c41edc9f1ec2592a074f87dadd5b9b90805906451268f0e SHA512 22534eb632f485de895b291a35325efe9bfd13ec0df84e94afe822593489ecdb2998352dcd501123d8d4c426a40bd4ff43190b50fb849392f886dd94bee42bf3
+DIST fossil-src-2.22.tar.gz 6730858 BLAKE2B 3f0108dfb5802c61d107a6318acd11061c8311f112376c8c96645d6b0de1441b3ec745fcb2e2ec3888ed15ca89f4a2af535f61edcc6f4b5944d81d381f522935 SHA512 99a456301ae4ac72449985ff3b8b2139b805ff84e27ffe4325bad0c90643dd51c655b0210cbfa290a621e33e42e1e35b75a6cdc1beb093221d2b5d23d64591bc
diff --git a/dev-vcs/fossil/fossil-2.22.ebuild b/dev-vcs/fossil/fossil-2.22.ebuild
new file mode 100644
index 000000000000..86f354db77d4
--- /dev/null
+++ b/dev-vcs/fossil/fossil-2.22.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_TAG="66ee0beb9b47d827bde533fe6a1fb2ead4ceb1936468881b4fb621bd6bdfd862"
+
+DESCRIPTION="Simple, high-reliability, source control management, and more"
+HOMEPAGE="https://www.fossil-scm.org/home"
+SRC_URI="https://fossil-scm.org/home/tarball/${MY_TAG}/fossil-src-${PV}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~x86"
+IUSE="debug fusefs json system-sqlite +ssl static tcl tcl-stubs
+ tcl-private-stubs th1-docs th1-hooks"
+
+# Please check sqlite minimum version on every release. This can be done with:
+# ./configure --print-minimum-sqlite-version
+RDEPEND="
+ sys-libs/zlib
+ || (
+ sys-libs/readline:0
+ dev-libs/libedit
+ )
+ system-sqlite? ( >=dev-db/sqlite-3.38.0:3 )
+ ssl? ( dev-libs/openssl:0= )
+ tcl? ( dev-lang/tcl:0= )
+"
+
+# Either tcl or jimtcl need to be present to build Fossil (Bug #675778)
+DEPEND="${RDEPEND}
+ !tcl? (
+ || (
+ dev-lang/tcl:*
+ dev-lang/jimtcl:*
+ )
+ )
+"
+
+# Tests can't be run from the build directory
+RESTRICT="test"
+
+PATCHES=(
+ # fossil-2.10-check-lib64-for-tcl.patch: Bug 690828
+ "${FILESDIR}"/fossil-2.10-check-lib64-for-tcl.patch
+)
+
+S="${WORKDIR}/fossil-src-${PV}"
+
+src_configure() {
+ # this is not an autotools situation so don't make it seem like one
+ # --with-tcl: works
+ # --without-tcl: dies
+ local myconf="--with-openssl=$(usex ssl auto none)"
+ use debug && myconf+=' --fossil-debug'
+ use json && myconf+=' --json'
+ use system-sqlite && myconf+=' --disable-internal-sqlite'
+ use static && myconf+=' --static'
+ use tcl && myconf+=' --with-tcl=1'
+ use fusefs || myconf+=' --disable-fusefs'
+
+ local u useflags
+ useflags=( tcl-stubs tcl-private-stubs th1-docs th1-hooks )
+ for u in ${useflags[@]} ; do
+ use ${u} && myconf+=" --with-${u}"
+ done
+
+ tc-export CC CXX
+ CC_FOR_BUILD=${CC} ./configure ${myconf} || die
+}
+
+src_install() {
+ dobin fossil
+}