summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFilip Kobierski <fkobi@pm.me>2024-11-06 17:13:54 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-11-07 15:59:19 +0200
commitf2aa451ce8185ca310a5bc2f199117d942216772 (patch)
tree8e67c46e6ff4f952b9eee7ce406621bf6e4ce7d6 /dev-util
parentdev-util/repolite: add sphinx to RDEPEND & more (diff)
downloadgentoo-f2aa451ce8185ca310a5bc2f199117d942216772.tar.gz
gentoo-f2aa451ce8185ca310a5bc2f199117d942216772.tar.bz2
gentoo-f2aa451ce8185ca310a5bc2f199117d942216772.zip
dev-util/repolite: drop 0.6.2-r0
Closes: https://bugs.gentoo.org/942940 Signed-off-by: Filip Kobierski <fkobi@pm.me> Closes: https://github.com/gentoo/gentoo/pull/39221 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/repolite/repolite-0.6.2.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-util/repolite/repolite-0.6.2.ebuild b/dev-util/repolite/repolite-0.6.2.ebuild
deleted file mode 100644
index 427603038c28..000000000000
--- a/dev-util/repolite/repolite-0.6.2.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Manage a small set of git repository dependencies with YAML."
-HOMEPAGE="https://github.com/sarnold/repolite"
-
-if [[ ${PV} = 9999* ]]; then
- EGIT_REPO_URI="https://github.com/sarnold/repolite.git"
- EGIT_BRANCH="master"
- inherit git-r3
-else
- SRC_URI="https://github.com/sarnold/repolite/releases/download/${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
-fi
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-IUSE="doc"
-RESTRICT="test" # no tests :(
-
-RDEPEND="
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/munch[${PYTHON_USEDEP}]
- dev-vcs/git
-"
-# needs versioningit if building from git repo source
-if [[ ${PV} = 9999* ]]; then
- BDEPEND="$(python_gen_any_dep '>=dev-python/versioningit-2.0.1[${PYTHON_USEDEP}]')"
-fi
-
-DOCS=( README.rst )
-
-distutils_enable_sphinx \
- docs/source \
- dev-python/sphinx-rtd-theme \
- dev-python/recommonmark \
- dev-python/sphinxcontrib-apidoc
-
-pkg_postinst() {
- optfeature "initialize repos with lfs files" dev-vcs/git-lfs
-}