summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-09-15 20:57:01 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-09-15 20:57:43 -0500
commit83ab9587be9f89e667506b861208d613a2f016e5 (patch)
tree5ea43f6ccdba0744bb9473c3b4b7e073f27d5b16 /dev-util/webhook/webhook-2.7.0.ebuild
parentapp-shells/zsh: add link to upstream patch submission (diff)
downloadgentoo-83ab9587be9f89e667506b861208d613a2f016e5.tar.gz
gentoo-83ab9587be9f89e667506b861208d613a2f016e5.tar.bz2
gentoo-83ab9587be9f89e667506b861208d613a2f016e5.zip
dev-util/webhook: update SRC_URI
Closes: https://bugs.gentoo.org/844454 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/webhook/webhook-2.7.0.ebuild')
-rw-r--r--dev-util/webhook/webhook-2.7.0.ebuild47
1 files changed, 5 insertions, 42 deletions
diff --git a/dev-util/webhook/webhook-2.7.0.ebuild b/dev-util/webhook/webhook-2.7.0.ebuild
index 60558169169b..26bab00698ef 100644
--- a/dev-util/webhook/webhook-2.7.0.ebuild
+++ b/dev-util/webhook/webhook-2.7.0.ebuild
@@ -1,8 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-EGO_PN=github.com/adnanh/webhook
inherit go-module
DESCRIPTION="lightweight incoming webhook server to run shell commands"
@@ -12,45 +11,7 @@ if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/adnanh/webhook/"
else
-EGO_SUM=(
- "github.com/clbanning/mxj v1.8.4" # SPDX:MIT,BSD-3-Clause
- "github.com/clbanning/mxj v1.8.4/go.mod"
- "github.com/dustin/go-humanize v1.0.0" # SPDX:MIT
- "github.com/dustin/go-humanize v1.0.0/go.mod"
- "github.com/fsnotify/fsnotify v1.4.7" # SPDX:BSD-3-Clause
- "github.com/fsnotify/fsnotify v1.4.7/go.mod"
- "github.com/ghodss/yaml v1.0.0" # SPDX:MIT,BSD-3-Clause
- "github.com/ghodss/yaml v1.0.0/go.mod"
- "github.com/go-chi/chi v4.0.2+incompatible" # SPDX:MIT
- "github.com/go-chi/chi v4.0.2+incompatible/go.mod"
- "github.com/gofrs/uuid v3.2.0+incompatible" # SPDX:MIT
- "github.com/gofrs/uuid v3.2.0+incompatible/go.mod"
- "github.com/gorilla/mux v1.7.3" # SPDX:BSD-3-Clause
- "github.com/gorilla/mux v1.7.3/go.mod"
- "github.com/kr/pretty v0.1.0" # SPDX:MIT
- "github.com/kr/pretty v0.1.0/go.mod"
- "github.com/kr/pty v1.1.1/go.mod" # SPDX:MIT
- "github.com/kr/text v0.1.0" # SPDX:MIT
- "github.com/kr/text v0.1.0/go.mod"
- "golang.org/x/crypto v0.0.0-20190308221718-c2843e01d9a2/go.mod"
- "golang.org/x/net v0.0.0-20191209160850-c0dbc17a3553" # SPDX:BSD-3-Clause
- "golang.org/x/net v0.0.0-20191209160850-c0dbc17a3553/go.mod"
- "golang.org/x/sys v0.0.0-20190215142949-d0b11bdaac8a" # SPDX:BSD-3-Clause
- "golang.org/x/sys v0.0.0-20190215142949-d0b11bdaac8a/go.mod"
- "golang.org/x/sys v0.0.0-20191228213918-04cbcbbfeed8" # SPDX:BSD-3-Clause
- "golang.org/x/sys v0.0.0-20191228213918-04cbcbbfeed8/go.mod"
- "golang.org/x/text v0.3.0" # SPDX:BSD-3-Clause
- "golang.org/x/text v0.3.0/go.mod"
- "gopkg.in/check.v1 v1.0.0-20190902080502-41f04d3bba15" # SPDX:BSD-2-Clause
- "gopkg.in/check.v1 v1.0.0-20190902080502-41f04d3bba15/go.mod"
- "gopkg.in/fsnotify.v1 v1.4.2" # SPDX:BSD-3-Clause
- "gopkg.in/fsnotify.v1 v1.4.2/go.mod"
- "gopkg.in/yaml.v2 v2.0.0-20170812160011-eb3733d160e7" # SPDX:Apache-2.0
- "gopkg.in/yaml.v2 v2.0.0-20170812160011-eb3733d160e7/go.mod"
-)
-go-module_set_globals
- SRC_URI="https://github.com/adnanh/webhook/archive/${PV}.tar.gz -> ${P}.tar.gz
- ${EGO_SUM_SRC_URI}"
+ SRC_URI="https://github.com/adnanh/webhook/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
S="${WORKDIR}/webhook-${PV}"
fi
@@ -92,7 +53,9 @@ src_unpack() {
src_compile() {
# Golang LDFLAGS are not the same as GCC/Binutils LDFLAGS
unset LDFLAGS
- go build
+ # -mod=vendor is needed because the go version specified in go.mod
+ # is too low.
+ ego build -mod=vendor
}
src_install() {