summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-06-22 09:21:36 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-06-22 09:21:44 +0100
commit3abf285d96a21f56f86e1fdf7814d186bef3c374 (patch)
tree2be9b992604915348ee7f660f4b383a39cd78001 /dev-util/radare2
parentdev-util/radare2: fix double-free in cmd_mount.c, bug #688336 (diff)
downloadgentoo-3abf285d96a21f56f86e1fdf7814d186bef3c374.tar.gz
gentoo-3abf285d96a21f56f86e1fdf7814d186bef3c374.tar.bz2
gentoo-3abf285d96a21f56f86e1fdf7814d186bef3c374.zip
dev-util/radare2: drop old, bug #688336
Reported-by: D'juan McDonald (domhnall) Bug: https://bugs.gentoo.org/688336 Package-Manager: Portage-2.3.67, Repoman-2.3.15 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util/radare2')
-rw-r--r--dev-util/radare2/Manifest2
-rw-r--r--dev-util/radare2/radare2-3.4.1.ebuild62
-rw-r--r--dev-util/radare2/radare2-3.5.0.ebuild56
-rw-r--r--dev-util/radare2/radare2-3.5.1.ebuild56
4 files changed, 0 insertions, 176 deletions
diff --git a/dev-util/radare2/Manifest b/dev-util/radare2/Manifest
index 0f14baa31982..1170aab8afed 100644
--- a/dev-util/radare2/Manifest
+++ b/dev-util/radare2/Manifest
@@ -1,3 +1 @@
-DIST radare2-3.4.1.tar.gz 7034801 BLAKE2B 7747af8e51c1120ef683884950e0e9e7581627906487449c81decd25b4d4a8ee5222892c42ba66d1a1d0b373b71ee6bf967df6ef117d30b171cf31740ac3058b SHA512 8803d54a8158aedd5900792bd013dad440a14abbb6fcbdf963e5d9031f30e66865479f29877e6f656ab01b59b3138458daf52f1eaeb462ec767c128d0b12640a
-DIST radare2-3.5.0.tar.gz 7076871 BLAKE2B 1877fb03006d5b5a3cb7e8f16ba28544c9f490f003c1a0c015ebadc64a80b15cab94aaf4640508fee53a007f06e3edb9e7b963826c2e462b53391e6eab103bfb SHA512 c2aaf6c258428987ad9c029f0bc3961503a7d505b422a97da1fd53bed8c0048955d0710958b7693f603002b62f64c7e0e2695256dfa2c3d629cf7080fbe267bd
DIST radare2-3.5.1.tar.gz 7083677 BLAKE2B 3d84e79d4e20e031b6cfdbabcf80922f977328bf7da8c2871924f9520ff87252d4df18a1239793c70f4b800bb7d5c4aef923e63c93aa15d86ae685ddda205da2 SHA512 24c2a45ed539830dcb8dc1585c27e45515c70989132f500527db0ca6795027eaa82ea54d1cd7fc73ddc49641a73148be963ade1648e92b5336d2e86335e2497a
diff --git a/dev-util/radare2/radare2-3.4.1.ebuild b/dev-util/radare2/radare2-3.4.1.ebuild
deleted file mode 100644
index c746c047f48a..000000000000
--- a/dev-util/radare2/radare2-3.4.1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit bash-completion-r1 eutils
-
-DESCRIPTION="unix-like reverse engineering framework and commandline tools"
-HOMEPAGE="http://www.radare.org"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/radare/radare2"
-else
- SRC_URI="https://github.com/radare/radare2/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="ssl libressl"
-
-RDEPEND="
- dev-libs/capstone:0=
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-src_configure() {
- econf \
- --without-libuv \
- --with-syscapstone \
- $(use_with ssl openssl)
-}
-
-src_compile() {
- # bug #682564: upstream build system has a problem with
- # 'hexagon_disas.o'. Workaround it until the fix is found.
- emake -j1
-}
-
-src_install() {
- default
-
- insinto /usr/share/zsh/site-functions
- doins doc/zsh/_*
-
- newbashcomp doc/bash_autocompletion.sh "${PN}"
- bashcomp_alias "${PN}" rafind2 r2 rabin2 rasm2 radiff2
-
- # a workaround for unstable $(INSTALL) call, bug #574866
- local d
- for d in doc/*; do
- if [[ -d $d ]]; then
- rm -rfv "$d" || die "failed to delete '$d'"
- fi
- done
-}
diff --git a/dev-util/radare2/radare2-3.5.0.ebuild b/dev-util/radare2/radare2-3.5.0.ebuild
deleted file mode 100644
index 0b3f4cfb432b..000000000000
--- a/dev-util/radare2/radare2-3.5.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit bash-completion-r1 eutils
-
-DESCRIPTION="unix-like reverse engineering framework and commandline tools"
-HOMEPAGE="http://www.radare.org"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/radare/radare2"
-else
- SRC_URI="https://github.com/radare/radare2/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="ssl libressl"
-
-RDEPEND="
- dev-libs/capstone:0=
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-src_configure() {
- econf \
- --without-libuv \
- --with-syscapstone \
- $(use_with ssl openssl)
-}
-
-src_install() {
- default
-
- insinto /usr/share/zsh/site-functions
- doins doc/zsh/_*
-
- newbashcomp doc/bash_autocompletion.sh "${PN}"
- bashcomp_alias "${PN}" rafind2 r2 rabin2 rasm2 radiff2
-
- # a workaround for unstable $(INSTALL) call, bug #574866
- local d
- for d in doc/*; do
- if [[ -d $d ]]; then
- rm -rfv "$d" || die "failed to delete '$d'"
- fi
- done
-}
diff --git a/dev-util/radare2/radare2-3.5.1.ebuild b/dev-util/radare2/radare2-3.5.1.ebuild
deleted file mode 100644
index 0b3f4cfb432b..000000000000
--- a/dev-util/radare2/radare2-3.5.1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit bash-completion-r1 eutils
-
-DESCRIPTION="unix-like reverse engineering framework and commandline tools"
-HOMEPAGE="http://www.radare.org"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/radare/radare2"
-else
- SRC_URI="https://github.com/radare/radare2/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="ssl libressl"
-
-RDEPEND="
- dev-libs/capstone:0=
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-src_configure() {
- econf \
- --without-libuv \
- --with-syscapstone \
- $(use_with ssl openssl)
-}
-
-src_install() {
- default
-
- insinto /usr/share/zsh/site-functions
- doins doc/zsh/_*
-
- newbashcomp doc/bash_autocompletion.sh "${PN}"
- bashcomp_alias "${PN}" rafind2 r2 rabin2 rasm2 radiff2
-
- # a workaround for unstable $(INSTALL) call, bug #574866
- local d
- for d in doc/*; do
- if [[ -d $d ]]; then
- rm -rfv "$d" || die "failed to delete '$d'"
- fi
- done
-}