summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-08-21 09:55:05 +0200
committerDavid Seifert <soap@gentoo.org>2019-08-21 09:55:05 +0200
commitc5f52da183f75cb3fc2a1afdfadc7e1aa08109ba (patch)
treeac8e2ee40bc27c955e4c88fef5b40053be9220c1 /dev-util/pscan
parentmedia-libs/libraw: Bump to version 0.19.5 (diff)
downloadgentoo-c5f52da183f75cb3fc2a1afdfadc7e1aa08109ba.tar.gz
gentoo-c5f52da183f75cb3fc2a1afdfadc7e1aa08109ba.tar.bz2
gentoo-c5f52da183f75cb3fc2a1afdfadc7e1aa08109ba.zip
dev-util/pscan: Port to EAPI 7
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-util/pscan')
-rw-r--r--dev-util/pscan/Manifest2
-rw-r--r--dev-util/pscan/files/pscan-20000721-fix-build-system.patch20
-rw-r--r--dev-util/pscan/pscan-20000721-r1.ebuild21
3 files changed, 30 insertions, 13 deletions
diff --git a/dev-util/pscan/Manifest b/dev-util/pscan/Manifest
index 3b1dc0e4df0c..8acbd564f998 100644
--- a/dev-util/pscan/Manifest
+++ b/dev-util/pscan/Manifest
@@ -1 +1 @@
-DIST pscan.tar.gz 14555 BLAKE2B 8e1a8ea91bc2a1b323dc607f703565579e596a3001151609e46a09160766b3b913610a15b64859dc88031a3acf2e3c147dcbd7b033517d3786976ab3cb1bc9f4 SHA512 83196cc9c450217fc2287d38fd1a0b9d1d9951b8f6328b6b9f7f50b680f653b099af04d4c448f3cb2b2a96871eec8772557851e887faa2f41dc259f01c031e78
+DIST pscan-20000721.tar.gz 14555 BLAKE2B 8e1a8ea91bc2a1b323dc607f703565579e596a3001151609e46a09160766b3b913610a15b64859dc88031a3acf2e3c147dcbd7b033517d3786976ab3cb1bc9f4 SHA512 83196cc9c450217fc2287d38fd1a0b9d1d9951b8f6328b6b9f7f50b680f653b099af04d4c448f3cb2b2a96871eec8772557851e887faa2f41dc259f01c031e78
diff --git a/dev-util/pscan/files/pscan-20000721-fix-build-system.patch b/dev-util/pscan/files/pscan-20000721-fix-build-system.patch
new file mode 100644
index 000000000000..cd22fc2eb195
--- /dev/null
+++ b/dev-util/pscan/files/pscan-20000721-fix-build-system.patch
@@ -0,0 +1,20 @@
+--- a/Makefile
++++ b/Makefile
+@@ -13,16 +13,10 @@
+ #CC=gcc -Wall -g
+ #LEX=flex
+
+-pscan: scanner.yy.o pscan.o
+- $(CC) scanner.yy.o pscan.o -o pscan
+-
+-scanner.yy.o: scanner.yy.c
+- $(CC) -c scanner.yy.c -o scanner.yy.o
++pscan: scanner.yy.o
+
+ scanner.yy.c: scanner.l
+ $(LEX) -t scanner.l > scanner.yy.c
+
+-pscan.o: pscan.c pscan.h
+-
+ clean:
+ rm -f *.o *~ pscan scanner.yy.c core
diff --git a/dev-util/pscan/pscan-20000721-r1.ebuild b/dev-util/pscan/pscan-20000721-r1.ebuild
index 11c078d3650b..e63242af2bde 100644
--- a/dev-util/pscan/pscan-20000721-r1.ebuild
+++ b/dev-util/pscan/pscan-20000721-r1.ebuild
@@ -1,34 +1,31 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
inherit toolchain-funcs
DESCRIPTION="A limited problem scanner for C source files"
HOMEPAGE="http://www.striker.ottawa.on.ca/~aland/pscan/"
-# I wish upstream would version their files, even if it's only with a date
-SRC_URI="http://www.striker.ottawa.on.ca/~aland/pscan/pscan.tar.gz"
+SRC_URI="mirror://gentoo/pscan.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE=""
-
# Does NOT contain a testsuite, but does contain a test.c that confuses src_test
RESTRICT="test"
-RDEPEND=""
-DEPEND="${RDEPEND}
- sys-devel/flex"
+BDEPEND="sys-devel/flex"
S="${WORKDIR}/${PN}"
+PATCHES=( "${FILESDIR}"/${P}-fix-build-system.patch )
-src_compile() {
- emake CC="$(tc-getCC) ${CFLAGS}" || die
+src_configure() {
+ tc-export CC
}
src_install() {
- newbin pscan printf-scan || die
- dodoc README find_formats.sh test.c wu-ftpd.pscan || die
+ newbin pscan printf-scan
+ dodoc README find_formats.sh test.c wu-ftpd.pscan
}