summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-04-20 23:24:11 +0300
committerMart Raudsepp <leio@gentoo.org>2018-04-20 23:26:00 +0300
commit4bc469862c7ef1ea2adb4bd572ae452494577802 (patch)
tree3b359c2350dd65ed4e1abe1f7b5a7d81140a2cca /dev-util/glade
parentx11-terms/tilda: epatch->PATCHES=() (diff)
downloadgentoo-4bc469862c7ef1ea2adb4bd572ae452494577802.tar.gz
gentoo-4bc469862c7ef1ea2adb4bd572ae452494577802.tar.bz2
gentoo-4bc469862c7ef1ea2adb4bd572ae452494577802.zip
dev-util/glade: bump to 3.20.4
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'dev-util/glade')
-rw-r--r--dev-util/glade/Manifest1
-rw-r--r--dev-util/glade/glade-3.20.4.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/dev-util/glade/Manifest b/dev-util/glade/Manifest
index 99cf143707a9..4a26e8fc1aaa 100644
--- a/dev-util/glade/Manifest
+++ b/dev-util/glade/Manifest
@@ -1 +1,2 @@
DIST glade-3.20.2.tar.xz 3535064 BLAKE2B 33e5e9477556ac5f645cf13658ff1eebdaf046c1bbbcf5ac528c00f9b5f76943ede8140cc6a3b73dc27ed96c363208700031306f19478ba0e9e2fbae8319f500 SHA512 45f850ed4d409aaf11153da45398e7974d7b85235bf5d5043bc11755c3e4d1201f59ed854786162a7414f0521c818982560d4e226f93625b9253dc598793118a
+DIST glade-3.20.4.tar.xz 3534860 BLAKE2B f502e863f9acbd6580c043ff82dffb84ea8fdb833c0b6fdb8bbeeb7a7056a79416f1140472d23e0cdb14ed3bd06e17fca93ea663af690451001909aa4abfe478 SHA512 3da7781f74fa80e21336e49b9b36cf73b88ec9cf6f66a5c0e5d48ebc3382d87f5eb981b924704f04dfa4931e5691928a20c7cc73cca5b5f3a32e2348d6b87802
diff --git a/dev-util/glade/glade-3.20.4.ebuild b/dev-util/glade/glade-3.20.4.ebuild
new file mode 100644
index 000000000000..243a72912856
--- /dev/null
+++ b/dev-util/glade/glade-3.20.4.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1 versionator virtualx
+
+DESCRIPTION="A user interface designer for GTK+ and GNOME"
+HOMEPAGE="https://glade.gnome.org/"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="3.10/6" # subslot = suffix of libgladeui-2.so
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+
+IUSE="debug +introspection python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/atk[introspection?]
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/libxml2-2.4.0:2
+ x11-libs/cairo:=
+ x11-libs/gdk-pixbuf:2[introspection?]
+ >=x11-libs/gtk+-3.20.0:3[introspection?]
+ x11-libs/pango[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.32:= )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/pygobject-3.8:3[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.13
+ >=dev-util/intltool-0.41.0
+ dev-util/itstool
+ virtual/pkgconfig
+
+ dev-libs/gobject-introspection-common
+ gnome-base/gnome-common
+"
+# eautoreconf requires:
+# dev-libs/gobject-introspection-common
+# gnome-base/gnome-common
+
+PATCHES=(
+ # To avoid file collison with other slots, rename help module.
+ # Prevent the UI from loading glade:3's gladeui devhelp documentation.
+ "${FILESDIR}"/${PN}-3.14.1-doc-version.patch
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --enable-gladeui \
+ --enable-libtool-lock \
+ $(usex debug --enable-debug ' ') \
+ $(use_enable introspection) \
+ $(use_enable python)
+}
+
+src_test() {
+ virtx emake check
+}
+
+src_install() {
+ # modify Name in .desktop file to avoid confusion with other slots
+ sed -e 's:^\(Name.*=Glade\):\1 '$(get_version_component_range 1-2): \
+ -i data/glade.desktop || die "sed of data/glade.desktop failed"
+ # modify name in .devhelp2 file to avoid shadowing with glade:3 docs
+ sed -e 's:name="gladeui":name="gladeui-2":' \
+ -i doc/html/gladeui.devhelp2 || die "sed of gladeui.devhelp2 failed"
+ gnome2_src_install
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if ! has_version dev-util/devhelp ; then
+ elog "You may want to install dev-util/devhelp for integration API"
+ elog "documentation support."
+ fi
+}