summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2022-05-29 16:36:11 -0700
committerBrian Dolbec <dolsen@gentoo.org>2022-05-29 17:11:16 -0700
commitc48a2baf347591248febbd9c6c331e94ab51c19a (patch)
treed3357df838a80a18fd0ca8de1539bf52e7927954 /dev-util/buildbot-www
parentdev-util/buildbot-pkg: Bump to 3.5.0 (diff)
downloadgentoo-c48a2baf347591248febbd9c6c331e94ab51c19a.tar.gz
gentoo-c48a2baf347591248febbd9c6c331e94ab51c19a.tar.bz2
gentoo-c48a2baf347591248febbd9c6c331e94ab51c19a.zip
dev-util/buildbot-www: Bump to 3.5.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util/buildbot-www')
-rw-r--r--dev-util/buildbot-www/Manifest1
-rw-r--r--dev-util/buildbot-www/buildbot-www-3.5.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/buildbot-www/Manifest b/dev-util/buildbot-www/Manifest
index b9cf8773bb60..897fedc4a878 100644
--- a/dev-util/buildbot-www/Manifest
+++ b/dev-util/buildbot-www/Manifest
@@ -1 +1,2 @@
DIST buildbot-www-3.4.0.tar.gz 3182445 BLAKE2B 350606158ae68aba1b82c43d202e6140f433905e9913c7f4fcd3f4ebd328f7b70940f0a4e76a4a1f89731f6364dd285f08052bd1d96badac4e69cd1e16643d4e SHA512 7be83f35b6042accae77db1133d54282d0d27ce15a9b34220cc015255935d7463c1a327ee289740325bbb73d6a6a162f384da2b3cc731719e7f99a911faf86cd
+DIST buildbot-www-3.5.0.tar.gz 3182531 BLAKE2B dcdd6487eff9d9a0429554d79f9ee83a9086dee3524b49fa8362085dddb969e088373a843a9d872e16d18350e1623ba65258799b9b93327e218f760540ece4fa SHA512 f40101624cf14f88f2796855845d13ee81471d7a1b4911461747aa073735352f21294c17f3a011229c5e1c99867013ff4b306bf32c2c37b3c57d530a6fccc01e
diff --git a/dev-util/buildbot-www/buildbot-www-3.5.0.ebuild b/dev-util/buildbot-www/buildbot-www-3.5.0.ebuild
new file mode 100644
index 000000000000..c63f1d6ffe14
--- /dev/null
+++ b/dev-util/buildbot-www/buildbot-www-3.5.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="BuildBot base web interface, use with buildbot-{console-view,waterfall-view}..."
+HOMEPAGE="https://buildbot.net/
+ https://github.com/buildbot/buildbot
+ https://pypi.org/project/buildbot-www/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~amd64-linux ~x86-linux"
+
+RDEPEND="~dev-util/buildbot-pkg-${PV}[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"