summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/bibtex2html
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/bibtex2html')
-rw-r--r--dev-tex/bibtex2html/Manifest2
-rw-r--r--dev-tex/bibtex2html/bibtex2html-1.97.ebuild58
-rw-r--r--dev-tex/bibtex2html/bibtex2html-1.98.ebuild58
-rw-r--r--dev-tex/bibtex2html/files/bibtex2html-1.88-destdir.patch40
-rw-r--r--dev-tex/bibtex2html/metadata.xml6
5 files changed, 164 insertions, 0 deletions
diff --git a/dev-tex/bibtex2html/Manifest b/dev-tex/bibtex2html/Manifest
new file mode 100644
index 000000000000..fd578ed706c7
--- /dev/null
+++ b/dev-tex/bibtex2html/Manifest
@@ -0,0 +1,2 @@
+DIST bibtex2html-1.97.tar.gz 94887 SHA256 99b5b66a729fd2928ee4d9d7d8397e36b684def4be9ee2746233006501c8e314 SHA512 001611bd763e4d91a926bc230341983b7feb1dd59687e1d64896607be54b206878ba4e163750b2d3f88e2e16cdac53a0e2ea70cc6e7ccf57262e368a7b067208 WHIRLPOOL d4531578214f4f21b44572750bdb7a69fa456303ee0876576b09f91504163b7aa3a72f30d6074a684634348d74a1dde7cc8fbcec31019be44b75835a0251b715
+DIST bibtex2html-1.98.tar.gz 92719 SHA256 e925a0b97bf87a14bcbda95cac269835cd5ae0173504261f2c60e3c46a8706d6 SHA512 7d8480ed87bef74a1e0c970446fba4d30b103df3e78f127a051efff875032ac7f52d3d6baab0c6a2fc67ca11f3d558d7be4439311934f99067993b5891ff6ad4 WHIRLPOOL e0a56cf31090012305140e11f46191a50d4949fbee1d179cdb9f56e216e5fcae05f60e4457de88cbc771a512f3b7b054a781ee604a1b25640eb810ff33224f1a
diff --git a/dev-tex/bibtex2html/bibtex2html-1.97.ebuild b/dev-tex/bibtex2html/bibtex2html-1.97.ebuild
new file mode 100644
index 000000000000..1488091b23e5
--- /dev/null
+++ b/dev-tex/bibtex2html/bibtex2html-1.97.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+IUSE="doc +ocamlopt"
+
+DESCRIPTION="A bibtex to HTML converter"
+SRC_URI="http://www.lri.fr/~filliatr/ftp/bibtex2html/${P}.tar.gz"
+HOMEPAGE="http://www.lri.fr/~filliatr/bibtex2html/"
+
+SLOT="0"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+RESTRICT="test"
+
+# With use doc we need a latex compiler to generate manual.pdf
+# hevea is used for manual.html
+# manual.tex needs fullpage.sty
+DEPEND=">=dev-lang/ocaml-3.10:=[ocamlopt?]
+ doc? ( virtual/latex-base
+ dev-texlive/texlive-latexextra
+ dev-tex/hevea )"
+# We need tex-base for bibtex but also some bibtex styles, so we use latex-base
+RDEPEND="virtual/latex-base"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.88-destdir.patch"
+ # Avoid pre-stripped files
+ sed -i -e "s/strip/true/" Makefile.in
+ # For make install
+ use ocamlopt || sed -i 's/= opt /= noopt /' Makefile.in
+}
+
+src_compile() {
+ export VARTEXFONTS="${T}/fonts"
+ if use ocamlopt ; then
+ emake opt
+ else
+ emake byte
+ fi
+ if use doc; then
+ emake doc
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README CHANGES
+ if use doc; then
+ dodoc manual.pdf
+ dohtml manual.html
+ fi
+}
diff --git a/dev-tex/bibtex2html/bibtex2html-1.98.ebuild b/dev-tex/bibtex2html/bibtex2html-1.98.ebuild
new file mode 100644
index 000000000000..e0c694d59773
--- /dev/null
+++ b/dev-tex/bibtex2html/bibtex2html-1.98.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+IUSE="doc +ocamlopt"
+
+DESCRIPTION="A bibtex to HTML converter"
+SRC_URI="http://www.lri.fr/~filliatr/ftp/bibtex2html/${P}.tar.gz"
+HOMEPAGE="http://www.lri.fr/~filliatr/bibtex2html/"
+
+SLOT="0"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc ~ppc64 ~x86"
+RESTRICT="test"
+
+# With use doc we need a latex compiler to generate manual.pdf
+# hevea is used for manual.html
+# manual.tex needs fullpage.sty
+DEPEND=">=dev-lang/ocaml-3.10:=[ocamlopt?]
+ doc? ( virtual/latex-base
+ dev-texlive/texlive-latexextra
+ dev-tex/hevea )"
+# We need tex-base for bibtex but also some bibtex styles, so we use latex-base
+RDEPEND="virtual/latex-base"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.88-destdir.patch"
+ # Avoid pre-stripped files
+ sed -i -e "s/strip/true/" Makefile.in
+ # For make install
+ use ocamlopt || sed -i 's/= opt /= noopt /' Makefile.in
+}
+
+src_compile() {
+ export VARTEXFONTS="${T}/fonts"
+ if use ocamlopt ; then
+ emake opt
+ else
+ emake byte
+ fi
+ if use doc; then
+ emake doc
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README CHANGES
+ if use doc; then
+ dodoc manual.pdf
+ dohtml manual.html
+ fi
+}
diff --git a/dev-tex/bibtex2html/files/bibtex2html-1.88-destdir.patch b/dev-tex/bibtex2html/files/bibtex2html-1.88-destdir.patch
new file mode 100644
index 000000000000..4230382ab3ab
--- /dev/null
+++ b/dev-tex/bibtex2html/files/bibtex2html-1.88-destdir.patch
@@ -0,0 +1,40 @@
+Index: bibtex2html-1.88/Makefile.in
+===================================================================
+--- bibtex2html-1.88.orig/Makefile.in
++++ bibtex2html-1.88/Makefile.in
+@@ -56,24 +56,24 @@ test: bibtex2html bib2bib
+ make -C bench test
+
+ install-indep:
+- mkdir -p $(BINDIR)
+- cp aux2bib $(BINDIR)/aux2bib
+- mkdir -p $(MANDIR)/man1
+- cp bibtex2html.1 $(MANDIR)/man1/bibtex2html.1
+- cp bibtex2html.1 $(MANDIR)/man1/bib2bib.1
+- cp aux2bib.1 $(MANDIR)/man1/aux2bib.1
++ mkdir -p $(DESTDIR)$(BINDIR)
++ cp aux2bib $(DESTDIR)$(BINDIR)/aux2bib
++ mkdir -p $(DESTDIR)$(MANDIR)/man1
++ cp bibtex2html.1 $(DESTDIR)$(MANDIR)/man1/bibtex2html.1
++ cp bibtex2html.1 $(DESTDIR)$(MANDIR)/man1/bib2bib.1
++ cp aux2bib.1 $(DESTDIR)$(MANDIR)/man1/aux2bib.1
+
+ install: install-indep
+ if test @OCAMLBEST@ = opt ; then \
+- cp bibtex2html bib2bib $(BINDIR) ; \
++ cp bibtex2html bib2bib $(DESTDIR)$(BINDIR) ; \
+ else \
+- cp bibtex2html.byte $(BINDIR)/bibtex2html ; \
+- cp bib2bib.byte $(BINDIR)/bib2bib ; \
++ cp bibtex2html.byte $(DESTDIR)$(BINDIR)/bibtex2html ; \
++ cp bib2bib.byte $(DESTDIR)$(BINDIR)/bib2bib ; \
+ fi
+
+ install-byte: install-indep
+- cp bibtex2html.byte $(BINDIR)/bibtex2html
+- cp bib2bib.byte $(BINDIR)/bib2bib
++ cp bibtex2html.byte $(DESTDIR)$(BINDIR)/bibtex2html
++ cp bib2bib.byte $(DESTDIR)$(BINDIR)/bib2bib
+
+ local: bibtex2html bib2bib
+ cp bibtex2html bib2bib aux2bib $$HOME/bin/$$OSTYPE
diff --git a/dev-tex/bibtex2html/metadata.xml b/dev-tex/bibtex2html/metadata.xml
new file mode 100644
index 000000000000..12a9af659609
--- /dev/null
+++ b/dev-tex/bibtex2html/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+<herd>ml</herd>
+</pkgmetadata>