summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-02-27 08:13:33 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-02-27 08:13:33 +0100
commit6795d1df8c3dfd87f090518b4e5b96093b70bada (patch)
tree3ad08ec72ed1629e3aabe03ca93e4eb7199519e6 /dev-tcltk/tclx/tclx-8.6.3.ebuild
parentdev-tcltk/bwidget: add 1.9.16, drop 1.9.14 (diff)
downloadgentoo-6795d1df8c3dfd87f090518b4e5b96093b70bada.tar.gz
gentoo-6795d1df8c3dfd87f090518b4e5b96093b70bada.tar.bz2
gentoo-6795d1df8c3dfd87f090518b4e5b96093b70bada.zip
dev-tcltk/tclx: add 8.6.3, drop 8.4.4-r4
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-tcltk/tclx/tclx-8.6.3.ebuild')
-rw-r--r--dev-tcltk/tclx/tclx-8.6.3.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-tcltk/tclx/tclx-8.6.3.ebuild b/dev-tcltk/tclx/tclx-8.6.3.ebuild
new file mode 100644
index 000000000000..0de700c1205e
--- /dev/null
+++ b/dev-tcltk/tclx/tclx-8.6.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A set of extensions to TCL"
+HOMEPAGE="http://tclx.sourceforge.net"
+SRC_URI="https://github.com/flightaware/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="threads"
+
+DEPEND="dev-lang/tcl:0="
+RDEPEND="${DEPEND}"
+
+# tests broken, bug #279283
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-8.4-varinit.patch
+ "${FILESDIR}"/${PN}-8.4-ldflags.patch
+)
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ stat64 # used to test for Large File Support
+)
+
+src_prepare() {
+ default
+
+ sed \
+ -e '/CC=/s:-pipe::g' \
+ -i tclconfig/tcl.m4 configure || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable threads) \
+ --enable-shared \
+ --with-tcl="${EPREFIX}/usr/$(get_libdir)/"
+
+ # adjust install_name on darwin
+ if [[ ${CHOST} == *-darwin* ]]; then
+ sed -i \
+ -e 's:^\(SHLIB_LD\W.*\)$:\1 -install_name ${pkglibdir}/$@:' \
+ "${S}"/Makefile || die 'sed failed'
+ fi
+}
+
+src_install() {
+ default
+ doman doc/*.[n3]
+}