summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-03-10 16:13:39 +0100
committerHans de Graaff <graaff@gentoo.org>2024-03-10 16:19:01 +0100
commit995f2d102180f574449ff0dfddcbf171d4e4d518 (patch)
treeeb27b73024f106ceb873df2fe7f843e377dd6304 /dev-ruby/octokit
parentdev-ruby/io-event: add 1.5.1 (diff)
downloadgentoo-995f2d102180f574449ff0dfddcbf171d4e4d518.tar.gz
gentoo-995f2d102180f574449ff0dfddcbf171d4e4d518.tar.bz2
gentoo-995f2d102180f574449ff0dfddcbf171d4e4d518.zip
dev-ruby/octokit: add 8.1.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/octokit')
-rw-r--r--dev-ruby/octokit/Manifest1
-rw-r--r--dev-ruby/octokit/octokit-8.1.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/octokit/Manifest b/dev-ruby/octokit/Manifest
index 26665a5e1118..087167e26c06 100644
--- a/dev-ruby/octokit/Manifest
+++ b/dev-ruby/octokit/Manifest
@@ -1,3 +1,4 @@
DIST octokit-6.1.1.tar.gz 3193336 BLAKE2B 890afac205992c25dd8b48f63ea7a4cf250687318ecb9c0980fc50ff1583943074cea1d9260f139b1a5f86295483f44120421dba8294eba641104301f0188123 SHA512 d91b326d892f80f08598ebb0a03edfd1fb85d36e40dac49593291a6b2ff6a957f5cd2283655c20ff0299f40c75ad7472ff55a14b182bec5f92693b560c2d3c87
DIST octokit-7.2.0.tar.gz 3293244 BLAKE2B 6c24add01107868d64b0409d7a4eaf5bc5b90a9932d10f46e091aa5f4a512dd64a70047e2615c4a064b33e66e48e724ca0c85a4dec523c8df6c4968ecae83b55 SHA512 91abe7e64a75da5ef4f93a891aedbd1a047f744fed695dfb843f5d6f7416d4e08c7cad192b60d3aead43e38095c0985239a364a70a51042dca1b74bbc3529e8a
DIST octokit-8.0.0.tar.gz 3306271 BLAKE2B f2bdfebd6f6df3dc507f534947b9cac68ff970d333958a8c7624b01ca090a49294ea2f2fb7b2f0f595f2e4fa37b082d19a3cf346b3634856dfd6c79981c1dcc9 SHA512 7894d8fb3f318827bbac3d8fa4787510195e5c583e256c96b8dd98ccb9ed2126f66f00799547e7db8f565f6c72d7af346c2558a31b8ad5b711c9db240e138878
+DIST octokit-8.1.0.tar.gz 3324751 BLAKE2B 84cc09d122e7a7269272b453f1042158329804bc25bc918fafdc382264b4db7c0264f4d1978521fc5b438e50abc4b879cfe287032998d337ba05c0eae27f4229 SHA512 77552e71fcf149a7aafa94c93210dcf9462cf8269be89e16248c47cf3bf40ab4cc754a9d989599822fc06c29a7edc7e9a16ae3cba696155175710ae7cf845567
diff --git a/dev-ruby/octokit/octokit-8.1.0.ebuild b/dev-ruby/octokit/octokit-8.1.0.ebuild
new file mode 100644
index 000000000000..c197bf7af4ed
--- /dev/null
+++ b/dev-ruby/octokit/octokit-8.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md CONTRIBUTING.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby toolkit for the Github API"
+HOMEPAGE="https://github.com/octokit/octokit.rb"
+SRC_URI="https://github.com/octokit/octokit.rb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RUBY_S=octokit.rb-${PV}
+
+ruby_add_rdepend "
+ || ( dev-ruby/faraday:2 dev-ruby/faraday:1 )
+ >=dev-ruby/sawyer-0.9:0
+"
+
+ruby_add_bdepend "test? (
+ || ( ( dev-ruby/faraday:2 dev-ruby/faraday-multipart ) dev-ruby/faraday:1 )
+ dev-ruby/jwt
+ dev-ruby/mime-types
+ >=dev-ruby/netrc-0.7.7
+ >=dev-ruby/rbnacl-7.1.1:6
+ dev-ruby/vcr[json]
+ dev-ruby/webmock:3 )"
+
+all_ruby_prepare() {
+ sed -e '/if RUBY_ENGINE/,/^end/ s:^:#: ; 1igem "webmock", "~>3.0"' \
+ -e '/pry/ s:^:#:' \
+ -i spec/spec_helper.rb || die
+}