summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/maruku
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/maruku')
-rw-r--r--dev-ruby/maruku/Manifest1
-rw-r--r--dev-ruby/maruku/maruku-0.7.2-r1.ebuild43
-rw-r--r--dev-ruby/maruku/maruku-0.7.2.ebuild43
-rw-r--r--dev-ruby/maruku/metadata.xml11
4 files changed, 98 insertions, 0 deletions
diff --git a/dev-ruby/maruku/Manifest b/dev-ruby/maruku/Manifest
new file mode 100644
index 000000000000..97a08b18bc32
--- /dev/null
+++ b/dev-ruby/maruku/Manifest
@@ -0,0 +1 @@
+DIST maruku-0.7.2.gem 142336 SHA256 e8a755d8e9c24f1601157c8b376f0378f88d487fa777aa655f332504557a0798 SHA512 45eaec7ba721499acbfed97cac4eddfe50c2200a70394e06dc6dd4c6c642b0c58d126c48dabfc4b9697423dd99ecf8691e223125a44d59a382a76e051f2af622 WHIRLPOOL e472acd1366a032c920447ede4a329defa074338da16ae3075238f6f2d6498b2968a1f09ac040ff90d9aef14ea4d0d5a118abcf334cd245a231fb3cc1eb0a090
diff --git a/dev-ruby/maruku/maruku-0.7.2-r1.ebuild b/dev-ruby/maruku/maruku-0.7.2-r1.ebuild
new file mode 100644
index 000000000000..b7aec59b9639
--- /dev/null
+++ b/dev-ruby/maruku/maruku-0.7.2-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="docs/div_syntax.md docs/entity_test.md
+ docs/markdown_syntax.md docs/maruku.md docs/math.md docs/other_stuff.md
+ docs/proposal.md"
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Markdown-superset interpreter written in Ruby"
+HOMEPAGE="https://github.com/bhollis/maruku"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="highlight test"
+
+ruby_add_bdepend "test? ( dev-ruby/nokogiri-diff )"
+ruby_add_rdepend "highlight? ( dev-ruby/syntax )"
+
+DEPEND+=" test? ( app-text/blahtexml )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Ss]imple[Cc]ov/ s:^:#:' spec/spec_helper.rb || die
+}
+
+pkg_postinst() {
+ elog
+ elog "You need to emerge app-text/texlive and dev-texlive/texlive-latexextra if"
+ elog "you want to use --pdf with Maruku. You may also want to emerge"
+ elog "dev-texlive/texlive-latexrecommended to enable LaTeX syntax highlighting."
+ elog
+}
diff --git a/dev-ruby/maruku/maruku-0.7.2.ebuild b/dev-ruby/maruku/maruku-0.7.2.ebuild
new file mode 100644
index 000000000000..5a72965d551c
--- /dev/null
+++ b/dev-ruby/maruku/maruku-0.7.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="docs/div_syntax.md docs/entity_test.md
+ docs/markdown_syntax.md docs/maruku.md docs/math.md docs/other_stuff.md
+ docs/proposal.md"
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Markdown-superset interpreter written in Ruby"
+HOMEPAGE="https://github.com/bhollis/maruku"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
+IUSE="highlight test"
+
+ruby_add_bdepend "test? ( dev-ruby/nokogiri-diff )"
+ruby_add_rdepend "highlight? ( dev-ruby/syntax )"
+
+DEPEND+=" test? ( app-text/blahtexml )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Ss]imple[Cc]ov/ s:^:#:' spec/spec_helper.rb || die
+}
+
+pkg_postinst() {
+ elog
+ elog "You need to emerge app-text/texlive and dev-texlive/texlive-latexextra if"
+ elog "you want to use --pdf with Maruku. You may also want to emerge"
+ elog "dev-texlive/texlive-latexrecommended to enable LaTeX syntax highlighting."
+ elog
+}
diff --git a/dev-ruby/maruku/metadata.xml b/dev-ruby/maruku/metadata.xml
new file mode 100644
index 000000000000..123f6e3177fb
--- /dev/null
+++ b/dev-ruby/maruku/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <use>
+ <flag name="highlight">Enable source code highlighting via <pkg>dev-ruby/syntax</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="github">bhollis/maruku</remote-id>
+ </upstream>
+</pkgmetadata>