summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-08-24 09:05:23 +0200
committerHans de Graaff <graaff@gentoo.org>2024-08-24 09:06:42 +0200
commitaf082eec6dcff34224649a28b8ff3a1c77fdbd4d (patch)
treeff42d9c720efa03833306a49cd76787486ee89e8 /dev-ruby/actionview
parentdev-ruby/activerecord: add 7.1.4 (diff)
downloadgentoo-af082eec6dcff34224649a28b8ff3a1c77fdbd4d.tar.gz
gentoo-af082eec6dcff34224649a28b8ff3a1c77fdbd4d.tar.bz2
gentoo-af082eec6dcff34224649a28b8ff3a1c77fdbd4d.zip
dev-ruby/actionview: add 7.1.4
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/actionview')
-rw-r--r--dev-ruby/actionview/Manifest1
-rw-r--r--dev-ruby/actionview/actionview-7.1.4.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-ruby/actionview/Manifest b/dev-ruby/actionview/Manifest
index 07f91732212c..211fe49c76dd 100644
--- a/dev-ruby/actionview/Manifest
+++ b/dev-ruby/actionview/Manifest
@@ -4,3 +4,4 @@ DIST rails-7.0.8.3.tgz 11080686 BLAKE2B 2d13559e7b7ab752af4fee480ee51f73b4d1f392
DIST rails-7.0.8.4.tgz 11082427 BLAKE2B 2ca521ad92b7a33fa2160b4cfbc1aac826641d2aac7a8751b6acaed1b7fc42bb860b4ade3f973eb51dc17d20fa4c97b02e8d6b970ae63b042cd58ab2f6cfc797 SHA512 e6628e901fcdcd4b9101cdae0cd556569fc7b577466a15f99d1e221c1c0059287dce87c1362df8b23ded992e96c551b35c0c789e683f080079e678555b7a79e6
DIST rails-7.1.3.3.tgz 10905515 BLAKE2B b2be6d8922d15478136875ac80d65fdc54bdf4a03ec17cddc20c20ae847f08fd52a2b1110ed27feb0217f4aa8dd827a8d95847e32eceaf8f5979843312f12a2a SHA512 0d108654a9ab2a9321822742906c4848508e0e4e09600c01bd5a86deeb324540bbae520a954499c4cc83bfe1246f929a581d1667f2b50c463d0bf8187f603df9
DIST rails-7.1.3.4.tgz 10917333 BLAKE2B 3266de2a86f8b107b18117c06115db14791bb98d672403eff28673e9d98df5e2c9a6c30f72d4141cd1f051054f2d5e1f636a93de9b14114cefef384fded7942a SHA512 4c303be256707b5bbedc05bf5bac7c60ff03cb8a14fa3d709a495d07ad1745d6c6f4d5dceb9860afff46f95f3f9fc525d1bcb75894a5b31a9d35f1aa6b105c5e
+DIST rails-7.1.4.tgz 10926853 BLAKE2B e1e62f95453fa0137337f40291614265ae4d8e6bedf496e0402f160ce938418760dcd850c37e82a7c9dd530dfe442b0f9b22d122dc80f1ff61c5c76244999416 SHA512 67770018663d930cb710fb08358c7d9c9d391a4c721212c55b60c4827f8cbdb38e55ee551b598e93244beba18f9c4c21dfdf6000e67880ac95345a70ff2e0841
diff --git a/dev-ruby/actionview/actionview-7.1.4.ebuild b/dev-ruby/actionview/actionview-7.1.4.ebuild
new file mode 100644
index 000000000000..fb3cb5feef80
--- /dev/null
+++ b/dev-ruby/actionview/actionview-7.1.4.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_EXTRAINSTALL="app"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple, battle-tested conventions and helpers for building web pages"
+HOMEPAGE="https://github.com/rails/rails/"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.1:* =dev-ruby/builder-3*:*
+ >=dev-ruby/erubi-1.11:0
+ >=dev-ruby/rails-dom-testing-2.2:2
+ >=dev-ruby/rails-html-sanitizer-1.6:1
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/capybara
+ dev-ruby/mocha
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/railties-${PV}
+ dev-ruby/sqlite3
+ dev-ruby/minitest:5
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|rack-cache\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\|bcrypt\|uglifier\|mime-types\|minitest\|sprockets\|stackprof\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
+ rm ../Gemfile.lock || die
+
+ # Fix loading of activerecord integration tests. This avoids loading
+ # activerecord twice and thus redefining constants leading to
+ # failures. Bug #719342
+ sed -e '/abstract_unit/arequire "active_record" ; require "active_record/fixtures"' \
+ -e '/defined/ s/FixtureSet/ActiveRecord::FixtureSet/' \
+ -i test/active_record_unit.rb || die
+
+ sed -e '3irequire "ostruct"' \
+ -e '3igem "railties", "~> 7.1.0"; gem "activerecord", "~> 7.1.0"' \
+ -i test/abstract_unit.rb || die
+
+ # Avoid test failing on capitalization difference
+ sed -e '/test_raise_arg_overrides_raise_config_option/askip "Capitalization difference"' \
+ -i test/template/translation_helper_test.rb || die
+
+ # Remove tests that are coupled to the Sanitizer (already removed upstream)
+ sed -e '/test_sanitized_allowed_\(tags_class_method\|attributes_class_method\)/askip "Removed upstream"' \
+ -i test/template/sanitize_helper_test.rb || die
+}