summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-10-26 11:48:31 +0200
committerHans de Graaff <graaff@gentoo.org>2024-10-26 11:49:56 +0200
commit25588e927b273c9677bd7e53966f045717334513 (patch)
treef6744d020f8c3fd515fc5e5d480ede4c640944e5 /dev-ruby/actiontext
parentdev-ruby/actionmailbox: add 7.0.8.6 (diff)
downloadgentoo-25588e927b273c9677bd7e53966f045717334513.tar.gz
gentoo-25588e927b273c9677bd7e53966f045717334513.tar.bz2
gentoo-25588e927b273c9677bd7e53966f045717334513.zip
dev-ruby/actiontext: add 7.0.8.6
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/actiontext')
-rw-r--r--dev-ruby/actiontext/Manifest1
-rw-r--r--dev-ruby/actiontext/actiontext-7.0.8.6.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-ruby/actiontext/Manifest b/dev-ruby/actiontext/Manifest
index 046023b83751..8ba2911fbfd3 100644
--- a/dev-ruby/actiontext/Manifest
+++ b/dev-ruby/actiontext/Manifest
@@ -3,6 +3,7 @@ DIST rails-6.1.7.8.tgz 11041890 BLAKE2B 285571972ec1d43ae65f3c4f586679e31d055026
DIST rails-6.1.7.9.tgz 11034686 BLAKE2B 12edf62a94e0b504f1db721081ce35a6b7e8f67bded2801ce54872f7cef80fb75120f56b356940a44d943cbd05b4d63778726885ac20dd04a2e5510f54ea06ac SHA512 387cbc5424b16ade97091e3cfc3a5bc0cfe277ee75a7f35cdf5d393c692d2ea17f258e38d8b25c8c8a1be4fb64a39d0f675b23942145929bb7be4783cd95d90b
DIST rails-7.0.8.4.tgz 11082427 BLAKE2B 2ca521ad92b7a33fa2160b4cfbc1aac826641d2aac7a8751b6acaed1b7fc42bb860b4ade3f973eb51dc17d20fa4c97b02e8d6b970ae63b042cd58ab2f6cfc797 SHA512 e6628e901fcdcd4b9101cdae0cd556569fc7b577466a15f99d1e221c1c0059287dce87c1362df8b23ded992e96c551b35c0c789e683f080079e678555b7a79e6
DIST rails-7.0.8.5.tgz 11073275 BLAKE2B f2d45a577a53d7741b1efab59991f8242cf76e96267f174d268026e9b1c543d95346a38312ba32a00793082dc441130f1132c3bdab5203f5015ea8ce2534bbbe SHA512 c00b0156382aaf18f2ba78ed531778c00dabfe30729681cb79be6adeb9fca15592255f6e1fb606930487c491c5fdb57aaaec955b828c3bc843913dba10e7ccc9
+DIST rails-7.0.8.6.tgz 11073387 BLAKE2B 94f86f41013c9929721786aaf668844915f340d490df1028218942192756404683736060b8bf23e04f431496d121245aae02c62f472cd482db3c9a21b0afca09 SHA512 0a302c395e0b00948b2c99096c6c240479bbd12110ab47d05771308676d35c22755ccc7888ebf37d650ac0ed7a21a0f2cfc7f366a051ae12ecae9e7f7f9624cd
DIST rails-7.1.4.1.tgz 10925600 BLAKE2B 81d9434c5db6cf452f9be8f9fe5dbb643c945b253bafb3f999dfe64d8ec7c15a6ae69407663107e540b67d4559a77dfdb1ab94c7ba4788b2eb0ecda8a012692a SHA512 5dfc411b94a03d4fde0aa426370feaa272768262f989a225c81b07a8830e57a3b72c1effa4ba09e991dd00dd85a0358ab21c1983aa1456ecc28b29447d5011d9
DIST rails-7.1.4.tgz 10926853 BLAKE2B e1e62f95453fa0137337f40291614265ae4d8e6bedf496e0402f160ce938418760dcd850c37e82a7c9dd530dfe442b0f9b22d122dc80f1ff61c5c76244999416 SHA512 67770018663d930cb710fb08358c7d9c9d391a4c721212c55b60c4827f8cbdb38e55ee551b598e93244beba18f9c4c21dfdf6000e67880ac95345a70ff2e0841
DIST rails-7.2.1.1.tgz 11062191 BLAKE2B 1fbecb5a2d47168ddcfad2bb82b0ebd45f43d3e0789e60286661c912d13a83a82e6a6651b6a8c196062d616a25a3c55aa510a129cc255d8a72876f43715d5ed4 SHA512 c430cf3886983e905fe5bbd6a4b502fcd137612361aaaaee606634de38c77eb211b86b041cf64f484741133d4cbc60daa9ca93a630cc97adc6ec43be36e09ef5
diff --git a/dev-ruby/actiontext/actiontext-7.0.8.6.ebuild b/dev-ruby/actiontext/actiontext-7.0.8.6.ebuild
new file mode 100644
index 000000000000..5c39b98a52c8
--- /dev/null
+++ b/dev-ruby/actiontext/actiontext-7.0.8.6.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="actiontext.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRAINSTALL="app db package.json"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Edit and display rich text in Rails applications"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activestorage-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/globalid-0.6.0
+ >=dev-ruby/nokogiri-1.8.5
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ dev-ruby/minitest:5.15
+ dev-ruby/mocha
+ dev-ruby/propshaft
+ >=dev-ruby/sqlite3-1.4.0
+)"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql2\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|sass-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webpacker\|webrick\|webmock\|webdrivers\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\|rack-cache\|rack-test\|bootsnap\|capybara\|dalli\|connection_pool\|terser\|cookiejar\|cgi\)/ s:^:#:" \
+ -e '/stimulus-rails/,/tailwindcss-rails/ s:^:#:' \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :\(cable\|doc\|rubocop\|storage\|test\)/,/^end/ s:^:#:' \
+ -e '/sqlite/ s/1.6.4/99/' \
+ -i ../Gemfile || die
+ rm ../Gemfile.lock || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby:'${RUBY}':' test/dummy/bin/* || die
+}