summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-10 15:17:36 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-10 15:26:43 +0200
commit2a99b9fb45ff2e102b6e1585d374c137da229bf6 (patch)
treeb2e5684d56437a07e1bf9be01ce1e08443cb75b1 /dev-ros/rqt_tf_tree
parentdev-ros/rqt_top: Remove old (diff)
downloadgentoo-2a99b9fb45ff2e102b6e1585d374c137da229bf6.tar.gz
gentoo-2a99b9fb45ff2e102b6e1585d374c137da229bf6.tar.bz2
gentoo-2a99b9fb45ff2e102b6e1585d374c137da229bf6.zip
dev-ros/rqt_tf_tree: bump to 0.6.1
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rqt_tf_tree')
-rw-r--r--dev-ros/rqt_tf_tree/Manifest1
-rw-r--r--dev-ros/rqt_tf_tree/files/yaml.patch13
-rw-r--r--dev-ros/rqt_tf_tree/rqt_tf_tree-0.6.1.ebuild30
-rw-r--r--dev-ros/rqt_tf_tree/rqt_tf_tree-9999.ebuild6
4 files changed, 47 insertions, 3 deletions
diff --git a/dev-ros/rqt_tf_tree/Manifest b/dev-ros/rqt_tf_tree/Manifest
index 3420f1b10b3d..af54de83d189 100644
--- a/dev-ros/rqt_tf_tree/Manifest
+++ b/dev-ros/rqt_tf_tree/Manifest
@@ -1,3 +1,4 @@
DIST rqt_robot_plugins-0.5.6.tar.gz 2107696 BLAKE2B 68a6643fef3c101ddbc0ae6a66d7fed3ec2fd7bc811947487946084bd6c93e564e11693941ef336b6d5428f926b0c297ccff845056e3f123320fba176ffe00cf SHA512 871f660e22afafd510e34984b94d2530bc3314db194c06ff458430e15b1183a60147289e9544a5fb070665a3c83034cbcccefe2f820e62f091c3bbc0edfd0a51
DIST rqt_tf_tree-0.5.7.tar.gz 8021 BLAKE2B 7fd327011a89c08894e6c66f02ffbf3144d66eb62c3b1a4a297466fea21536e1cb7685f9db27ee7ba31a39af9d36684c0cdd2036d874837fd7e570eec1413b2d SHA512 024a38d446288e620728210a3de1569d93dafc3040c600a2de5359f3d6fef6074700562e8ff0c5cb2571cc0abef8db3e7071994d6ec916fea336ae1b8d267140
DIST rqt_tf_tree-0.5.8.tar.gz 8111 BLAKE2B b4cb996f5d6b4366345d2434bf95117c7f25b50a99f7a8c4a2422710821ddc1c7c354f544365e4bd78eab80fe46cb4c14fe78e843e91f35af410c458a4bc54d5 SHA512 6bfbb692da82edbbbcae90bdba8b69f0023b7b5b9e67c64a33864be3ec8359ee87922b7957dfff9ba4db6febb07e3106f9742e89bacfc31d85ef4e0db34c02bc
+DIST rqt_tf_tree-0.6.1.tar.gz 8469 BLAKE2B 0ff1291f982ba0338b75997df868f623682007cbff29b90465aef550463ab8082ca1c068fe4cbca3cfa4a5b46c132cfef089af948300a7e8f1f919933cc1ade6 SHA512 22441bd7313c250f786060d09eb170a42b85ec5414b24be2db1ecdb6d1336acef6a879513793f6a60ddd875ca7fbd1c6b0ac2bde759968440c6c638c62c6c89b
diff --git a/dev-ros/rqt_tf_tree/files/yaml.patch b/dev-ros/rqt_tf_tree/files/yaml.patch
new file mode 100644
index 000000000000..c1435cc59ab6
--- /dev/null
+++ b/dev-ros/rqt_tf_tree/files/yaml.patch
@@ -0,0 +1,13 @@
+Index: rqt_tf_tree-0.6.1/src/rqt_tf_tree/dotcode_tf.py
+===================================================================
+--- rqt_tf_tree-0.6.1.orig/src/rqt_tf_tree/dotcode_tf.py
++++ rqt_tf_tree-0.6.1/src/rqt_tf_tree/dotcode_tf.py
+@@ -93,7 +93,7 @@ class RosTfTreeDotcodeGenerator(object):
+ self.listen_duration = 0
+
+ yaml_data = tf2_frame_srv().frame_yaml
+- data = yaml_parser.load(yaml_data)
++ data = yaml_parser.safe_load(yaml_data)
+ self.graph = self.generate(data, timer.now().to_sec())
+ self.dotcode = self.dotcode_factory.create_dot(self.graph)
+
diff --git a/dev-ros/rqt_tf_tree/rqt_tf_tree-0.6.1.ebuild b/dev-ros/rqt_tf_tree/rqt_tf_tree-0.6.1.ebuild
new file mode 100644
index 000000000000..97bbaad2eb7d
--- /dev/null
+++ b/dev-ros/rqt_tf_tree/rqt_tf_tree-0.6.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_tf_tree"
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing the ROS TF frame tree"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_dotgraph[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_graph[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/tf2_ros[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+PATCHES=( "${FILESDIR}/yaml.patch" )
diff --git a/dev-ros/rqt_tf_tree/rqt_tf_tree-9999.ebuild b/dev-ros/rqt_tf_tree/rqt_tf_tree-9999.ebuild
index acd62217748c..97bbaad2eb7d 100644
--- a/dev-ros/rqt_tf_tree/rqt_tf_tree-9999.ebuild
+++ b/dev-ros/rqt_tf_tree/rqt_tf_tree-9999.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
KEYWORDS="~amd64"
ROS_REPO_URI="https://github.com/ros-visualization/rqt_tf_tree"
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin
@@ -28,3 +27,4 @@ RDEPEND="
"
DEPEND="${RDEPEND}
test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+PATCHES=( "${FILESDIR}/yaml.patch" )