summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-03-04 14:00:04 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-03-04 14:36:44 +0100
commitcf82b0692c3dbe657b1f67fa7808645dbaee0011 (patch)
tree15af5766bacecfcb15fb7c1effae0e3d45930a4e /dev-ros/rqt_graph/rqt_graph-0.4.7.ebuild
parentdev-ros/rqt_dep: Bump to 0.4.7. (diff)
downloadgentoo-cf82b0692c3dbe657b1f67fa7808645dbaee0011.tar.gz
gentoo-cf82b0692c3dbe657b1f67fa7808645dbaee0011.tar.bz2
gentoo-cf82b0692c3dbe657b1f67fa7808645dbaee0011.zip
dev-ros/rqt_graph: Bump to 0.4.7.
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-ros/rqt_graph/rqt_graph-0.4.7.ebuild')
-rw-r--r--dev-ros/rqt_graph/rqt_graph-0.4.7.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/rqt_graph/rqt_graph-0.4.7.ebuild b/dev-ros/rqt_graph/rqt_graph-0.4.7.ebuild
new file mode 100644
index 000000000000..fd756b8d5609
--- /dev/null
+++ b/dev-ros/rqt_graph/rqt_graph-0.4.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing the ROS computation graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_dotgraph[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosnode[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosservice[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"