summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2025-01-05 21:49:34 -0500
committerIonen Wolkens <ionen@gentoo.org>2025-01-06 02:04:45 -0500
commit1ae87c7d88b76d82c38c675ed990599c6e8cd2b1 (patch)
tree925fe5e8d0c95d34f948eef171d3474d6e5d618e /dev-qt
parentx11-terms/kitty: Stabilize 0.38.1 amd64, #945895 (diff)
downloadgentoo-1ae87c7d88b76d82c38c675ed990599c6e8cd2b1.tar.gz
gentoo-1ae87c7d88b76d82c38c675ed990599c6e8cd2b1.tar.bz2
gentoo-1ae87c7d88b76d82c38c675ed990599c6e8cd2b1.zip
dev-qt/qttools: migrate to llvm-r2.eclass
Given pkg_setup is not exported with LLVM_OPTIONAL, may as well use llvm_chost_setup directly in src_configure rather than define pkg_setup. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qttools/qttools-6.8.1.ebuild10
-rw-r--r--dev-qt/qttools/qttools-6.8.9999.ebuild10
-rw-r--r--dev-qt/qttools/qttools-6.9.9999.ebuild10
-rw-r--r--dev-qt/qttools/qttools-6.9999.ebuild10
4 files changed, 16 insertions, 24 deletions
diff --git a/dev-qt/qttools/qttools-6.8.1.ebuild b/dev-qt/qttools/qttools-6.8.1.ebuild
index 75971ea96c1a..7f580d0836cb 100644
--- a/dev-qt/qttools/qttools-6.8.1.ebuild
+++ b/dev-qt/qttools/qttools-6.8.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021-2024 Gentoo Authors
+# Copyright 2021-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -11,7 +11,7 @@ LLVM_OPTIONAL=1
# and 3rdparty/ tries to FetchContent gtest)
QT6_RESTRICT_TESTS=1
-inherit desktop llvm-r1 optfeature qt6-build
+inherit desktop llvm-r2 optfeature qt6-build
DESCRIPTION="Qt Tools Collection"
@@ -62,11 +62,9 @@ DEPEND="
)
"
-pkg_setup() {
- use clang && llvm-r1_pkg_setup
-}
-
src_configure() {
+ use clang && llvm_chost_setup
+
local mycmakeargs=(
# prevent the clang test as it can abort due to bug #916098
$(cmake_use_find_package clang WrapLibClang)
diff --git a/dev-qt/qttools/qttools-6.8.9999.ebuild b/dev-qt/qttools/qttools-6.8.9999.ebuild
index 94d7719b638f..8f4634e0ffca 100644
--- a/dev-qt/qttools/qttools-6.8.9999.ebuild
+++ b/dev-qt/qttools/qttools-6.8.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021-2024 Gentoo Authors
+# Copyright 2021-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -11,7 +11,7 @@ LLVM_OPTIONAL=1
# and 3rdparty/ tries to FetchContent gtest)
QT6_RESTRICT_TESTS=1
-inherit desktop llvm-r1 optfeature qt6-build
+inherit desktop llvm-r2 optfeature qt6-build
DESCRIPTION="Qt Tools Collection"
@@ -62,11 +62,9 @@ DEPEND="
)
"
-pkg_setup() {
- use clang && llvm-r1_pkg_setup
-}
-
src_configure() {
+ use clang && llvm_chost_setup
+
local mycmakeargs=(
# prevent the clang test as it can abort due to bug #916098
$(cmake_use_find_package clang WrapLibClang)
diff --git a/dev-qt/qttools/qttools-6.9.9999.ebuild b/dev-qt/qttools/qttools-6.9.9999.ebuild
index 94d7719b638f..8f4634e0ffca 100644
--- a/dev-qt/qttools/qttools-6.9.9999.ebuild
+++ b/dev-qt/qttools/qttools-6.9.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021-2024 Gentoo Authors
+# Copyright 2021-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -11,7 +11,7 @@ LLVM_OPTIONAL=1
# and 3rdparty/ tries to FetchContent gtest)
QT6_RESTRICT_TESTS=1
-inherit desktop llvm-r1 optfeature qt6-build
+inherit desktop llvm-r2 optfeature qt6-build
DESCRIPTION="Qt Tools Collection"
@@ -62,11 +62,9 @@ DEPEND="
)
"
-pkg_setup() {
- use clang && llvm-r1_pkg_setup
-}
-
src_configure() {
+ use clang && llvm_chost_setup
+
local mycmakeargs=(
# prevent the clang test as it can abort due to bug #916098
$(cmake_use_find_package clang WrapLibClang)
diff --git a/dev-qt/qttools/qttools-6.9999.ebuild b/dev-qt/qttools/qttools-6.9999.ebuild
index 94d7719b638f..8f4634e0ffca 100644
--- a/dev-qt/qttools/qttools-6.9999.ebuild
+++ b/dev-qt/qttools/qttools-6.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021-2024 Gentoo Authors
+# Copyright 2021-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -11,7 +11,7 @@ LLVM_OPTIONAL=1
# and 3rdparty/ tries to FetchContent gtest)
QT6_RESTRICT_TESTS=1
-inherit desktop llvm-r1 optfeature qt6-build
+inherit desktop llvm-r2 optfeature qt6-build
DESCRIPTION="Qt Tools Collection"
@@ -62,11 +62,9 @@ DEPEND="
)
"
-pkg_setup() {
- use clang && llvm-r1_pkg_setup
-}
-
src_configure() {
+ use clang && llvm_chost_setup
+
local mycmakeargs=(
# prevent the clang test as it can abort due to bug #916098
$(cmake_use_find_package clang WrapLibClang)