summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-04-09 22:00:29 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-04-09 23:36:28 +0200
commit56acf9bac388533631838ff019e20eb41af0bbe0 (patch)
treec07a708b057f14c3743b759772c8fb0d82704201 /dev-qt/qtspeech
parentqt5-build.eclass: Drop obsolete in-source build workaround for >=5.14.2 (diff)
downloadgentoo-56acf9bac388533631838ff019e20eb41af0bbe0.tar.gz
gentoo-56acf9bac388533631838ff019e20eb41af0bbe0.tar.bz2
gentoo-56acf9bac388533631838ff019e20eb41af0bbe0.zip
dev-qt: Add Qt 5.14.2
Closes: https://bugs.gentoo.org/669994 Closes: https://bugs.gentoo.org/710866 Closes: https://bugs.gentoo.org/713722 Closes: https://bugs.gentoo.org/716754 Package-Manager: Portage-2.3.98, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtspeech')
-rw-r--r--dev-qt/qtspeech/Manifest1
-rw-r--r--dev-qt/qtspeech/qtspeech-5.14.2.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-qt/qtspeech/Manifest b/dev-qt/qtspeech/Manifest
index 4dd59554ad20..186bf77a499f 100644
--- a/dev-qt/qtspeech/Manifest
+++ b/dev-qt/qtspeech/Manifest
@@ -1,2 +1,3 @@
DIST qtspeech-everywhere-src-5.13.2.tar.xz 100312 BLAKE2B c033b95351278d0cbe9a665a16a0b145bbbd6389f19ac63a166cc1fc63b60c3649bf48bae1e0060b855ac278ed240954afcd4bde9adc1a87742a0dc3299aa55a SHA512 9288cfbc37fd308deb41f287e3da38b5bdb83088fbc0f0276426f44c595a53fdc476b1e6122320f28a27f590e4801320eb14599dafa7491aa0d50be0bd124e27
DIST qtspeech-everywhere-src-5.14.1.tar.xz 101072 BLAKE2B 53aaec0f74f516ddffb154401dfcad334e96f5ab7935e4aeb69d2ad20012c3006ef355b7733023ddd871fdb866aeabbbac809c03dd7d304cc303118e34e482ae SHA512 8249e374735a4a3de6b8795a5c09c9bc285eff8fc7e98e0a2446eb6b7306da1decd657bf92d5b8d195b042e7459097ce9129c8f6e4a23326f698c6e7010c46a1
+DIST qtspeech-everywhere-src-5.14.2.tar.xz 101100 BLAKE2B d37d08a2f7e6d40c7f6e68f9c4e301cdf9762ad9088a3fa0f9568af7211a2842b035e8f5eb001538aaa84385104d112cd6e550e32119099acee922f2dd13db36 SHA512 d3870cc66cba4f5dd2c0a2a4845defe4299de2d7affe12ccdadc4948116317590b580592d575cc5e8eb190043a92f38416e030f47cfb87f5cf3419a31152e00f
diff --git a/dev-qt/qtspeech/qtspeech-5.14.2.ebuild b/dev-qt/qtspeech/qtspeech-5.14.2.ebuild
new file mode 100644
index 000000000000..12d0485fe59b
--- /dev/null
+++ b/dev-qt/qtspeech/qtspeech-5.14.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qt5-build
+
+DESCRIPTION="Text-to-speech library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+# TODO: flite plugin - needs 2.0.0 (not yet in tree)
+IUSE=""
+
+RDEPEND="
+ >=app-accessibility/speech-dispatcher-0.8.7
+ ~dev-qt/qtcore-${PV}
+"
+DEPEND="${RDEPEND}"