summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-30 20:05:30 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-30 20:18:22 +0100
commitfd33418d5e8d53767590821706faa093eeb095b4 (patch)
tree452a33bd8ef705e2cc8242b04a0fd444855c94f0 /dev-python
parentdev-python/cachetools: Enable pypy3 (diff)
downloadgentoo-fd33418d5e8d53767590821706faa093eeb095b4.tar.gz
gentoo-fd33418d5e8d53767590821706faa093eeb095b4.tar.bz2
gentoo-fd33418d5e8d53767590821706faa093eeb095b4.zip
dev-python/time-machine: New dep of dev-python/tox, v2.8.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/time-machine/Manifest1
-rw-r--r--dev-python/time-machine/metadata.xml12
-rw-r--r--dev-python/time-machine/time-machine-2.8.2.ebuild36
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/time-machine/Manifest b/dev-python/time-machine/Manifest
new file mode 100644
index 000000000000..a8fc15ce2551
--- /dev/null
+++ b/dev-python/time-machine/Manifest
@@ -0,0 +1 @@
+DIST time-machine-2.8.2.gh.tar.gz 27856 BLAKE2B 2669bacfc7fb9d10186d6053ee155ca7dd28ec3da688971baa371eb8e095a8694e955797bdf1b556056e79277d46c2382dd06979d8e960da5731c3710018e445 SHA512 f49442fe2b846676abca15a9e7231a4b59e8d520482a4ef2294eac9a4e2c0866836d6bd9bec42202bf5f9e94766e9c2a00d4f7c6eb76d5cbc8a702fceef4294c
diff --git a/dev-python/time-machine/metadata.xml b/dev-python/time-machine/metadata.xml
new file mode 100644
index 000000000000..00899fd664c4
--- /dev/null
+++ b/dev-python/time-machine/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">adamchainz/time-machine</remote-id>
+ <remote-id type="pypi">time-machine</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/time-machine/time-machine-2.8.2.ebuild b/dev-python/time-machine/time-machine-2.8.2.ebuild
new file mode 100644
index 000000000000..5a263e14bd0d
--- /dev/null
+++ b/dev-python/time-machine/time-machine-2.8.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Travel through time in your tests"
+HOMEPAGE="
+ https://github.com/adamchainz/time-machine/
+ https://pypi.org/project/time-machine/
+"
+SRC_URI="
+ https://github.com/adamchainz/time-machine/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' 3.8)
+ )
+"
+
+distutils_enable_tests pytest