summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-06 18:01:44 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-06 18:03:02 +0100
commite6ced24d28044bfa0314af6743b3a81c1ae5bf02 (patch)
tree67026a0df2f3a2cf67a36dae6368cd970bc23fe1 /dev-python
parentdev-python/pyre2: Modernize, PEP517 (diff)
downloadgentoo-e6ced24d28044bfa0314af6743b3a81c1ae5bf02.tar.gz
gentoo-e6ced24d28044bfa0314af6743b3a81c1ae5bf02.tar.bz2
gentoo-e6ced24d28044bfa0314af6743b3a81c1ae5bf02.zip
dev-python/pyre2: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyre2/pyre2-1.0.7-r1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-python/pyre2/pyre2-1.0.7-r1.ebuild b/dev-python/pyre2/pyre2-1.0.7-r1.ebuild
index 75ab7c25b76c..c79bf410219d 100644
--- a/dev-python/pyre2/pyre2-1.0.7-r1.ebuild
+++ b/dev-python/pyre2/pyre2-1.0.7-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
@@ -31,3 +31,11 @@ RDEPEND="
"
distutils_enable_tests unittest
+
+src_prepare() {
+ # py3.12
+ # https://github.com/facebook/pyre2/pull/26
+ sed -e 's:assertRaisesRegexp:assertRaisesRegex:' \
+ -i tests/test_match.py || die
+ distutils-r1_src_prepare
+}