summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-08 21:08:06 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-08 21:26:53 +0100
commitd958a498ab4663d54906de14d5dfc31e634636f9 (patch)
treeb6665cdad8ebb348a4c5c0ac09583d7c514dd132 /dev-python
parentdev-python/packaging: Bump to 24.2 (diff)
downloadgentoo-d958a498ab4663d54906de14d5dfc31e634636f9.tar.gz
gentoo-d958a498ab4663d54906de14d5dfc31e634636f9.tar.bz2
gentoo-d958a498ab4663d54906de14d5dfc31e634636f9.zip
dev-python/django-registration: Bump to 5.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django-registration/Manifest1
-rw-r--r--dev-python/django-registration/django-registration-5.1.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/django-registration/Manifest b/dev-python/django-registration/Manifest
index 442eacfc477c..9f61ba456cd8 100644
--- a/dev-python/django-registration/Manifest
+++ b/dev-python/django-registration/Manifest
@@ -1 +1,2 @@
DIST django-registration-3.4.gh.tar.gz 81582 BLAKE2B bc3ee4ed806486c8a0422cc4ef62c2628f6b5880e0aa63ffdfd5ba7f90967c96c5cd7555faf58254e0a49bdb025b9bdf8eb212bfce4596db7db4f97e4eb3400d SHA512 b6c87cbaeb9548e2c2d8672078b5967aee1e881c2b880193ba410a8c293c93fd0c8e57abac8deda2cb6f61a11936fd5c72060e4954f1d74de1e3a3646b63885b
+DIST django-registration-5.1.0.gh.tar.gz 92245 BLAKE2B ccd1c0c34a0a579877b36eb25639887d148132ce552ef3fa9df5f36a0f05a5f7d290f6f1a5b2e8584dec53b6646cdf776a0a2154792f06432d38813badf98975 SHA512 81feb228c27ed433a97546e4ace794f8718d6c3a5d741507d36cb142a63aa20f31259604945dde0020656d8240e0e4cf46295b0e9082e2e1a9cb4fb025472ff8
diff --git a/dev-python/django-registration/django-registration-5.1.0.ebuild b/dev-python/django-registration/django-registration-5.1.0.ebuild
new file mode 100644
index 000000000000..3596be0ba0de
--- /dev/null
+++ b/dev-python/django-registration/django-registration-5.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="user-registration application for Django"
+HOMEPAGE="
+ https://pypi.org/project/django-registration/
+ https://github.com/ubernostrum/django-registration/
+"
+SRC_URI="
+ https://github.com/ubernostrum/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/confusable-homoglyphs-3.0[${PYTHON_USEDEP}]
+ >=dev-python/django-4.2[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ local -x DJANGO_SETTINGS_MODULE=tests.settings
+ PYTHONPATH=. "${EPYTHON}" runtests.py || die "Tests failed with ${EPYTHON}"
+}