summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-09-01 17:15:28 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-09-01 18:03:40 +0000
commitc3ab5ece8caaf00fcfc5a822bb5b5582326253a3 (patch)
tree89ce9de9eff1be733898870d1a35e47c6ce9860e /dev-python
parentdev-python/photutils: version bump (diff)
downloadgentoo-c3ab5ece8caaf00fcfc5a822bb5b5582326253a3.tar.gz
gentoo-c3ab5ece8caaf00fcfc5a822bb5b5582326253a3.tar.bz2
gentoo-c3ab5ece8caaf00fcfc5a822bb5b5582326253a3.zip
dev-python/specutils: version bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/specutils/Manifest1
-rw-r--r--dev-python/specutils/specutils-0.2.2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/specutils/Manifest b/dev-python/specutils/Manifest
index d7c90f174fc5..3be35784d4ab 100644
--- a/dev-python/specutils/Manifest
+++ b/dev-python/specutils/Manifest
@@ -1 +1,2 @@
+DIST specutils-0.2.2.tar.gz 3349951 SHA256 85dba626e4ea2750eadb65e0a16147bc33e174f68e412c5d53688560e0e3f6f7 SHA512 34afeaa33dc529372b926d905024c88786fd622864b35c3d811ce9f99ac26146b13951ed6334e1041c98b0f31ed86e60f21ec9306808b5d52167d9349f139e07 WHIRLPOOL fb177acb76f53314db1c786ad5811861553254939d9568d7acbef774e877a7a085943f99b956a32fd5b378905e19258d6000d437c4c56230bd31b9dd70d82a65
DIST specutils-0.2.tar.gz 3348219 SHA256 e232013a0615105b07a388be1a5faca2b26a71ee19dcf454508229188356df98 SHA512 ac05a795ddf3e690c7f5f7fe1a4b0340b546363ac132ce78bedc6ce364feb7418d896e18302ce391717cc507dbd37de210f5b6dfcfda2c44f9f8e0191619bace WHIRLPOOL 885e8060519842652d845a5afb69fecea5768ba00d7e05877e31349a546ad80b36a132fb0e4ca6ae82b8eb9a7c49dc5180baaf245051c62f3776c74f060f35ca
diff --git a/dev-python/specutils/specutils-0.2.2.ebuild b/dev-python/specutils/specutils-0.2.2.ebuild
new file mode 100644
index 000000000000..004433701606
--- /dev/null
+++ b/dev-python/specutils/specutils-0.2.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit distutils-r1
+
+DESCRIPTION="Python package for astronomy spectral operations"
+HOMEPAGE="https://specutils.readthedocs.org/"
+SRC_URI="https://github.com/astropy/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc test"
+DOCS=( README.rst )
+
+RDEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ python_setup
+ VARTEXFONTS="${T}"/fonts \
+ MPLCONFIGDIR="${BUILD_DIR}" \
+ PYTHONPATH="${BUILD_DIR}"/lib \
+ esetup.py build_sphinx
+ fi
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/ )
+ distutils-r1_python_install_all
+}