summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-03-29 15:26:08 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-03-29 15:26:08 +0200
commitc2aaf7fd68ff35054c7ae08b5ab8de2a4af9c009 (patch)
tree0ed3f4f4270623e70a667f6342f39dab8551f53b /dev-python
parentdev-python/jupyter-lsp: add 2.0.1 (diff)
downloadgentoo-c2aaf7fd68ff35054c7ae08b5ab8de2a4af9c009.tar.gz
gentoo-c2aaf7fd68ff35054c7ae08b5ab8de2a4af9c009.tar.bz2
gentoo-c2aaf7fd68ff35054c7ae08b5ab8de2a4af9c009.zip
dev-python/jupyter_ydoc: add 1.0.0
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jupyter_ydoc/Manifest1
-rw-r--r--dev-python/jupyter_ydoc/files/jupyter_ydoc-1.0.0-no-node-for-version.patch30
-rw-r--r--dev-python/jupyter_ydoc/jupyter_ydoc-1.0.0.ebuild47
3 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/jupyter_ydoc/Manifest b/dev-python/jupyter_ydoc/Manifest
index d7991cb32c70..a27338f6d52f 100644
--- a/dev-python/jupyter_ydoc/Manifest
+++ b/dev-python/jupyter_ydoc/Manifest
@@ -1,2 +1,3 @@
DIST jupyter_ydoc-0.2.2.gh.tar.gz 10664 BLAKE2B d8a0536c07097e359b0145e5ca08f203dcc06d6ff1f556b814cebb5d8798dcd0ca36f70c010f410f4c14a754989db7dc65255863ea7c2610f0201820917f0e90 SHA512 f8db63a1829ffd58c8e773a2c9be674023e58a57dbd7bfffdfaf37ee735bf6cbd62c984df830198b1e8bdd5d1bcb1679cef07a77af36b02c72a704d6e9e295ca
DIST jupyter_ydoc-0.3.4.gh.tar.gz 172549 BLAKE2B 1dd9d7e88736c8fb4681a47ba70d57871b94d2e64947fd5f469f4e0884705011f50e31f04c7f5cc0aaeb98987bf1ccf09029daa849c7aa644a04fb3dbc743742 SHA512 23523c91daf799f944684ea0b3f7768ab2625472b1f9d330fca3be91a532e0ec676cef4c2a82ee33af129e3ac9a1165272386b573098e4267af68c872607c1d1
+DIST jupyter_ydoc-1.0.0.gh.tar.gz 985632 BLAKE2B 6e4456d3eb96f40e4703d7a1413d62d82497ff46fa15c3e0c6a9dd6544cdbddf5cb5b24d87e135170af643bc45b6b88a0a5f5a3fd03986d85f8428b5f12c4b85 SHA512 7cf8f37fb28ce1b0cf02e5e2db642e6fd5debbf5cb6a119b5291ea2930b177d5f17d7236e105891e828e2c0a4ced3c06cb4e78a1b6c2c318e2674fa5da2a8b8b
diff --git a/dev-python/jupyter_ydoc/files/jupyter_ydoc-1.0.0-no-node-for-version.patch b/dev-python/jupyter_ydoc/files/jupyter_ydoc-1.0.0-no-node-for-version.patch
new file mode 100644
index 000000000000..2195a0d60e0b
--- /dev/null
+++ b/dev-python/jupyter_ydoc/files/jupyter_ydoc-1.0.0-no-node-for-version.patch
@@ -0,0 +1,30 @@
+diff --git a/pyproject.toml b/pyproject.toml
+index 6e0a069..42f76c1 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -2,12 +2,12 @@
+ # Distributed under the terms of the Modified BSD License.
+
+ [build-system]
+-requires = ["hatchling>=1.10.0", "hatch-nodejs-version"]
++requires = ["hatchling>=1.10.0"]
+ build-backend = "hatchling.build"
+
+ [project]
+ name = "jupyter-ydoc"
+-dynamic = ["version"]
++version = "1.0.0"
+ description = "Document structures for collaborative editing using Ypy"
+ requires-python = ">=3.7"
+ keywords = ["jupyter", "ypy"]
+@@ -56,10 +56,6 @@ text = "BSD 3-Clause License"
+ Homepage = "https://jupyter.org"
+ Source = "https://github.com/jupyter-server/jupyter_ydoc"
+
+-[tool.hatch.version]
+-source = "nodejs"
+-path = "javascript/package.json"
+-
+ [tool.hatch.build]
+ exclude = ["javascript", "!javascript/package.json"]
+
diff --git a/dev-python/jupyter_ydoc/jupyter_ydoc-1.0.0.ebuild b/dev-python/jupyter_ydoc/jupyter_ydoc-1.0.0.ebuild
new file mode 100644
index 000000000000..6b92a4de8d15
--- /dev/null
+++ b/dev-python/jupyter_ydoc/jupyter_ydoc-1.0.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Document structures for collaborative editing using Ypy"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter-server/jupyter_ydoc/
+ https://pypi.org/project/jupyter-ydoc/
+"
+SRC_URI="https://github.com/jupyter-server/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Requires node
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/y-py-0.6.0[${PYTHON_USEDEP}]
+ <dev-python/y-py-0.7.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.8.3[${PYTHON_USEDEP}]
+ ' 3.9)
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ >=dev-python/websockets-10.0[${PYTHON_USEDEP}]
+ <dev-python/ypy-websocket-0.9.0[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-no-node-for-version.patch"
+)
+
+distutils_enable_tests pytest
+# Hangs for some reason
+#distutils_enable_sphinx docs/source dev-python/myst-parser dev-python/pydata-sphinx-theme