summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-26 07:48:05 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-26 08:10:13 +0100
commit970cad127b6b68ae2bd9b3b91c212ec71366245c (patch)
tree3305b224deaf2234ab47b6a535aa63d0cf62d70b /dev-python
parentdev-python/python-xlib: Bump to 0.33 (diff)
downloadgentoo-970cad127b6b68ae2bd9b3b91c212ec71366245c.tar.gz
gentoo-970cad127b6b68ae2bd9b3b91c212ec71366245c.tar.bz2
gentoo-970cad127b6b68ae2bd9b3b91c212ec71366245c.zip
dev-python/huawei-lte-api: Bump to 1.6.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/huawei-lte-api/Manifest1
-rw-r--r--dev-python/huawei-lte-api/huawei-lte-api-1.6.10.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/huawei-lte-api/Manifest b/dev-python/huawei-lte-api/Manifest
index 7998ded4c08f..85a60f41593d 100644
--- a/dev-python/huawei-lte-api/Manifest
+++ b/dev-python/huawei-lte-api/Manifest
@@ -1,2 +1,3 @@
+DIST huawei-lte-api-1.6.10.gh.tar.gz 36991 BLAKE2B d0999e8988bce8d8683b64423bb5f7380224fb4a6c7068f21107987d8e98921a6db54fca18e4e336320b4ee586d9e77adb56a13a4aeda80c14cd2533acad4a57 SHA512 183232335d7a313af57c7812e18365d4b3ce3bcda9f0a857fc30a04357e2ac2c72e95fbb4593d8e2b83c5cebed9922bac1f6910ad06929ff051678769a047fa2
DIST huawei-lte-api-1.6.7.gh.tar.gz 34677 BLAKE2B 289f9aefbf0c9491dcaa3a0afc120a70d578092e4bcf1ae66d30cff528dfa8231dbfc60c4660d8862b82801429b61bb97f584319e49307cbd44051cbf1c80239 SHA512 184c3e05e5d1b3b19ebdd3caaceb79fecbe8ed7f2337d7d4b0dc392f6e6ca8f45f663c8d6056d8660e8167f357d329015fd13b521093ae92b0a9a6b04c42e352
DIST huawei-lte-api-1.6.9.gh.tar.gz 35605 BLAKE2B e81e3769fdd6307ae69cb0ff59bbe5e6c8e1cfe2a9629c683859c0ff0dfb9d44376f0d0cb33c40f7ed0211ca7ea4f990d8f471a154605475db2f126ec9bcf080 SHA512 224236356f899e8d621e87320e58faef7a4a313105d1938ba3fdc0fbe9f8e2b1135eac62aca39cd2f7c677e1aaa822821677adbbd18df4f00b7cf475c986a1f8
diff --git a/dev-python/huawei-lte-api/huawei-lte-api-1.6.10.ebuild b/dev-python/huawei-lte-api/huawei-lte-api-1.6.10.ebuild
new file mode 100644
index 000000000000..5b62e249fda3
--- /dev/null
+++ b/dev-python/huawei-lte-api/huawei-lte-api-1.6.10.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="API For huawei LAN/WAN LTE Modems"
+HOMEPAGE="
+ https://github.com/Salamek/huawei-lte-api/
+ https://pypi.org/project/huawei-lte-api/
+"
+SRC_URI="
+ https://github.com/Salamek/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # make cryptodome-friendly
+ sed -i -e 's:pycryptodomex:pycryptodome:' setup.py || die
+ find -name '*.py' -exec \
+ sed -i -e 's:Cryptodome:Crypto:g' {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+distutils_enable_tests pytest