summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-03 06:58:52 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-03 07:23:22 +0200
commit833ce4fbe4d9cee17c5bda9242344c72d89b4487 (patch)
treeb2dc67086da7e120f027fceaf1191dfa63997cfc /dev-python
parentdev-python/openapi-core: Bump to 0.19.4 (diff)
downloadgentoo-833ce4fbe4d9cee17c5bda9242344c72d89b4487.tar.gz
gentoo-833ce4fbe4d9cee17c5bda9242344c72d89b4487.tar.bz2
gentoo-833ce4fbe4d9cee17c5bda9242344c72d89b4487.zip
dev-python/doc8: Bump to 1.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/doc8/Manifest1
-rw-r--r--dev-python/doc8/doc8-1.1.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/doc8/Manifest b/dev-python/doc8/Manifest
index 510c83beecc5..bd4cfddbd0f3 100644
--- a/dev-python/doc8/Manifest
+++ b/dev-python/doc8/Manifest
@@ -1 +1,2 @@
DIST doc8-1.1.1.tar.gz 26514 BLAKE2B 847e34081f4e00698cbe3ca9b7325de2995c45bd02b2f443459050a2801a5b476222c345c4ba06463fc6ff489c3c59e5b6e7abbd7b98af740f09d5b04771a4b2 SHA512 7ec21c2483f7ebf2a7e1fef6677c6051ac253da6014354a968b8a107d8097f986b6b162850561fd6a103e93d157b2c849554aabe2484a49c4a3726c8e2083a89
+DIST doc8-1.1.2.tar.gz 27030 BLAKE2B 76c02acb4165bc70a5f84a68c44a1560ca2fe7eae97efe12e93f48922439ca5141028be4be78f3edaff5e25757bf668e567b77ca2f46c0844a54b085da9e3e1e SHA512 77e6dd1abe99ae993138653093458672e8af281e9c195696b67e2ba1a2d0ef4f1b77dd9f24077f159d0b6d9dbb2c78b5b24fc1a6121e2a199fe72528e3926072
diff --git a/dev-python/doc8/doc8-1.1.2.ebuild b/dev-python/doc8/doc8-1.1.2.ebuild
new file mode 100644
index 000000000000..e07ea6f14043
--- /dev/null
+++ b/dev-python/doc8/doc8-1.1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Style checker for Sphinx (or other) RST documentation"
+HOMEPAGE="
+ https://pypi.org/project/doc8/
+ https://github.com/PyCQA/doc8/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/docutils-0.19[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/restructuredtext-lint-0.7[${PYTHON_USEDEP}]
+ dev-python/stevedore[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ # unpin docutils
+ sed -i -e '/docutils/s:,<=[0-9.]*::' pyproject.toml || die
+}