summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-20 16:41:20 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-06-08 21:15:10 +0200
commit77942a08e5dfba186e4a2a4a65f58e5b37829b9c (patch)
tree2ffbc19b63c49cf3feb4e1d93331dddbefb5e469 /dev-python
parentnet-libs/libqrtr-glib: Add package, v1.2.2 (diff)
downloadgentoo-77942a08e5dfba186e4a2a4a65f58e5b37829b9c.tar.gz
gentoo-77942a08e5dfba186e4a2a4a65f58e5b37829b9c.tar.bz2
gentoo-77942a08e5dfba186e4a2a4a65f58e5b37829b9c.zip
dev-python/sip: add 6.6.1, enable py3.11
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sip/Manifest1
-rw-r--r--dev-python/sip/files/sip-6.6.1-python311-invalid-regex.patch21
-rw-r--r--dev-python/sip/sip-6.6.1.ebuild39
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/sip/Manifest b/dev-python/sip/Manifest
index 52c9a17c715e..e7ef4971e16e 100644
--- a/dev-python/sip/Manifest
+++ b/dev-python/sip/Manifest
@@ -2,3 +2,4 @@ DIST sip-4.19.25.tar.gz 1056384 BLAKE2B f92e105e6b30e871aea2883dc9cd459e4032fb13
DIST sip-5.5.0.tar.gz 1108126 BLAKE2B 59f0323b3befd7ebb89461e93e1e7e5707d11b2882bd524a45f3a6ba8d8a3c792aff5580027255812f6a3fa0854febeb418690fa6106efb21aab1610d66ef911 SHA512 0122beab575239cdb3b1430dc53a7f74175e3fbb3e113bcafced122ffbc4bd3d339b64a672ac1319ea14cd540b5877c2bcfeb7f8821fe8a3c8ba3ce9744bf803
DIST sip-6.4.0.tar.gz 1201890 BLAKE2B be5ccdfa7853eb2baa3b7c4e7f64a315e39ef899631e93569d75ed27bbf9752c97cca1bfd6c813efb0046d1d82fc8c5625a04f08c330a4e2c102461f3a42beee SHA512 eec1bdbe4ef3d8ba5152a2dcd888efc23498bcbee01c95b7eb72074c2a133d8e8599cc4bb6d6b2fec99f093a73705e0fea1c148c2e49058c0fd6f2ba97f40884
DIST sip-6.5.0.tar.gz 1202004 BLAKE2B a67ba784c0851a528fded689cc2a84fa18ba906d23adb71fceab14e652c02b079ce7d3b40a3594251852d20875ac53571e851630e441b8846c302772933b1829 SHA512 3baa20403b668e5f02b2506a693522ce421080e073ac39f62a23823b3e023b0b88fc60ab79e2301ecc39304f6df3d8647adc56429641e91c217fecea9bfacb91
+DIST sip-6.6.1.tar.gz 1134991 BLAKE2B dec51bce80566ffad25dd67686a746134e032f3cf1696fbf256d000d266f9e3921dcafaead40bcf3dc67d42aa89c5982d090abde7d8b3c3f8ec6ddd4470b9a43 SHA512 49d03730819210f4239946da0ddd0694583dc13458997edc11895ef399d8017f38e3354a87bae495492c3cf3334b810c2d924ec0f5bbb129e88cc15eac720c01
diff --git a/dev-python/sip/files/sip-6.6.1-python311-invalid-regex.patch b/dev-python/sip/files/sip-6.6.1-python311-invalid-regex.patch
new file mode 100644
index 000000000000..908111627854
--- /dev/null
+++ b/dev-python/sip/files/sip-6.6.1-python311-invalid-regex.patch
@@ -0,0 +1,21 @@
+
+# HG changeset patch
+# User Phil Thompson <phil@riverbankcomputing.com>
+# Date 1651507410 -3600
+# Node ID 3d656f0765f508ea9714b5e7c9ce00e304e6f600
+# Parent c179f418c5bee188e3ec7a0c0e50f9eab34cf12f
+Fixed indented directives.
+
+diff -r c179f418c5be -r 3d656f0765f5 sipbuild/generator/parser/tokens.py
+--- a/sipbuild/generator/parser/tokens.py Mon May 02 16:51:06 2022 +0100
++++ b/sipbuild/generator/parser/tokens.py Mon May 02 17:03:30 2022 +0100
+@@ -174,7 +174,7 @@
+
+ # Handle directives.
+ def t_DIRECTIVE(t):
+- r'(?m)^\s*%[a-zA-Z][a-zA-Z]*'
++ r'%[a-zA-Z][a-zA-Z]*'
+
+ # The name of the directive is used as its type.
+ name = t.value[t.value.index('%') + 1:]
+
diff --git a/dev-python/sip/sip-6.6.1.ebuild b/dev-python/sip/sip-6.6.1.ebuild
new file mode 100644
index 000000000000..4e130e33eb13
--- /dev/null
+++ b/dev-python/sip/sip-6.6.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Python bindings generator for C/C++ libraries"
+HOMEPAGE="https://www.riverbankcomputing.com/software/sip/ https://pypi.org/project/sip/"
+
+MY_P=${PN}-${PV/_pre/.dev}
+if [[ ${PV} == *_pre* ]]; then
+ SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+fi
+S=${WORKDIR}/${MY_P}
+
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+SLOT="5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ !<dev-python/sip-4.19.25-r1[${PYTHON_USEDEP}]
+ !=dev-python/sip-5.5.0-r0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-python311-invalid-regex.patch"
+ "${FILESDIR}/${PN}-6.5.0-pep517-args.patch"
+)
+
+distutils_enable_sphinx doc --no-autodoc