summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2023-06-28 17:29:16 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2023-06-29 09:47:37 +0300
commit752cf8b31a347959e9ad0d06e26fde7181f98c0c (patch)
tree7eca92654f81da6a4ace37ed461a51ac36488467 /dev-python
parentwww-client/firefox: keyword 114.0 for ~ppc64 (diff)
downloadgentoo-752cf8b31a347959e9ad0d06e26fde7181f98c0c.tar.gz
gentoo-752cf8b31a347959e9ad0d06e26fde7181f98c0c.tar.bz2
gentoo-752cf8b31a347959e9ad0d06e26fde7181f98c0c.zip
dev-python/sphinx-copybutton: new package, add 0.5.2
Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinx-copybutton/Manifest1
-rw-r--r--dev-python/sphinx-copybutton/metadata.xml15
-rw-r--r--dev-python/sphinx-copybutton/sphinx-copybutton-0.5.2.ebuild22
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/sphinx-copybutton/Manifest b/dev-python/sphinx-copybutton/Manifest
new file mode 100644
index 000000000000..2a1ecd3b7d6a
--- /dev/null
+++ b/dev-python/sphinx-copybutton/Manifest
@@ -0,0 +1 @@
+DIST sphinx-copybutton-0.5.2.tar.gz 23039 BLAKE2B 5a440865610dbcfc8abc8a10c38832439d5f588a26a8641374cada3cc181a0ba2a19e62b287a296c1879f25342ce8aae1ade080126f837e5ad9291c152a30c6e SHA512 83f61526d8a20f70b0de63a5bad89ed4ae4f3cf5cd589f1a1e2e91f08f4d45a05acf780a4cf3703d4490ab93c9c9bb18c11d3170b8011c2254aab0334940ab2d
diff --git a/dev-python/sphinx-copybutton/metadata.xml b/dev-python/sphinx-copybutton/metadata.xml
new file mode 100644
index 000000000000..343dee9179fb
--- /dev/null
+++ b/dev-python/sphinx-copybutton/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">executablebooks/sphinx-copybutton</remote-id>
+ <remote-id type="pypi">sphinx-copybutton</remote-id>
+ <doc>https://sphinx-copybutton.readthedocs.io</doc>
+ <bugs-to>https://github.com/executablebooks/sphinx-copybutton/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinx-copybutton/sphinx-copybutton-0.5.2.ebuild b/dev-python/sphinx-copybutton/sphinx-copybutton-0.5.2.ebuild
new file mode 100644
index 000000000000..297c59d28f0d
--- /dev/null
+++ b/dev-python/sphinx-copybutton/sphinx-copybutton-0.5.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYPI_NO_NORMALIZE=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A small sphinx extension to add a \"copy\" button to code blocks"
+HOMEPAGE="https://pypi.org/project/sphinx-copybutton/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/sphinx-6.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest