summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-26 08:05:38 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-26 08:10:17 +0100
commit5e0bf4941f5df82788420dce2a30ad79647ce8de (patch)
tree1ae6ce761a615aabff167507afca114d028d4329 /dev-python
parentdev-python/seedir: New package, v0.4.2 (diff)
downloadgentoo-5e0bf4941f5df82788420dce2a30ad79647ce8de.tar.gz
gentoo-5e0bf4941f5df82788420dce2a30ad79647ce8de.tar.bz2
gentoo-5e0bf4941f5df82788420dce2a30ad79647ce8de.zip
dev-python/sybil: Bump to 4.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sybil/Manifest1
-rw-r--r--dev-python/sybil/sybil-4.0.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index df143e6c4dbb..c5dc440f16fa 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1 +1,2 @@
DIST sybil-3.0.1.tar.gz 38265 BLAKE2B 3a9dd8d85a5a6228944f104d255826b4dfee80f5a349da3a0fa69edcfa0953145378f002c1bf834e21c0d382fc96a993b927bdc92bb3e9a84d34998ad6ade62f SHA512 312c57f0de646b1e7a3b992806362c1020b2d567c805d248e94ab22a336a8fc77704234e123e1ec74987bfea620b2f8c4d3714d32aee03587c615d3d90fe5558
+DIST sybil-4.0.0.gh.tar.gz 50845 BLAKE2B 5c7144ad1dd131f98c48f18cf6770782529a3c86a3f976461f032c9024ef93dc2de3c8bc327421a55a3f505982608e15cdcfe022f964c4fd871bd9de61205d68 SHA512 6cf0422ba856a85ba5dd105481cb2d06eb2ff196aee263a36e7ab44c7d45185df022bd859afc92b3b42dc418142e441f377adda82c0b5b0d1410697b563db994
diff --git a/dev-python/sybil/sybil-4.0.0.ebuild b/dev-python/sybil/sybil-4.0.0.ebuild
new file mode 100644
index 000000000000..1cb06c5c1fb1
--- /dev/null
+++ b/dev-python/sybil/sybil-4.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="
+ https://github.com/simplistix/sybil/
+ https://pypi.org/project/sybil/
+"
+SRC_URI="
+ https://github.com/simplistix/sybil/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/myst_parser[${PYTHON_USEDEP}]
+ dev-python/seedir[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest