summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-04-19 23:15:11 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-04-20 00:25:32 -0700
commit371831a1635ba9e7d691dd1567f99424bed26643 (patch)
treea0268ca5fe6fe28dadca109f08025bcbd93d8269 /dev-python
parentnet-libs/grpc: bump to 1.28.1 (diff)
downloadgentoo-371831a1635ba9e7d691dd1567f99424bed26643.tar.gz
gentoo-371831a1635ba9e7d691dd1567f99424bed26643.tar.bz2
gentoo-371831a1635ba9e7d691dd1567f99424bed26643.zip
dev-python/grpcio: bump to 1.28.1
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/grpcio/Manifest1
-rw-r--r--dev-python/grpcio/grpcio-1.28.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/grpcio/Manifest b/dev-python/grpcio/Manifest
index bff63af10b65..c79340241f2e 100644
--- a/dev-python/grpcio/Manifest
+++ b/dev-python/grpcio/Manifest
@@ -1 +1,2 @@
DIST grpcio-1.26.0.tar.gz 15406206 BLAKE2B 4a9031e1d9e9285d1c1ee90396ae339a47715fa2c279f5bce517e3ea02bdc755e3044e3e402f73b3d797a6b1415f58396097a55ba16200c7f9d4569b0b159fe3 SHA512 df3b6787449c202f3e70640907c76231dbbeb6b411167300ba8a53c17f7d45ffa513a81046a4a66a368f2c17c2d57a48a07cb236f44a005e4073bd5d8aa3865c
+DIST grpcio-1.28.1.tar.gz 19511346 BLAKE2B 01ebdeddcba5efbb67880693ede04ccd828771fe73def24a91d882c28f5cf6f14215daca212df1d8bb9372f385aff1e31418870437c87343f218e7b78a06b04c SHA512 12feaee3816a5e7b20b648a144d37f7e550a057112f5460bc4ec016885461951148cd4d2900fbfc905f76059ef29ae4c4d1d5a3216e5e3a2d17048c8b45f394f
diff --git a/dev-python/grpcio/grpcio-1.28.1.ebuild b/dev-python/grpcio/grpcio-1.28.1.ebuild
new file mode 100644
index 000000000000..3a7c37294781
--- /dev/null
+++ b/dev-python/grpcio/grpcio-1.28.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="High-performance RPC framework (python libraries)"
+HOMEPAGE="https://grpc.io"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-libs/openssl-1.0.2:0=[-bindist]
+ >=dev-python/cython-0.28.3[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ net-dns/c-ares:=
+ sys-libs/zlib:=
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_configure_all() {
+ export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY=1
+ export GRPC_PYTHON_BUILD_SYSTEM_CARES=1
+ export GRPC_PYTHON_BUILD_SYSTEM_OPENSSL=1
+ export GRPC_PYTHON_BUILD_SYSTEM_ZLIB=1
+ export GRPC_PYTHON_BUILD_WITH_CYTHON=1
+ export GRPC_PYTHON_BUILD_EXT_COMPILER_JOBS="$(makeopts_jobs)"
+}