summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-17 06:46:48 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-17 07:58:51 +0200
commit28c61bedacee13e986a3a4f72f9aa43234f22817 (patch)
tree1fe9f55f0b6b58458e13c494c5f5b89070013d15 /dev-python
parentdev-python/botocore: Bump to 1.29.155 (diff)
downloadgentoo-28c61bedacee13e986a3a4f72f9aa43234f22817.tar.gz
gentoo-28c61bedacee13e986a3a4f72f9aa43234f22817.tar.bz2
gentoo-28c61bedacee13e986a3a4f72f9aa43234f22817.zip
dev-python/boto3: Bump to 1.26.155
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.26.155.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 21f3d23c315f..dbdc2a7dd50f 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,3 +4,4 @@ DIST boto3-1.26.151.gh.tar.gz 661732 BLAKE2B 8adc42757d828414dd4bde9f460bc9fd678
DIST boto3-1.26.152.gh.tar.gz 662874 BLAKE2B 31866c0c3244cdb868fadaf985410e5577d8d75f37387ee44f6ce879ae06c282a4e85e262da4bab3e588918b126110c10b5a64bf7764f076baf495a4382cd225 SHA512 3d496da055172bbc840a3a6f8bd7df6f24bbb1f2f5dbacbbc0e337d4bd15d1355b9fd2e5dbb9e611aa1e415d11dc32bd0b61428a0d0ce7e2d55bb143a0cf1491
DIST boto3-1.26.153.gh.tar.gz 663859 BLAKE2B 6c5a04fcaa6dde09a09552c2687a2ad1a780ce703cc60eda84c2fa6ad9061dd5f0a4aa0c8f7a7d15f73da2abd9f28d12f8f3d4f859a552cc355bde16f9b306aa SHA512 70117de2475d82f4bb94be2033b7ba18447290f767334d3ea11c60807619d76846003868439f1d025b396df12b91e126f4935f7438d649ca2ee7d629f0a499f4
DIST boto3-1.26.154.gh.tar.gz 664248 BLAKE2B d36363c3a1561392fe9217c694f263ed34d10fee42141efffbe9d0899e5472d765af717a148deb9b3ef2abe654dcbb5840557d24644763a43ebda61fb39d7b5a SHA512 3aa8b243f9a39921c48d7d63ffb0be64f3bf8dbb824df03e7aafea072a218973660deb52b80ec23367f2a94f8bb9b2ee284a5b4d41d0edd81a1ea063cf94f453
+DIST boto3-1.26.155.gh.tar.gz 664838 BLAKE2B 35c78d4da5bcba6f218a854d67647b71b16915b380271ed03c79775c547ab69fadd750f58557460445d5a6448f927042cccb6cea6e14670dda7e59ccac3c5b5f SHA512 40197333b87c85119428faa35489207ffdc6c03cec03c6446e239d616bd19a40da1512e5ce43618fea9465f174564b533021ba95e26d105a00786dfe47ec7342
diff --git a/dev-python/boto3/boto3-1.26.155.ebuild b/dev-python/boto3/boto3-1.26.155.ebuild
new file mode 100644
index 000000000000..2a4a7643203e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.155.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}