summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-01 06:33:13 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-01 07:22:19 +0200
commit18c54b66034c737e1ef8b7b65cec546f1f49a33f (patch)
tree72dc2d5e1d740b26bd6d8b944a12dd3c4518d26e /dev-python
parentdev-python/trimesh: Bump to 3.22.3 (diff)
downloadgentoo-18c54b66034c737e1ef8b7b65cec546f1f49a33f.tar.gz
gentoo-18c54b66034c737e1ef8b7b65cec546f1f49a33f.tar.bz2
gentoo-18c54b66034c737e1ef8b7b65cec546f1f49a33f.zip
dev-python/hcloud-python: Bump to 1.23.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hcloud-python/Manifest1
-rw-r--r--dev-python/hcloud-python/hcloud-python-1.23.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/hcloud-python/Manifest b/dev-python/hcloud-python/Manifest
index 9775aa93c914..b9b197baa131 100644
--- a/dev-python/hcloud-python/Manifest
+++ b/dev-python/hcloud-python/Manifest
@@ -2,3 +2,4 @@ DIST hcloud-python-1.20.0.gh.tar.gz 100107 BLAKE2B 584e1399ddb1c5d1e5ad0beaf7956
DIST hcloud-python-1.21.0.gh.tar.gz 102150 BLAKE2B 4ec6fb813f61f3c487d632e12a71f9105af5d45a307567fd2b22ff716e30c645bffebc5cd768846fc7d7892ab753d3e4487a1b72edfee62fb99dfefe188be41d SHA512 8226a79324f0097d576cc1336e813a28a562fb9c3f50dcac1debb3c32bb52f4f5e563e920e2bbb6ce8be407a65de321b734d30156fd066d74ed95f6e6bd94a35
DIST hcloud-python-1.22.0.gh.tar.gz 103301 BLAKE2B 0280567bf75dfe1e684cc9a630cd9c517a9039add7b8937d6293fdddf55e593afa68c4ee7ffc73c186b3444d47fb5dcd385229bace3cf058a37497790d2abf46 SHA512 fca41cc61033c050981588633f9a9801a444db5782eafa35933dec5011f24542a103b1c900b9a830ea426418070d060e4ec407941d54cb9579291a7b467e6a22
DIST hcloud-python-1.23.0.gh.tar.gz 101752 BLAKE2B 5a8746d7ea58e3ba89271efe541183c72792480b81307433a899278e0e6037e3b5d59519a9d1af4ffeaf391b20643cec33fdd8b82019faf29ed865c4563ff96b SHA512 94463080d0b0605efbbc5bc193c602ae207d45ca7accd5a370b8ba7663d867bf065f5cf154f51095f6ae8b4fb2470202512ba3f61df36d2f6e04bf7ad2a606a5
+DIST hcloud-python-1.23.1.gh.tar.gz 102214 BLAKE2B e8e16a9a4435b579ee7e72738c296b1ee55c15d3868da39c58fcf9489479451e7adfe046696ffd9728a529f60003a4ebe26b0c07f322296ef1e3fe468fe0e9ed SHA512 cf5497b4906cb2abece9afd64fad0aad4deedecafb50f6977c29f0a38951287be07f9f75a18e1ce4cbcedf38261c146236526be7581d8362c6d6ecf7c38992b9
diff --git a/dev-python/hcloud-python/hcloud-python-1.23.1.ebuild b/dev-python/hcloud-python/hcloud-python-1.23.1.ebuild
new file mode 100644
index 000000000000..748e02d44670
--- /dev/null
+++ b/dev-python/hcloud-python/hcloud-python-1.23.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=hcloud-python-${PV}
+DESCRIPTION="Official Hetzner Cloud python library"
+HOMEPAGE="
+ https://github.com/hetznercloud/hcloud-python/
+ https://pypi.org/project/hcloud/
+"
+# sdist is missing doc assets as of 1.19.0
+# https://github.com/hetznercloud/hcloud-python/pull/183
+SRC_URI="
+ https://github.com/hetznercloud/hcloud-python/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/requests-2.20[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Integration tests need docker:
+ # https://github.com/hetznercloud/hcloud-python/blob/master/.travis.yml#L16
+ tests/integration
+)
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}