summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-29 06:12:45 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-29 07:05:25 +0200
commit04c39e7892f47fe103c3e55ac33d3bc0e183d42d (patch)
treef06fc4b29aa6e65343711de6a384803dabbc3a4f /dev-python
parentdev-python/Nuitka: Bump to 1.6.6 (diff)
downloadgentoo-04c39e7892f47fe103c3e55ac33d3bc0e183d42d.tar.gz
gentoo-04c39e7892f47fe103c3e55ac33d3bc0e183d42d.tar.bz2
gentoo-04c39e7892f47fe103c3e55ac33d3bc0e183d42d.zip
dev-python/typing-extensions: Bump to 4.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/typing-extensions/Manifest1
-rw-r--r--dev-python/typing-extensions/typing-extensions-4.7.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/typing-extensions/Manifest b/dev-python/typing-extensions/Manifest
index 98592f53816a..f3320bb3913e 100644
--- a/dev-python/typing-extensions/Manifest
+++ b/dev-python/typing-extensions/Manifest
@@ -1 +1,2 @@
DIST typing_extensions-4.6.3.gh.tar.gz 75114 BLAKE2B 2c6761d26de5ce4a09c2957e93225798d282dcbc5689921f72acd2ccc338e458e21b2b73884af4a329c65f1a7eed7898e13e87fdab7fce757b4927adcdb09770 SHA512 4c8dd4e1494ed504466f3188146059203f9ce37b8f2d9f70929c1bffa7e58bee87c3ef01162cedb55ba3fd048cec0da96cc4141b25ba76dc32c7d493a69efeab
+DIST typing_extensions-4.7.0.gh.tar.gz 84473 BLAKE2B 786a305e31a93ca70e964a42209f3e8f5574950054305b4bea077b0ba5452a478c10f2c8e6b2fbe13460d1f5e8fa12d1b6df18b2260ba62eeca7b3b7d7948715 SHA512 02c72581a197af989996f7d887919a6c91966d3c1d15a39dee9670a37b61e796c3aff7e544b01d9d2bd3932024a27054f03ccbe1a4b0370a310454bcebf904f3
diff --git a/dev-python/typing-extensions/typing-extensions-4.7.0.ebuild b/dev-python/typing-extensions/typing-extensions-4.7.0.ebuild
new file mode 100644
index 000000000000..df5b00b2ff74
--- /dev/null
+++ b/dev-python/typing-extensions/typing-extensions-4.7.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/-/_}
+DESCRIPTION="Backported and Experimental Type Hints for Python 3.7+"
+HOMEPAGE="
+ https://pypi.org/project/typing-extensions/
+ https://github.com/python/typing_extensions/
+"
+SRC_URI="
+ https://github.com/python/typing_extensions/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+distutils_enable_tests unittest
+
+python_test() {
+ cd src || die
+ eunittest
+}