summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-05 06:38:28 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-05 06:50:54 +0200
commitb83cafb69bad3f0c4c42f82fdbe5fef5faf782cc (patch)
tree13b330bf5b55c7140bec958a817939527d7dd73c /dev-python/zipp
parentdev-python/nodeenv: Bump to 1.9.1 (diff)
downloadgentoo-b83cafb69bad3f0c4c42f82fdbe5fef5faf782cc.tar.gz
gentoo-b83cafb69bad3f0c4c42f82fdbe5fef5faf782cc.tar.bz2
gentoo-b83cafb69bad3f0c4c42f82fdbe5fef5faf782cc.zip
dev-python/zipp: Bump to 3.19.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zipp')
-rw-r--r--dev-python/zipp/Manifest1
-rw-r--r--dev-python/zipp/zipp-3.19.2.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/zipp/Manifest b/dev-python/zipp/Manifest
index cf8377387047..08fa7ac3e3e9 100644
--- a/dev-python/zipp/Manifest
+++ b/dev-python/zipp/Manifest
@@ -1,2 +1,3 @@
DIST zipp-3.18.2.tar.gz 21783 BLAKE2B 488c7ebe2a37d5d38f8aac86a578144aaa77d9acb375cb2aa45eb16e5f5d2db30be00827f580ee35b5aa85559001e457054cca1dd34dec7005c0169bd4a4f1b3 SHA512 c8ba020fe210a3c9b54da2f868c324b41d281dc50342f9ce68e493a695d8c8620ab19303fb81bd64cc458667113ef31a890e8e71180a0155a83ed9ead6049bcd
DIST zipp-3.19.1.tar.gz 22625 BLAKE2B 283754c1b2280ac7dcce867555bacdccb59f4183e6b722c7916b5825bc16e1922a15c0b1d5684be0a89ce6672be58f0752e21b85ad02afabeeeb26d9d4706b7a SHA512 c0a4b4055f6652852526b7749d738cedda6534ea21945933ec727b5364a5558697fce6757e4045d30df55a1dce57509c92046f25d6914707fcc97e07f3088c3a
+DIST zipp-3.19.2.tar.gz 22922 BLAKE2B 8f4a115079b6faa730a3502592983c13b2db27541cdbd91723fd20f320d22678f3740b01f24b46f7049607c49953ea64fa8e4855d26f28f0683d330b625a2d0b SHA512 3f1b663c4befef774e076845a8a2d2fc414cb768af0e3bccc57b6b694e9ef28e8dd8ae59b596b269f610b082e9c7a92ec3dcd465aad4e5ebe250ea96df89b2cf
diff --git a/dev-python/zipp/zipp-3.19.2.ebuild b/dev-python/zipp/zipp-3.19.2.ebuild
new file mode 100644
index 000000000000..4c2c0b9b1eb8
--- /dev/null
+++ b/dev-python/zipp/zipp-3.19.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE="
+ https://github.com/jaraco/zipp/
+ https://pypi.org/project/zipp/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+# big_o is only used in test_complexity, that we ignore
+BDEPEND="
+ test? (
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/jaraco-itertools[${PYTHON_USEDEP}]
+ dev-python/jaraco-test[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # performance tests are flaky by design
+ tests/test_complexity.py
+)
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "zipp"
+ version = "${PV}"
+ description = "Backport of pathlib-compatible object wrapper for zip files"
+ EOF
+}