summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-31 15:58:30 +0100
committerMichał Górny <mgorny@gentoo.org>2024-10-31 16:49:55 +0100
commit3feaae9e0ee18137a3ec4a314ed20629dc9d09fa (patch)
tree67b167d52d36c1df52edf23f46210c2feb696cc3 /dev-python/xmlschema
parentdev-python/mkdocs-material: Bump to 9.5.43 (diff)
downloadgentoo-3feaae9e0ee18137a3ec4a314ed20629dc9d09fa.tar.gz
gentoo-3feaae9e0ee18137a3ec4a314ed20629dc9d09fa.tar.bz2
gentoo-3feaae9e0ee18137a3ec4a314ed20629dc9d09fa.zip
dev-python/xmlschema: Bump to 3.4.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xmlschema')
-rw-r--r--dev-python/xmlschema/Manifest1
-rw-r--r--dev-python/xmlschema/xmlschema-3.4.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/xmlschema/Manifest b/dev-python/xmlschema/Manifest
index 3cdb9303dbd4..27f733f79e55 100644
--- a/dev-python/xmlschema/Manifest
+++ b/dev-python/xmlschema/Manifest
@@ -1 +1,2 @@
DIST xmlschema-3.4.2.tar.gz 584249 BLAKE2B 82c01c295932e0e0a503d89b878cd7972550b531edc2aa162b9e6139cf3657890d3b5fe15a8bd667e5adc24ab29b6458f095ad55f9a88b7cd9bca93eed200200 SHA512 fd8c3df89f1768a8670e8bfdb34eaf93b80e191afe6ee15904269f0e3ab728aaeca5c56e046893708aba0c7763421a50b085bd03ec8aba1326f6608b39871b03
+DIST xmlschema-3.4.3.tar.gz 585144 BLAKE2B e93ed5fed2f108f9a067b2c96aff884bda4980d57ad0efedacb7c0302cb7cebc99ce49d98e4272a50f6c6bc79a401218c75cbde682028558bbe6e815b6aeaad3 SHA512 7645ea820ec6f469e560ffaba10948b185d9dcfc7a5d4cde1a5062f20b904cb97ffbc7f57893768879a192cbb63208a5c6f79775d09be650d24a54b1bb7e9176
diff --git a/dev-python/xmlschema/xmlschema-3.4.3.ebuild b/dev-python/xmlschema/xmlschema-3.4.3.ebuild
new file mode 100644
index 000000000000..ffac0df6b109
--- /dev/null
+++ b/dev-python/xmlschema/xmlschema-3.4.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="An XML Schema validator and decoder"
+HOMEPAGE="
+ https://github.com/sissaschool/xmlschema/
+ https://pypi.org/project/xmlschema/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ <dev-python/elementpath-5[${PYTHON_USEDEP}]
+ >=dev-python/elementpath-4.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" tests/test_all.py -v || die "Tests fail with ${EPYTHON}"
+}