summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-17 18:36:35 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-17 19:03:11 +0200
commitf47dc36450311f0cd52e0a3848924758e0bda247 (patch)
tree7440fb8bb409a23349cee1eabe9ef8807e845111 /dev-python/wrapt
parentdev-python/simsimd: Bump to 5.7.3 (diff)
downloadgentoo-f47dc36450311f0cd52e0a3848924758e0bda247.tar.gz
gentoo-f47dc36450311f0cd52e0a3848924758e0bda247.tar.bz2
gentoo-f47dc36450311f0cd52e0a3848924758e0bda247.zip
dev-python/wrapt: Bump to 1.17.0_rc1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wrapt')
-rw-r--r--dev-python/wrapt/Manifest1
-rw-r--r--dev-python/wrapt/wrapt-1.17.0_rc1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/wrapt/Manifest b/dev-python/wrapt/Manifest
index 89cb32bdfc50..89cbb85c298b 100644
--- a/dev-python/wrapt/Manifest
+++ b/dev-python/wrapt/Manifest
@@ -1 +1,2 @@
DIST wrapt-1.16.0.gh.tar.gz 138520 BLAKE2B 6317f2fa58aaa017b510f60fb20e8b3bc4721977806f4b8e7a3f316bfa4da2a8d24156f8ab670d96f5bab6fcc29437d5d18c28ce91618f5a7093cc85d6c5b578 SHA512 65bdda3b6580748ceb720e8fc1a6b05832a355d541aa650bc87052f3aa8793d03d29a080b79eceb16392e297aed8f11a283e36f5f40a0db614b409b1dc2b6c9c
+DIST wrapt-1.17.0rc1.gh.tar.gz 140545 BLAKE2B 825b6c4e8d22af404ea0e0e586542be9ef8a302389ba683548e41d93adb2afdd33e61269a2d4d9a832eedc8d48c4a96076ac14d44d3c9617c241cf76910ee753 SHA512 833ba6a8e07b610bdf830bd6c1cac9140a94f35a18f19ea5aa52c3673323e11ce15f302cc38c1ed12d7f24c220540f30c43a8186bda6bb42609f68774cd8409b
diff --git a/dev-python/wrapt/wrapt-1.17.0_rc1.ebuild b/dev-python/wrapt/wrapt-1.17.0_rc1.ebuild
new file mode 100644
index 000000000000..10b0cdd3eb23
--- /dev/null
+++ b/dev-python/wrapt/wrapt-1.17.0_rc1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/_}
+DESCRIPTION="Module for decorators, wrappers and monkey patching"
+HOMEPAGE="
+ https://github.com/GrahamDumpleton/wrapt/
+ https://pypi.org/project/wrapt/
+"
+SRC_URI="
+ https://github.com/GrahamDumpleton/wrapt/archive/${PV/_}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+native-extensions"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+
+python_compile() {
+ local -x WRAPT_INSTALL_EXTENSIONS=$(usex native-extensions true false)
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}