summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-27 05:57:52 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-27 06:38:11 +0100
commitbb99a6f35f5295717b13bc78af017876a16d6a15 (patch)
treea4fa99f79666a19bdc225c33ffd8eaffe11917a2 /dev-python/wrapt
parentdev-python/pypdf: Bump to 3.5.0 (diff)
downloadgentoo-bb99a6f35f5295717b13bc78af017876a16d6a15.tar.gz
gentoo-bb99a6f35f5295717b13bc78af017876a16d6a15.tar.bz2
gentoo-bb99a6f35f5295717b13bc78af017876a16d6a15.zip
dev-python/wrapt: Bump to 1.15.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wrapt')
-rw-r--r--dev-python/wrapt/Manifest1
-rw-r--r--dev-python/wrapt/wrapt-1.15.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/wrapt/Manifest b/dev-python/wrapt/Manifest
index e3c349abfe4a..139040ecc8fd 100644
--- a/dev-python/wrapt/Manifest
+++ b/dev-python/wrapt/Manifest
@@ -1 +1,2 @@
DIST wrapt-1.14.1.gh.tar.gz 133767 BLAKE2B 407a9531f581b034be7fe4392dcbf94803aa9c3a82d7c392750dfef62a5cbb84582e292819bf749356fad2b6e98cc89777df0f3b0f4ca70422e75b72ad256711 SHA512 c67e99eb29afeefb2512fb545cd180b8e96f69235d6281edebe62ea5e411188a904a7e683afdda2d6a86cf8b7fd74f79a3c3bec04e19a7c5ef347729bb43f94c
+DIST wrapt-1.15.0.gh.tar.gz 137402 BLAKE2B 8c4764251a89f7795fef71dd71d9c36611d896d2e2791a5e7ce4f665f7b477e683f21aa05251a6ceb96644221a7ff9b01dfe98a7f4d278987dedc17ead39b343 SHA512 6be3fc6380e6bb11a26e35fb093ca54d2e851ab384682f6b1201599980c0429c1e2f23089540b66dd80985baaaf3fb93ce29034758e062e2cfb2f52e3b362779
diff --git a/dev-python/wrapt/wrapt-1.15.0.ebuild b/dev-python/wrapt/wrapt-1.15.0.ebuild
new file mode 100644
index 000000000000..1b7cfe7b88b0
--- /dev/null
+++ b/dev-python/wrapt/wrapt-1.15.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for decorators, wrappers and monkey patching"
+HOMEPAGE="
+ https://github.com/GrahamDumpleton/wrapt/
+ https://pypi.org/project/wrapt/
+"
+SRC_URI="
+ https://github.com/GrahamDumpleton/wrapt/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+
+python_compile() {
+ local -x WRAPT_INSTALL_EXTENSIONS=true
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}