summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-14 13:27:13 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-14 15:05:42 +0300
commit400022fd34aa2cef8613be7f98fe26c30afc5846 (patch)
tree81701be18ba8ee2193726a2bebffdad8f94945ae /dev-python/whoosh
parentdev-python/imagesize: enable py3.11 (diff)
downloadgentoo-400022fd34aa2cef8613be7f98fe26c30afc5846.tar.gz
gentoo-400022fd34aa2cef8613be7f98fe26c30afc5846.tar.bz2
gentoo-400022fd34aa2cef8613be7f98fe26c30afc5846.zip
dev-python/whoosh: EAPI=8, PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/whoosh')
-rw-r--r--dev-python/whoosh/whoosh-2.7.4-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/whoosh/whoosh-2.7.4-r2.ebuild b/dev-python/whoosh/whoosh-2.7.4-r2.ebuild
new file mode 100644
index 000000000000..6d53d20f60c6
--- /dev/null
+++ b/dev-python/whoosh/whoosh-2.7.4-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Fast, pure-Python full text indexing, search and spell checking library"
+HOMEPAGE="https://pypi.org/project/Whoosh/"
+SRC_URI="mirror://pypi/W/${PN^}/${P^}.tar.gz"
+S="${WORKDIR}/${P^}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-solaris"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.7.4-tests-specify-utf8.patch
+)
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # (backport from upstream)
+ sed -i -e '/cmdclass/s:pytest:PyTest:' setup.py || die
+ # fix old section name
+ sed -i -e 's@\[pytest\]@[tool:pytest]@' setup.cfg || die
+ # TODO: broken?
+ sed -i -e 's:test_minimize_dfa:_&:' tests/test_automata.py || die
+
+ distutils-r1_python_prepare_all
+}