summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-20 08:39:14 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-20 09:25:15 +0200
commit886650e214219068c7f156e91827302dcf94f970 (patch)
tree3a33ab767e22f2552672624369e923cee20df6b5 /dev-python/watchdog
parentdev-python/rich: Bump to 10.2.2 (diff)
downloadgentoo-886650e214219068c7f156e91827302dcf94f970.tar.gz
gentoo-886650e214219068c7f156e91827302dcf94f970.tar.bz2
gentoo-886650e214219068c7f156e91827302dcf94f970.zip
dev-python/watchdog: Bump to 2.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/watchdog')
-rw-r--r--dev-python/watchdog/Manifest1
-rw-r--r--dev-python/watchdog/watchdog-2.1.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/watchdog/Manifest b/dev-python/watchdog/Manifest
index d6acd9ca1d42..248a576b676e 100644
--- a/dev-python/watchdog/Manifest
+++ b/dev-python/watchdog/Manifest
@@ -3,3 +3,4 @@ DIST watchdog-2.0.2.tar.gz 95452 BLAKE2B e3a071cdf1c47698cd54bbaf925c4eb7e2af739
DIST watchdog-2.0.3.tar.gz 95524 BLAKE2B 568e9d66efbfa98c19dab704681dbc48f869b59d51d7c7ff7ce1fd7465efcc6233f871e7f9276f2732692645491f2fd197a639b17e9a3d8abb76d0148a934796 SHA512 e1c506e4ead8c3ee8d19e456b67623f3a1823007be6c1fad0d76c697205696183e7bd15e46c21bf61abce6dd16d267e55da8986633eeee337d10c609318fb958
DIST watchdog-2.1.0.tar.gz 95833 BLAKE2B f11eb7961885fd0fbf8e6f888a069d77d9ff26b245bd3583e9060044c43a3356d56a334108c8c1a11735fffa779cc750bc390dd1510cf2c549ec9fe064899540 SHA512 65cc291927a61506fd2c26e05b85112e1cc0f26ca851138c62dfa34fae7958ee2b3946ffe586a9d2b7a48d59a6b5ce11c8dac276a3d78dcbeca8da011a880668
DIST watchdog-2.1.1.tar.gz 96703 BLAKE2B cbcaff41de6111a3c9c2ff00b7c0a9ce1a769bb2b0f8e2af841a0783dd7f3a55f46003863b05eb983531211743fd112a6e63944193e10e8dd296523a1da27d59 SHA512 5b9eb75bc7b8642a8246f426a992265bbe2e5d82a3fcdd543289db7734701bdca1a868b02edfdc26ea239a89d80dd5322e410b949e419c66bdcc0645241d826b
+DIST watchdog-2.1.2.tar.gz 97407 BLAKE2B a847089409537391287a146670864c7721344ba8a6378c89483e9e08abe3f61690bfca48016f628ab0e6b0ff317679db3c72e27594e049ea03334dd20c305008 SHA512 2a127faffebb35f0b14d578570a4c5a7c27d6bd38042e34ea50f4b654be1ca07b193dfa72dfe25442d3e6da746f1cfbdda71c38be1386cc5a3e69204843c16f1
diff --git a/dev-python/watchdog/watchdog-2.1.2.ebuild b/dev-python/watchdog/watchdog-2.1.2.ebuild
new file mode 100644
index 000000000000..ab944b67adbb
--- /dev/null
+++ b/dev-python/watchdog/watchdog-2.1.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python API and shell utilities to monitor file system events"
+HOMEPAGE="https://github.com/gorakhargosh/watchdog"
+SRC_URI="https://github.com/gorakhargosh/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+CDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ dev-python/argh[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ test? (
+ >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/--cov/d' setup.cfg || die
+ default
+}
+
+python_test() {
+ local deselect=()
+ [[ ${EPYTHON} == pypy3 ]] && deselect+=(
+ tests/test_inotify_buffer.py::test_move_internal_batch
+ )
+
+ epytest -p no:django ${deselect[@]/#/--deselect }
+}
+
+pkg_postinst() {
+ optfeature "Bash completion" dev-python/argcomplete
+}