summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-30 06:52:24 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-30 07:02:38 +0200
commit2c0989cf9d01cca95e015ef01de6198b584a9c9d (patch)
tree5a0f1a1a8dca4a579ab60045d5d87b59b2df248d /dev-python/versioningit
parentdev-python/threadpoolctl: Bump to 3.5.0 (diff)
downloadgentoo-2c0989cf9d01cca95e015ef01de6198b584a9c9d.tar.gz
gentoo-2c0989cf9d01cca95e015ef01de6198b584a9c9d.tar.bz2
gentoo-2c0989cf9d01cca95e015ef01de6198b584a9c9d.zip
dev-python/versioningit: Bump to 3.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/versioningit')
-rw-r--r--dev-python/versioningit/Manifest1
-rw-r--r--dev-python/versioningit/versioningit-3.1.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/versioningit/Manifest b/dev-python/versioningit/Manifest
index 65a88a6d7cc8..75fda49f2ae0 100644
--- a/dev-python/versioningit/Manifest
+++ b/dev-python/versioningit/Manifest
@@ -1 +1,2 @@
DIST versioningit-3.1.0.tar.gz 215117 BLAKE2B d0fc7056cc59088ed0091bc20af540b39238ca33bc049ffb87978e48a605cbee69a2daf574ff9b3791b3d55b708adeaca877f1914b8d4d2106f76cfa33dea608 SHA512 d30ec0b2831ab3e77e51b3e41b542ef2e73838dd78a2b1bebb64db4f7fdb4c988299f7b9605c9ff884c130fe97b2491e1bb27866450346023b68dd1a2204e04d
+DIST versioningit-3.1.1.tar.gz 212882 BLAKE2B 786af766a5e85ea426dee02d1ae888b0a50712f9d154690302b3fdb1f4aa037a931612ad3f1f169a3d8f3481db09da895cf3ba7dcbc7d2f256b3b8622334e08e SHA512 f8e23834324f785b93668f4cb55d57885cf96e9ca16f1d6a06c3610dd00a79c018960fe52aff5fe4cc735b5fcec27be1ceb151a88e0e9a447cba750dd6956816
diff --git a/dev-python/versioningit/versioningit-3.1.1.ebuild b/dev-python/versioningit/versioningit-3.1.1.ebuild
new file mode 100644
index 000000000000..105eac3c72ec
--- /dev/null
+++ b/dev-python/versioningit/versioningit-3.1.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A setuptools plugin for versioning based on git tags"
+HOMEPAGE="
+ https://github.com/jwodder/versioningit/
+ https://pypi.org/project/versioningit/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-17.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ <dev-python/tomli-3[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # Tries to do wheel/pip installs
+ test/test_end2end.py
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -o addopts=
+}