summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-14 15:56:33 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-14 16:00:11 +0200
commitef500f638a05a0d5a8833a7b23100c772fe9dff5 (patch)
tree2acadc1235f85e1dff3e0d8dcaf10374b46e7ad0 /dev-python/uvloop
parentdev-python/uvloop: Skip crashing test (diff)
downloadgentoo-ef500f638a05a0d5a8833a7b23100c772fe9dff5.tar.gz
gentoo-ef500f638a05a0d5a8833a7b23100c772fe9dff5.tar.bz2
gentoo-ef500f638a05a0d5a8833a7b23100c772fe9dff5.zip
dev-python/uvloop: Bump to 0.18.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/uvloop')
-rw-r--r--dev-python/uvloop/Manifest1
-rw-r--r--dev-python/uvloop/uvloop-0.18.0.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/dev-python/uvloop/Manifest b/dev-python/uvloop/Manifest
index cc6d66efd06c..4df2666edcbe 100644
--- a/dev-python/uvloop/Manifest
+++ b/dev-python/uvloop/Manifest
@@ -1 +1,2 @@
DIST uvloop-0.17.0.tar.gz 2279973 BLAKE2B 7ccbf3b8e723e36c1010a70e256de0ad1a9728fe10b3538e05c57157b16ea7e5369347c855cd1460e49f89197ebb05628c4b6fcd7e50c623b1aaa5890ac64b5f SHA512 861d7f28ad879ecbfa40d53b9626e38660f02618fd433edbd5a8ea5100a17ade042a26549def04bc23f928aca3adc83d62503f0548038cd400284f5654003ee4
+DIST uvloop-0.18.0.tar.gz 2319264 BLAKE2B 9aeef9278ec97dce62458b3ce4833ef5beeb101d3feaf5b2e45d1ac05b2f40c21bcd6aa3135694c8b9dc9e8078cbd0c74d113784a10f94039f6bbeaf24b06f1f SHA512 1ce01f3e4fca15d1f76c71eb29abb608f6f65d6ebdb3f79ed7c63db5b96bb1325f7a7d97c3adbf8cdb2506907ad13a1c88c767fd3a143cd728f9153ec8958d0e
diff --git a/dev-python/uvloop/uvloop-0.18.0.ebuild b/dev-python/uvloop/uvloop-0.18.0.ebuild
new file mode 100644
index 000000000000..9c5ab1780086
--- /dev/null
+++ b/dev-python/uvloop/uvloop-0.18.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Ultra-fast implementation of asyncio event loop on top of libuv"
+HOMEPAGE="
+ https://github.com/magicstack/uvloop/
+ https://pypi.org/project/uvloop/
+"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 -riscv ~sparc ~x86"
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+
+DEPEND="
+ >=dev-libs/libuv-1.11.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ <dev-python/cython-3[${PYTHON_USEDEP}]
+ >=dev-python/cython-0.29.32[${PYTHON_USEDEP}]
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-22.0.0[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ rm -r vendor || die
+ cat <<-EOF >> setup.cfg || die
+ [build_ext]
+ use_system_libuv=True
+ cython_always=True
+ EOF
+
+ # flake8 only
+ #rm tests/test_sourcecode.py || die
+ # force cythonization
+ rm uvloop/loop.c || die
+ # hangs
+ #sed -i -e 's:test_remote_shutdown_receives_trailing_data:_&:' \
+ # tests/test_tcp.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local EPYTEST_IGNORE=(
+ # linting
+ tests/test_sourcecode.py
+ )
+ local EPYTEST_DESELECT=(
+ # TODO: expects some... cython_helper?
+ tests/test_libuv_api.py::Test_UV_libuv::test_libuv_get_loop_t_ptr
+ # unhappy about sandbox injecting its envvars
+ tests/test_process.py::Test_UV_Process::test_process_env_2
+ tests/test_process.py::Test_AIO_Process::test_process_env_2
+ # hangs
+ tests/test_tcp.py::Test_AIO_TCPSSL::test_remote_shutdown_receives_trailing_data
+ # crashes on assertion
+ # https://github.com/MagicStack/uvloop/issues/574
+ tests/test_cython.py::TestCythonIntegration::test_cython_coro_is_coroutine
+ )
+
+ rm -rf uvloop || die
+ epytest -s
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}